at_spi2_tool is now in path'ed directory
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %bcond_with x
2
3 Name: at-spi2-core
4 Version: 2.31.1
5 Release: 0
6 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
7 License: LGPL-2.0+
8 Group: System/Libraries
9 Url: http://www.gnome.org/
10 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.31/%{name}-%{version}.tar.xz
11 Source1001:    %{name}.manifest
12 Requires:      dbus
13 BuildRequires: python-devel
14 BuildRequires: python-xml
15 BuildRequires: intltool
16 BuildRequires: dbus-devel
17 BuildRequires: glib2-devel
18 BuildRequires: gettext
19 BuildRequires: gtk-doc
20 %if %{with x}
21 BuildRequires: libX11-devel
22 BuildRequires: libXtst-devel
23 BuildRequires: libXi-devel
24 %endif
25 BuildRequires: pkgconfig(vconf)
26 BuildRequires: pkgconfig(appsvc)
27 BuildRequires: pkgconfig(dlog)
28 BuildRequires: pkgconfig(aul)
29 BuildRequires: gobject-introspection
30 BuildRequires: meson
31 BuildRequires: app-svc-devel
32
33 %description
34 AT-SPI is a general interface for applications to make use of the
35 accessibility toolkit. This version is based on dbus.
36
37 This package contains the AT-SPI registry daemon. It provides a
38 mechanism for all assistive technologies to discover and interact
39 with applications running on the desktop.
40
41 %package -n libatspi0
42 Summary: An Accessibility ToolKit -- Library
43 Group: System/Libraries
44
45 %description -n libatspi0
46 AT-SPI is a general interface for applications to make use of the
47 accessibility toolkit. This version is based on dbus.
48
49 %package -n typelib-1_0-Atspi-2_0
50 Summary: An Accessibility ToolKit -- Introspection bindings
51 Group: System/Libraries
52
53 %description -n typelib-1_0-Atspi-2_0
54 AT-SPI is a general interface for applications to make use of the
55 accessibility toolkit. This version is based on dbus.
56
57 This package provides the GObject Introspection bindings for the
58 libatspi library.
59
60 %package devel
61 Summary: Include Files and Libraries mandatory for Development
62 Group: Development/Libraries
63 Requires: %{name} = %{version}
64 Requires: libatspi0 = %{version}
65 Requires: typelib-1_0-Atspi-2_0 = %{version}
66
67 %description devel
68 This package contains all necessary include files and libraries needed
69 to develop applications that require these.
70
71 %prep
72 %setup -q
73 cp %{SOURCE1001} .
74
75 %build
76 meson --prefix /usr/ build -Dwith-dbus-daemondir=%{_bindir} -Ddbus_daemon=/usr/bin/dbus-daemon \
77 %if !%{with x}
78         -Denable-x11=no \
79 %else
80         -Denable-x11=yes \
81 %endif
82         -Denable-static=no
83
84 ninja -C build all
85
86 %install
87 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
88
89 export DESTDIR=%{buildroot}
90 ninja -C build install
91
92 %find_lang %{name}
93
94 %clean
95 rm -fr %{buildroot}
96
97 %post -n libatspi0 -p /sbin/ldconfig
98
99 %postun -n libatspi0 -p /sbin/ldconfig
100
101 %files -f %{name}.lang
102 %manifest %{name}.manifest
103 %defattr(-,root,root)
104 %{_bindir}/at_spi2_tool
105
106 %doc AUTHORS README
107 %license COPYING
108 %{_libexecdir}/at-spi-bus-launcher
109 %{_libexecdir}/at-spi2-registryd
110 %{_datadir}/defaults/at-spi2/accessibility.conf
111 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
112 %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
113 %{_datadir}/dbus-1/services/org.a11y.Bus.service
114 %{_prefix}/lib/systemd/user/at-spi-dbus-bus.service
115 %files -n libatspi0
116 %manifest %{name}.manifest
117 %defattr(-, root, root)
118 %{_libdir}/libatspi.so.0*
119
120 %files -n typelib-1_0-Atspi-2_0
121 %manifest %{name}.manifest
122 %defattr(-, root, root)
123
124 %files devel
125 %manifest %{name}.manifest
126 %defattr(-, root, root)
127 %{_includedir}/at-spi-2.0
128 %{_libdir}/libatspi.so
129 %{_libdir}/pkgconfig/atspi-2.pc