Some conditions added to build also on wayland
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %define debug_package %{nil}
2 %bcond_with x
3
4 Name: at-spi2-core
5 Version: 2.16.0
6 Release: 0
7 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
8 License: LGPL-2.0+
9 Group: System/Libraries
10 Url: http://www.gnome.org/
11 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.16/%{name}-%{version}.tar.xz
12 Source1001:    %{name}.manifest
13 Requires:      dbus
14 BuildRequires: python-devel
15 BuildRequires: python-xml
16 BuildRequires: intltool
17 BuildRequires: dbus-devel
18 BuildRequires: glib2-devel
19 BuildRequires: gettext
20 BuildRequires: gtk-doc
21 %if %{with x}
22 BuildRequires: libX11-devel
23 BuildRequires: libXtst-devel
24 BuildRequires: libXi-devel
25 %endif
26
27 %description
28 AT-SPI is a general interface for applications to make use of the
29 accessibility toolkit. This version is based on dbus.
30
31 This package contains the AT-SPI registry daemon. It provides a
32 mechanism for all assistive technologies to discover and interact
33 with applications running on the desktop.
34
35 %package -n libatspi0
36 Summary: An Accessibility ToolKit -- Library
37 Group: System/Libraries
38
39 %description -n libatspi0
40 AT-SPI is a general interface for applications to make use of the
41 accessibility toolkit. This version is based on dbus.
42
43 %package -n typelib-1_0-Atspi-2_0
44 Summary: An Accessibility ToolKit -- Introspection bindings
45 Group: System/Libraries
46
47 %description -n typelib-1_0-Atspi-2_0
48 AT-SPI is a general interface for applications to make use of the
49 accessibility toolkit. This version is based on dbus.
50
51 This package provides the GObject Introspection bindings for the
52 libatspi library.
53
54 %package devel
55 Summary: Include Files and Libraries mandatory for Development
56 Group: Development/Libraries
57 Requires: %{name} = %{version}
58 Requires: libatspi0 = %{version}
59 Requires: typelib-1_0-Atspi-2_0 = %{version}
60
61 %description devel
62 This package contains all necessary include files and libraries needed
63 to develop applications that require these.
64
65 %prep
66 %setup -q
67 cp %{SOURCE1001} .
68
69 %build
70 %autogen --libexecdir=%{_libexecdir}/at-spi2 \
71         --with-dbus-daemondir=%{_bindir} \
72 %if !%{with x}
73         --disable-x11 \
74 %endif
75         --disable-static
76 %__make %{?_smp_flags}
77
78 %install
79 rm -rf %{buildroot}
80 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
81 %make_install
82 %find_lang %{name}
83
84 %check
85 mkdir -p %{buildroot}/usr/share/license
86 cp -f COPYING %{buildroot}/usr/share/license/%{name}
87
88 %clean
89 rm -fr %{buildroot}
90
91 %post -n libatspi0 -p /sbin/ldconfig
92
93 %postun -n libatspi0 -p /sbin/ldconfig
94
95 %files -f %{name}.lang
96 %manifest %{name}.manifest
97 %defattr(-,root,root)
98 %doc AUTHORS README
99 %license COPYING
100 %{_libexecdir}/at-spi2/at-spi-bus-launcher
101 %{_libexecdir}/at-spi2/at-spi2-registryd
102 %config %{_sysconfdir}/at-spi2/accessibility.conf
103 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
104 %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
105 %{_datadir}/dbus-1/services/org.a11y.Bus.service
106
107
108 %files -n libatspi0
109 %manifest %{name}.manifest
110 %defattr(-, root, root)
111 %{_libdir}/libatspi.so.0*
112
113 %files -n typelib-1_0-Atspi-2_0
114 %manifest %{name}.manifest
115 %defattr(-, root, root)
116
117 %files devel
118 %manifest %{name}.manifest
119 %defattr(-, root, root)
120 %{_includedir}/at-spi-2.0
121 %{_libdir}/libatspi.so
122 %{_libdir}/pkgconfig/atspi-2.pc
123