Build DEBUG package
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %bcond_with x
2
3 Name: at-spi2-core
4 Version: 2.16.1
5 Release: 0
6 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
7 License: LGPL-2.0+
8 Group: System/Libraries
9 Url: http://www.gnome.org/
10 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.16/%{name}-%{version}.tar.xz
11 Source1001:    %{name}.manifest
12 Requires:      dbus
13 BuildRequires: python-devel
14 BuildRequires: python-xml
15 BuildRequires: intltool
16 BuildRequires: dbus-devel
17 BuildRequires: glib2-devel
18 BuildRequires: gettext
19 BuildRequires: gtk-doc
20 %if %{with x}
21 BuildRequires: libX11-devel
22 BuildRequires: libXtst-devel
23 BuildRequires: libXi-devel
24 %endif
25 BuildRequires: pkgconfig(vconf)
26 BuildRequires: pkgconfig(appsvc)
27 BuildRequires: pkgconfig(dlog)
28 BuildRequires: pkgconfig(aul)
29
30 %description
31 AT-SPI is a general interface for applications to make use of the
32 accessibility toolkit. This version is based on dbus.
33
34 This package contains the AT-SPI registry daemon. It provides a
35 mechanism for all assistive technologies to discover and interact
36 with applications running on the desktop.
37
38 %package -n libatspi0
39 Summary: An Accessibility ToolKit -- Library
40 Group: System/Libraries
41
42 %description -n libatspi0
43 AT-SPI is a general interface for applications to make use of the
44 accessibility toolkit. This version is based on dbus.
45
46 %package -n typelib-1_0-Atspi-2_0
47 Summary: An Accessibility ToolKit -- Introspection bindings
48 Group: System/Libraries
49
50 %description -n typelib-1_0-Atspi-2_0
51 AT-SPI is a general interface for applications to make use of the
52 accessibility toolkit. This version is based on dbus.
53
54 This package provides the GObject Introspection bindings for the
55 libatspi library.
56
57 %package devel
58 Summary: Include Files and Libraries mandatory for Development
59 Group: Development/Libraries
60 Requires: %{name} = %{version}
61 Requires: libatspi0 = %{version}
62 Requires: typelib-1_0-Atspi-2_0 = %{version}
63
64 %description devel
65 This package contains all necessary include files and libraries needed
66 to develop applications that require these.
67
68 %prep
69 %setup -q
70 cp %{SOURCE1001} .
71
72 %build
73 %autogen --libexecdir=%{_libexecdir}/at-spi2 \
74         --with-dbus-daemondir=%{_bindir} \
75 %if !%{with x}
76         --disable-x11 \
77 %endif
78         --disable-static
79 %__make %{?_smp_flags}
80
81 %install
82 rm -rf %{buildroot}
83 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
84
85 %make_install
86 %find_lang %{name}
87
88 %clean
89 rm -fr %{buildroot}
90
91 %post -n libatspi0 -p /sbin/ldconfig
92
93 %postun -n libatspi0 -p /sbin/ldconfig
94
95 %files -f %{name}.lang
96 %manifest %{name}.manifest
97 %defattr(-,root,root)
98 %{_bindir}/at_spi2_tool
99
100 %doc AUTHORS README
101 %license COPYING
102 %{_libexecdir}/at-spi2/at-spi-bus-launcher
103 %{_libexecdir}/at-spi2/at-spi2-registryd
104 %config %{_sysconfdir}/at-spi2/accessibility.conf
105 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
106 %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
107 %{_datadir}/dbus-1/services/org.a11y.Bus.service
108
109 %files -n libatspi0
110 %manifest %{name}.manifest
111 %defattr(-, root, root)
112 %{_libdir}/libatspi.so.0*
113
114 %files -n typelib-1_0-Atspi-2_0
115 %manifest %{name}.manifest
116 %defattr(-, root, root)
117
118 %files devel
119 %manifest %{name}.manifest
120 %defattr(-, root, root)
121 %{_includedir}/at-spi-2.0
122 %{_libdir}/libatspi.so
123 %{_libdir}/pkgconfig/atspi-2.pc