Bump package version to 2.16
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %define debug_package %{nil}
2 %bcond_with x
3
4 Name: at-spi2-core
5 Version: 2.16.0
6 Release: 0
7 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
8 License: LGPL-2.0+
9 Group: System/Libraries
10 Url: http://www.gnome.org/
11 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.16/%{name}-%{version}.tar.xz
12 Source1001:    %{name}.manifest
13 Requires:      dbus
14 BuildRequires: python-devel
15 BuildRequires: python-xml
16 BuildRequires: intltool
17 BuildRequires: dbus-devel
18 BuildRequires: glib2-devel
19 BuildRequires: gettext
20 BuildRequires: gtk-doc
21 %if !%{with x}
22 ExclusiveArch:
23 %endif
24 BuildRequires: libX11-devel
25 BuildRequires: libXtst-devel
26 BuildRequires: libXi-devel
27
28 %description
29 AT-SPI is a general interface for applications to make use of the
30 accessibility toolkit. This version is based on dbus.
31
32 This package contains the AT-SPI registry daemon. It provides a
33 mechanism for all assistive technologies to discover and interact
34 with applications running on the desktop.
35
36 %package -n libatspi0
37 Summary: An Accessibility ToolKit -- Library
38 Group: System/Libraries
39
40 %description -n libatspi0
41 AT-SPI is a general interface for applications to make use of the
42 accessibility toolkit. This version is based on dbus.
43
44 %package -n typelib-1_0-Atspi-2_0
45 Summary: An Accessibility ToolKit -- Introspection bindings
46 Group: System/Libraries
47
48 %description -n typelib-1_0-Atspi-2_0
49 AT-SPI is a general interface for applications to make use of the
50 accessibility toolkit. This version is based on dbus.
51
52 This package provides the GObject Introspection bindings for the
53 libatspi library.
54
55 %package devel
56 Summary: Include Files and Libraries mandatory for Development
57 Group: Development/Libraries
58 Requires: %{name} = %{version}
59 Requires: libatspi0 = %{version}
60 Requires: typelib-1_0-Atspi-2_0 = %{version}
61
62 %description devel
63 This package contains all necessary include files and libraries needed
64 to develop applications that require these.
65
66 %prep
67 %setup -q
68 cp %{SOURCE1001} .
69
70 %build
71 %autogen --libexecdir=%{_libexecdir}/at-spi2 \
72         --with-dbus-daemondir=%{_bindir} \
73         --disable-static
74 %__make %{?_smp_flags}
75
76 %install
77 rm -rf %{buildroot}
78 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
79 %make_install
80 %find_lang %{name}
81
82 %check
83 mkdir -p %{buildroot}/usr/share/license
84 cp -f COPYING %{buildroot}/usr/share/license/%{name}
85
86 %clean
87 rm -fr %{buildroot}
88
89 %post -n libatspi0 -p /sbin/ldconfig
90
91 %postun -n libatspi0 -p /sbin/ldconfig
92
93 %files -f %{name}.lang
94 %manifest %{name}.manifest
95 %defattr(-,root,root)
96 %doc AUTHORS README
97 %license COPYING
98 %{_libexecdir}/at-spi2/at-spi-bus-launcher
99 %{_libexecdir}/at-spi2/at-spi2-registryd
100 %config %{_sysconfdir}/at-spi2/accessibility.conf
101 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
102 %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
103 %{_datadir}/dbus-1/services/org.a11y.Bus.service
104
105
106 %files -n libatspi0
107 %manifest %{name}.manifest
108 %defattr(-, root, root)
109 %{_libdir}/libatspi.so.0*
110
111 %files -n typelib-1_0-Atspi-2_0
112 %manifest %{name}.manifest
113 %defattr(-, root, root)
114
115 %files devel
116 %manifest %{name}.manifest
117 %defattr(-, root, root)
118 %{_includedir}/at-spi-2.0
119 %{_libdir}/libatspi.so
120 %{_libdir}/pkgconfig/atspi-2.pc
121