892fabd9f8a658e1c12990aafaf3c8515d222723
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %define debug_package %{nil}
2 %bcond_with x
3
4 Name: at-spi2-core
5 Version: 2.16.0
6 Release: 0
7 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
8 #License: LGPL-2.0+
9 License: %{_builddir}/%{buildsubdir}/COPYING
10 Group: System/Libraries
11 Url: http://www.gnome.org/
12 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.16/%{name}-%{version}.tar.xz
13 Source1001:    %{name}.manifest
14 Requires:      dbus
15 BuildRequires: python-devel
16 BuildRequires: python-xml
17 BuildRequires: intltool
18 BuildRequires: dbus-devel
19 BuildRequires: glib2-devel
20 BuildRequires: gettext
21 BuildRequires: gtk-doc
22 %if %{with x}
23 BuildRequires: libX11-devel
24 BuildRequires: libXtst-devel
25 BuildRequires: libXi-devel
26 %endif
27 BuildRequires: pkgconfig(vconf)
28 BuildRequires: pkgconfig(appsvc)
29 BuildRequires: pkgconfig(dlog)
30 BuildRequires: pkgconfig(aul)
31
32 %description
33 AT-SPI is a general interface for applications to make use of the
34 accessibility toolkit. This version is based on dbus.
35
36 This package contains the AT-SPI registry daemon. It provides a
37 mechanism for all assistive technologies to discover and interact
38 with applications running on the desktop.
39
40 %package -n libatspi0
41 Summary: An Accessibility ToolKit -- Library
42 Group: System/Libraries
43
44 %description -n libatspi0
45 AT-SPI is a general interface for applications to make use of the
46 accessibility toolkit. This version is based on dbus.
47
48 %package -n typelib-1_0-Atspi-2_0
49 Summary: An Accessibility ToolKit -- Introspection bindings
50 Group: System/Libraries
51
52 %description -n typelib-1_0-Atspi-2_0
53 AT-SPI is a general interface for applications to make use of the
54 accessibility toolkit. This version is based on dbus.
55
56 This package provides the GObject Introspection bindings for the
57 libatspi library.
58
59 %package devel
60 Summary: Include Files and Libraries mandatory for Development
61 Group: Development/Libraries
62 Requires: %{name} = %{version}
63 Requires: libatspi0 = %{version}
64 Requires: typelib-1_0-Atspi-2_0 = %{version}
65
66 %description devel
67 This package contains all necessary include files and libraries needed
68 to develop applications that require these.
69
70 %prep
71 %setup -q
72 cp %{SOURCE1001} .
73
74 %build
75 %autogen --libexecdir=%{_libexecdir}/at-spi2 \
76         --with-dbus-daemondir=%{_bindir} \
77 %if !%{with x}
78         --disable-x11 \
79 %endif
80         --disable-static
81 %__make %{?_smp_flags}
82
83 %install
84 rm -rf %{buildroot}
85 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
86 %make_install
87 %find_lang %{name}
88
89 %check
90
91 %clean
92 rm -fr %{buildroot}
93
94 %post -n libatspi0 -p /sbin/ldconfig
95
96 %postun -n libatspi0 -p /sbin/ldconfig
97
98 %files -f %{name}.lang
99 %manifest %{name}.manifest
100 %defattr(-,root,root)
101 %doc AUTHORS README
102 #%license COPYING
103 %{_libexecdir}/at-spi2/at-spi-bus-launcher
104 %{_libexecdir}/at-spi2/at-spi2-registryd
105 %config %{_sysconfdir}/at-spi2/accessibility.conf
106 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
107 %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
108 %{_datadir}/dbus-1/services/org.a11y.Bus.service
109
110 %files -n libatspi0
111 %manifest %{name}.manifest
112 %defattr(-, root, root)
113 %{_libdir}/libatspi.so.0*
114
115 %files -n typelib-1_0-Atspi-2_0
116 %manifest %{name}.manifest
117 %defattr(-, root, root)
118
119 %files devel
120 %manifest %{name}.manifest
121 %defattr(-, root, root)
122 %{_includedir}/at-spi-2.0
123 %{_libdir}/libatspi.so
124 %{_libdir}/pkgconfig/atspi-2.pc
125