Merge upstream branch 2.31.1 into branch origin/tizen
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %bcond_with x
2
3 Name: at-spi2-core
4 Version: 2.31.1
5 Release: 0
6 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
7 License: LGPL-2.0+
8 Group: System/Libraries
9 Url: http://www.gnome.org/
10 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.31/%{name}-%{version}.tar.xz
11 Source1001:    %{name}.manifest
12 Requires:      dbus
13 BuildRequires: python-devel
14 BuildRequires: python-xml
15 BuildRequires: intltool
16 BuildRequires: dbus-devel
17 BuildRequires: glib2-devel
18 BuildRequires: gettext
19 BuildRequires: gtk-doc
20 %if %{with x}
21 BuildRequires: libX11-devel
22 BuildRequires: libXtst-devel
23 BuildRequires: libXi-devel
24 %endif
25 BuildRequires: pkgconfig(vconf)
26 BuildRequires: pkgconfig(appsvc)
27 BuildRequires: pkgconfig(dlog)
28 BuildRequires: pkgconfig(aul)
29 BuildRequires: gobject-introspection
30 BuildRequires: meson
31 BuildRequires: app-svc-devel
32
33 %description
34 AT-SPI is a general interface for applications to make use of the
35 accessibility toolkit. This version is based on dbus.
36
37 This package contains the AT-SPI registry daemon. It provides a
38 mechanism for all assistive technologies to discover and interact
39 with applications running on the desktop.
40
41 %package -n libatspi0
42 Summary: An Accessibility ToolKit -- Library
43 Group: System/Libraries
44
45 %description -n libatspi0
46 AT-SPI is a general interface for applications to make use of the
47 accessibility toolkit. This version is based on dbus.
48
49 %package -n typelib-1_0-Atspi-2_0
50 Summary: An Accessibility ToolKit -- Introspection bindings
51 Group: System/Libraries
52
53 %description -n typelib-1_0-Atspi-2_0
54 AT-SPI is a general interface for applications to make use of the
55 accessibility toolkit. This version is based on dbus.
56
57 This package provides the GObject Introspection bindings for the
58 libatspi library.
59
60 %package devel
61 Summary: Include Files and Libraries mandatory for Development
62 Group: Development/Libraries
63 Requires: %{name} = %{version}
64 Requires: libatspi0 = %{version}
65 Requires: typelib-1_0-Atspi-2_0 = %{version}
66
67 %description devel
68 This package contains all necessary include files and libraries needed
69 to develop applications that require these.
70
71 %prep
72 %setup -q
73 cp %{SOURCE1001} .
74
75 %build
76 meson build -Dwith-dbus-daemondir=%{_bindir} \
77 %if !%{with x}
78         -Denable-x11=no \
79 %else
80         -Denable-x11=yes \
81 %endif
82         -Denable-static=no
83
84 (cd build && ninja)
85
86 %install
87 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
88
89 (cd build && DESTDIR=%{buildroot} ninja install)
90 %find_lang %{name}
91
92 %clean
93 rm -fr %{buildroot}
94
95 %post -n libatspi0 -p /sbin/ldconfig
96
97 %postun -n libatspi0 -p /sbin/ldconfig
98
99 %files -f %{name}.lang
100 %manifest %{name}.manifest
101 %defattr(-,root,root)
102 /usr/local/libexec/at_spi2_tool
103
104 %doc AUTHORS README
105 %license COPYING
106 /usr/local/libexec/at-spi-bus-launcher
107 /usr/local/libexec/at-spi2-registryd
108 /usr/local/share/defaults/at-spi2/accessibility.conf
109 /usr/local/etc/xdg/autostart/at-spi-dbus-bus.desktop
110 /usr/local/share/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
111 /usr/local/share/dbus-1/services/org.a11y.Bus.service
112 /usr/local/lib/systemd/user/at-spi-dbus-bus.service
113 %files -n libatspi0
114 %manifest %{name}.manifest
115 %defattr(-, root, root)
116 /usr/local/lib/libatspi.so.0*
117
118 %files -n typelib-1_0-Atspi-2_0
119 %manifest %{name}.manifest
120 %defattr(-, root, root)
121
122 %files devel
123 %manifest %{name}.manifest
124 %defattr(-, root, root)
125 /usr/local/include/at-spi-2.0
126 /usr/local/lib/libatspi.so
127 /usr/local/lib/pkgconfig/atspi-2.pc