spec file, manifest and gbs.conf adapted for Tizen
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %define debug_package %{nil}
2
3 Name: at-spi2-core
4 Version: 2_12_0
5 Release: 0
6 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
7 License: LGPL-2.0+
8 Group: System/Libraries
9 Url: http://www.gnome.org/
10 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.12/%{name}-%{version}.tar.xz
11 Source1001:    %{name}.manifest
12 Requires:      dbus
13 BuildRequires: python-devel
14 BuildRequires: python-xml
15 BuildRequires: intltool
16 BuildRequires: dbus-devel
17 BuildRequires: glib2-devel
18 BuildRequires: libX11-devel
19 BuildRequires: libXtst-devel
20 BuildRequires: libXi-devel
21 BuildRequires: gettext
22 BuildRequires: gtk-doc
23
24 %description
25 AT-SPI is a general interface for applications to make use of the
26 accessibility toolkit. This version is based on dbus.
27
28 This package contains the AT-SPI registry daemon. It provides a
29 mechanism for all assistive technologies to discover and interact
30 with applications running on the desktop.
31
32 %package -n libatspi0
33 Summary: An Accessibility ToolKit -- Library
34 Group: System/Libraries
35
36 %description -n libatspi0
37 AT-SPI is a general interface for applications to make use of the
38 accessibility toolkit. This version is based on dbus.
39
40 %package -n typelib-1_0-Atspi-2_0
41 Summary: An Accessibility ToolKit -- Introspection bindings
42 Group: System/Libraries
43
44 %description -n typelib-1_0-Atspi-2_0
45 AT-SPI is a general interface for applications to make use of the
46 accessibility toolkit. This version is based on dbus.
47
48 This package provides the GObject Introspection bindings for the
49 libatspi library.
50
51 %package devel
52 Summary: Include Files and Libraries mandatory for Development
53 Group: Development/Libraries
54 Requires: %{name} = %{version}
55 Requires: libatspi0 = %{version}
56 Requires: typelib-1_0-Atspi-2_0 = %{version}
57
58 %description devel
59 This package contains all necessary include files and libraries needed
60 to develop applications that require these.
61
62 %prep
63 %setup -q
64 cp %{SOURCE1001} .
65
66 %build
67 %autogen --libexecdir=%{_libexecdir}/at-spi2 \
68         --with-dbus-daemondir=%{_bindir} \
69         --disable-static
70 %__make %{?_smp_flags}
71
72 %install
73 rm -rf %{buildroot}
74 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
75 %make_install
76 %find_lang %{name}
77
78 %check
79 mkdir -p %{buildroot}/usr/share/license
80 cp -f COPYING %{buildroot}/usr/share/license/%{name}
81
82 %clean
83 rm -fr %{buildroot}
84
85 %post -n libatspi0 -p /sbin/ldconfig
86
87 %postun -n libatspi0 -p /sbin/ldconfig
88
89 %files -f %{name}.lang
90 %manifest %{name}.manifest
91 %defattr(-,root,root)
92 %doc AUTHORS README
93 %license COPYING
94 %{_libexecdir}/at-spi2/at-spi-bus-launcher
95 %{_libexecdir}/at-spi2/at-spi2-registryd
96 %config %{_sysconfdir}/at-spi2/accessibility.conf
97 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
98 %{_datadir}/dbus-1/services/org.a11y.atspi.Registry.service
99 %{_datadir}/dbus-1/services/org.a11y.Bus.service
100
101
102 %files -n libatspi0
103 %manifest %{name}.manifest
104 %defattr(-, root, root)
105 %{_libdir}/libatspi.so.0*
106
107 %files -n typelib-1_0-Atspi-2_0
108 %manifest %{name}.manifest
109 %defattr(-, root, root)
110
111 %files devel
112 %manifest %{name}.manifest
113 %defattr(-, root, root)
114 %{_includedir}/at-spi-2.0
115 %{_libdir}/libatspi.so
116 %{_libdir}/pkgconfig/atspi-2.pc
117