[LICENSE] apply SPDX license to spec file
[platform/upstream/at-spi2-core.git] / packaging / at-spi2-core.spec
1 %define debug_package %{nil}
2 %bcond_with x
3
4 Name: at-spi2-core
5 Version: 2.16.0
6 Release: 0
7 Summary: Assistive Technology Service Provider Interface - D-Bus based implementation
8 License: LGPL-2.0+
9 Group: System/Libraries
10 Url: http://www.gnome.org/
11 Source: http://ftp.gnome.org/pub/GNOME/sources/at-spi2-core/2.16/%{name}-%{version}.tar.xz
12 Source1001:    %{name}.manifest
13 Requires:      dbus
14 BuildRequires: python-devel
15 BuildRequires: python-xml
16 BuildRequires: intltool
17 BuildRequires: dbus-devel
18 BuildRequires: glib2-devel
19 BuildRequires: gettext
20 BuildRequires: gtk-doc
21 %if %{with x}
22 BuildRequires: libX11-devel
23 BuildRequires: libXtst-devel
24 BuildRequires: libXi-devel
25 %endif
26 BuildRequires: pkgconfig(vconf)
27 BuildRequires: pkgconfig(appsvc)
28 BuildRequires: pkgconfig(dlog)
29 BuildRequires: pkgconfig(aul)
30
31 %description
32 AT-SPI is a general interface for applications to make use of the
33 accessibility toolkit. This version is based on dbus.
34
35 This package contains the AT-SPI registry daemon. It provides a
36 mechanism for all assistive technologies to discover and interact
37 with applications running on the desktop.
38
39 %package -n libatspi0
40 Summary: An Accessibility ToolKit -- Library
41 Group: System/Libraries
42
43 %description -n libatspi0
44 AT-SPI is a general interface for applications to make use of the
45 accessibility toolkit. This version is based on dbus.
46
47 %package -n typelib-1_0-Atspi-2_0
48 Summary: An Accessibility ToolKit -- Introspection bindings
49 Group: System/Libraries
50
51 %description -n typelib-1_0-Atspi-2_0
52 AT-SPI is a general interface for applications to make use of the
53 accessibility toolkit. This version is based on dbus.
54
55 This package provides the GObject Introspection bindings for the
56 libatspi library.
57
58 %package devel
59 Summary: Include Files and Libraries mandatory for Development
60 Group: Development/Libraries
61 Requires: %{name} = %{version}
62 Requires: libatspi0 = %{version}
63 Requires: typelib-1_0-Atspi-2_0 = %{version}
64
65 %description devel
66 This package contains all necessary include files and libraries needed
67 to develop applications that require these.
68
69 %prep
70 %setup -q
71 cp %{SOURCE1001} .
72
73 %build
74 %autogen --libexecdir=%{_libexecdir}/at-spi2 \
75         --with-dbus-daemondir=%{_bindir} \
76 %if !%{with x}
77         --disable-x11 \
78 %endif
79         --disable-static
80 %__make %{?_smp_flags}
81
82 %install
83 rm -rf %{buildroot}
84 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
85 %make_install
86 %find_lang %{name}
87 mkdir -p %{buildroot}/%{_datadir}/usr/share/license
88 cp -f %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{_datadir}/usr/share/license/%{name}
89
90 %check
91
92 %clean
93 rm -fr %{buildroot}
94
95 %post -n libatspi0 -p /sbin/ldconfig
96
97 %postun -n libatspi0 -p /sbin/ldconfig
98
99 %files -f %{name}.lang
100 %manifest %{name}.manifest
101 %defattr(-,root,root)
102 %doc AUTHORS README
103 #%license COPYING
104 %{_libexecdir}/at-spi2/at-spi-bus-launcher
105 %{_libexecdir}/at-spi2/at-spi2-registryd
106 %config %{_sysconfdir}/at-spi2/accessibility.conf
107 %{_sysconfdir}/xdg/autostart/at-spi-dbus-bus.desktop
108 %{_datadir}/dbus-1/accessibility-services/org.a11y.atspi.Registry.service
109 %{_datadir}/dbus-1/services/org.a11y.Bus.service
110 %{_datadir}/usr/share/license/%{name}
111
112 %files -n libatspi0
113 %manifest %{name}.manifest
114 %defattr(-, root, root)
115 %{_libdir}/libatspi.so.0*
116
117 %files -n typelib-1_0-Atspi-2_0
118 %manifest %{name}.manifest
119 %defattr(-, root, root)
120
121 %files devel
122 %manifest %{name}.manifest
123 %defattr(-, root, root)
124 %{_includedir}/at-spi-2.0
125 %{_libdir}/libatspi.so
126 %{_libdir}/pkgconfig/atspi-2.pc
127