Update spec for changing license to MIT
[platform/upstream/alure.git] / packaging / alure.spec
1 Name:           alure
2 Version:        1.2
3 Release:        1
4 License:        MIT
5 Summary:        File-loading and utility functions for OpenAL
6 Group:          System Environment/Libraries
7 URL:            http://kcat.strangesoft.net/alure.html
8 Group:          System/Libraries
9 Source:         %{name}-%{version}.tar.bz2
10 Source1001:     alure.manifest
11 BuildRequires:  cmake, libsndfile-devel, openal-soft-devel
12
13 %description
14 ALURE is a utility library to help manage common tasks with OpenAL applications
15
16 %package devel
17 Summary:        Development files for %{name}
18 Group:          Development/Libraries
19 Requires:       %{name} = %{version}
20 Requires:       pkgconfig
21
22 %description devel
23 ALURE is a utility library to help manage common tasks with OpenAL applications
24
25 %prep
26 %setup -q
27 cp %{SOURCE1001} .
28
29 %build
30
31 %cmake .
32 make %{?_smp_mflags}
33
34 %install
35 %make_install
36
37 %post -p /sbin/ldconfig
38
39 %postun -p /sbin/ldconfig
40
41
42 %files
43 %defattr(-,root,root,-)
44 %manifest %{name}.manifest
45 %license COPYING
46 %{_libdir}/libalure.so.*
47 %{_bindir}/alure*
48
49 %files devel
50 %defattr(-,root,root,-)
51 %manifest %{name}.manifest
52 %exclude /usr/share/doc/alure/html/*
53 %{_includedir}/AL/alure.h
54 %{_libdir}/*.so
55 %{_libdir}/pkgconfig/*.pc