resetting manifest requested domain to floor
[platform/upstream/adns.git] / packaging / adns.spec
1 Name:           adns
2 %define lname   libadns
3 Version:        1.4
4 Release:        0
5 License:        GPL-2.0+
6 Summary:        Advanced Easy-to-Use Asynchronous-Capable DNS Utilities
7 Url:            http://www.chiark.greenend.org.uk/~ian/adns/
8 Group:          Productivity/Networking/DNS/Utilities
9 Source:         %{name}-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 Source1001:     adns.manifest
12 BuildRequires:  autoconf
13
14 %description
15 adns includes a collection of useful DNS resolver utilities.
16
17 %package -n %lname
18 Summary:        Advanced DNS resolver client library
19 Group:          System/Libraries
20
21 %description -n %lname
22 Libadns is an advanced, easy to use, asynchronous-capable DNS resolver
23 client library for C (and C++) programs.
24
25 %package -n libadns-devel
26 Summary:        Libraries and header files to develop programs with libadns support
27 Group:          Development/Languages/C and C++
28 Requires:       %lname = %{version}
29 Requires:       glibc-devel
30
31 %description -n libadns-devel
32 Libadns-devel includes the header file and static library to develop
33 programs with libads support.
34
35 %prep
36 %setup -q
37 cp %{SOURCE1001} .
38
39 %build
40 autoreconf -fiv
41 %configure
42 make %{?_smp_mflags} all
43
44 %install
45 %make_install
46
47
48 %files
49 %manifest %{name}.manifest
50 %defattr(-,root,root)
51 %license COPYING GPL-vs-LGPL LICENCE.WAIVERS
52 %{_bindir}/adns*
53
54 %files -n %lname
55 %manifest %{name}.manifest
56 %defattr(-,root,root)
57 %{_libdir}/libadns.so.1*
58
59 %files -n libadns-devel
60 %manifest %{name}.manifest
61 %defattr(-,root,root)
62 %{_includedir}/adns.h
63 %{_libdir}/libadns.so
64
65 %post -n %lname -p /sbin/ldconfig
66
67 %postun -n %lname -p /sbin/ldconfig
68
69 %changelog