89a59f2ddf4a7f1c16674ed9a298a998dc0f7ef4
[platform/upstream/adns.git] / packaging / adns.spec
1 Name:           adns
2 %define lname   libadns
3 Version:        1.4
4 Release:        0
5 License:        GPL-2.0+
6 Summary:        Advanced Easy-to-Use Asynchronous-Capable DNS Utilities
7 Url:            http://www.chiark.greenend.org.uk/~ian/adns/
8 Group:          Productivity/Networking/DNS/Utilities
9 Source:         %{name}-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 BuildRequires:  autoconf
12
13 %description
14 adns includes a collection of useful DNS resolver utilities.
15
16 %package -n %lname
17 Summary:        Advanced DNS resolver client library
18 Group:          System/Libraries
19 Provides:       libadns = %{version}
20
21 %description -n %lname
22 Libadns is an advanced, easy to use, asynchronous-capable DNS resolver
23 client library for C (and C++) programs.
24
25 %package -n libadns-devel
26 Summary:        Libraries and header files to develop programs with libadns support
27 Group:          Development/Languages/C and C++
28 Requires:       %lname = %{version}
29 Requires:       glibc-devel
30
31 %description -n libadns-devel
32 Libadns-devel includes the header file and static library to develop
33 programs with libads support.
34
35 %prep
36 %setup -q
37
38 %build
39 autoreconf -fiv
40 %configure
41 make %{?_smp_mflags} all
42
43 %install
44 %make_install
45
46
47 %files
48 %defattr(-,root,root)
49 %doc COPYING GPL-vs-LGPL LICENCE.WAIVERS
50 %{_bindir}/adns*
51
52 %files -n %lname
53 %defattr(-,root,root)
54 %{_libdir}/libadns.so.1*
55
56 %files -n libadns-devel
57 %defattr(-,root,root)
58 %{_includedir}/adns.h
59 %{_libdir}/libadns.so
60
61 %post -n %lname -p /sbin/ldconfig
62
63 %postun -n %lname -p /sbin/ldconfig
64
65 %changelog