fixed rpmlint errors, set %license
[platform/upstream/adns.git] / packaging / adns.spec
1 Name:           adns
2 %define lname   libadns
3 Version:        1.4
4 Release:        0
5 License:        GPL-2.0+
6 Summary:        Advanced Easy-to-Use Asynchronous-Capable DNS Utilities
7 Url:            http://www.chiark.greenend.org.uk/~ian/adns/
8 Group:          Productivity/Networking/DNS/Utilities
9 Source:         %{name}-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 BuildRequires:  autoconf
12
13 %description
14 adns includes a collection of useful DNS resolver utilities.
15
16 %package -n %lname
17 Summary:        Advanced DNS resolver client library
18 Group:          System/Libraries
19
20 %description -n %lname
21 Libadns is an advanced, easy to use, asynchronous-capable DNS resolver
22 client library for C (and C++) programs.
23
24 %package -n libadns-devel
25 Summary:        Libraries and header files to develop programs with libadns support
26 Group:          Development/Languages/C and C++
27 Requires:       %lname = %{version}
28 Requires:       glibc-devel
29
30 %description -n libadns-devel
31 Libadns-devel includes the header file and static library to develop
32 programs with libads support.
33
34 %prep
35 %setup -q
36
37 %build
38 autoreconf -fiv
39 %configure
40 make %{?_smp_mflags} all
41
42 %install
43 %make_install
44
45
46 %files
47 %defattr(-,root,root)
48 %license COPYING GPL-vs-LGPL LICENCE.WAIVERS
49 %{_bindir}/adns*
50
51 %files -n %lname
52 %defattr(-,root,root)
53 %{_libdir}/libadns.so.1*
54
55 %files -n libadns-devel
56 %defattr(-,root,root)
57 %{_includedir}/adns.h
58 %{_libdir}/libadns.so
59
60 %post -n %lname -p /sbin/ldconfig
61
62 %postun -n %lname -p /sbin/ldconfig
63
64 %changelog