[api] Add timeout function
[platform/upstream/SSAT.git] / packaging / ssat.spec
1 Name:           ssat
2 Summary:        Shell Script Automated Tester
3 Version:        1.2.0
4 Release:        1
5 Group:          Development/Tools
6 Packager:       MyungJoo Ham <myungjoo.ham@samsung.com>
7 License:        Apache-2.0
8 Source0:        ssat-%{version}.tar.gz
9 Source1001:     ssat.manifest
10 BuildArch:      noarch
11
12 Requires:       bash
13 Requires:       perl
14
15 %description
16 SSAT provides testing environment for shell scripts with Apache-2.0 license.
17 This is created to avoid any complications related with GPL licenses.
18
19 %prep
20 %setup -q
21 cp %{SOURCE1001} .
22
23 %build
24 # DO NOTHING
25
26 %install
27 mkdir -p %{buildroot}%{_bindir}
28 install -p -m 0755 ssat.sh %{buildroot}%{_bindir}/
29 install -p -m 0644 ssat-api.sh %{buildroot}%{_bindir}/
30 pushd %{buildroot}%{_bindir}
31 ln -s ssat.sh ssat
32 popd
33
34 %files
35 %manifest ssat.manifest
36 %{_bindir}/ssat
37 %{_bindir}/ssat.sh
38 %{_bindir}/ssat-api.sh