Add bmp2png utility.
[platform/upstream/SSAT.git] / packaging / ssat.spec
1 Name:           ssat
2 Summary:        Shell Script Automated Tester
3 Version:        1.3.0
4 Release:        0
5 Group:          Development/Tools
6 Packager:       MyungJoo Ham <myungjoo.ham@samsung.com>
7 License:        Apache-2.0
8 Source0:        ssat-%{version}.tar.gz
9 Source1001:     ssat.manifest
10
11 Requires:       bash
12 Requires:       perl
13
14 ## For the utility
15 BuildRequires:  meson
16 BuildRequires:  ninja
17 BuildRequires:  pkgconfig(libpng)
18 BuildRequires:  glib2-devel
19
20 %description
21 SSAT provides testing environment for shell scripts with Apache-2.0 license.
22 This is created to avoid any complications related with GPL licenses.
23
24 %prep
25 %setup -q
26 cp %{SOURCE1001} .
27
28 %build
29 # Utilities
30 meson --prefix=%{_prefix} --bindir=bin build util
31 ninja -C build
32
33 %install
34 mkdir -p %{buildroot}%{_bindir}
35 install -p -m 0755 ssat.sh %{buildroot}%{_bindir}/
36 install -p -m 0644 ssat-api.sh %{buildroot}%{_bindir}/
37 pushd %{buildroot}%{_bindir}
38 ln -s ssat.sh ssat
39 popd
40 DESTDIR=%{buildroot} ninja -C build install
41
42 %files
43 %manifest ssat.manifest
44 %{_bindir}/ssat
45 %{_bindir}/ssat.sh
46 %{_bindir}/ssat-api.sh
47 %{_bindir}/bmp2png