[SDL_Tizen] Modify SDL-Tizen docs
[platform/upstream/SDL.git] / SDL2.spec
1 Summary: Simple DirectMedia Layer
2 Name: SDL2
3 Version: 2.0.4
4 Release: 2
5 Source: http://www.libsdl.org/release/%{name}-%{version}.tar.gz
6 URL: http://www.libsdl.org/
7 License: zlib
8 Group: System Environment/Libraries
9 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
10 Prefix: %{_prefix}
11 %ifos linux
12 Provides: libSDL2-2.0.so.0
13 %endif
14
15 %define __defattr %defattr(-,root,root)
16 %define __soext so
17
18 %description
19 This is the Simple DirectMedia Layer, a generic API that provides low
20 level access to audio, keyboard, mouse, and display framebuffer across
21 multiple platforms.
22
23 %package devel
24 Summary: Libraries, includes and more to develop SDL applications.
25 Group: Development/Libraries
26 Requires: %{name} = %{version}
27
28 %description devel
29 This is the Simple DirectMedia Layer, a generic API that provides low
30 level access to audio, keyboard, mouse, and display framebuffer across
31 multiple platforms.
32
33 This is the libraries, include files and other resources you can use
34 to develop SDL applications.
35
36
37 %prep
38 %setup -q 
39
40 %build
41 %ifos linux
42 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix} --disable-video-directfb
43 %else
44 %configure
45 %endif
46 make
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %ifos linux
51 make install prefix=$RPM_BUILD_ROOT%{prefix} \
52              bindir=$RPM_BUILD_ROOT%{_bindir} \
53              libdir=$RPM_BUILD_ROOT%{_libdir} \
54              includedir=$RPM_BUILD_ROOT%{_includedir} \
55              datadir=$RPM_BUILD_ROOT%{_datadir} \
56              mandir=$RPM_BUILD_ROOT%{_mandir}
57 %else
58 %makeinstall
59 %endif
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %{__defattr}
66 %doc README*.txt COPYING.txt CREDITS.txt BUGS.txt
67 %{_libdir}/lib*.%{__soext}.*
68
69 %files devel
70 %{__defattr}
71 %doc docs/README*.md
72 %{_bindir}/*-config
73 %{_libdir}/lib*.a
74 %{_libdir}/lib*.la
75 %{_libdir}/lib*.%{__soext}
76 %{_includedir}/*/*.h
77 %{_libdir}/pkgconfig/*
78 %{_datadir}/aclocal/*
79
80 %changelog
81 * Thu Jun 04 2015 Ryan C. Gordon <icculus@icculus.org>
82 - Fixed README paths.
83
84 * Sun Dec 07 2014 Simone Contini <s.contini@oltrelinux.com>
85 - Fixed changelog date issue and docs filenames
86
87 * Sun Jan 22 2012 Sam Lantinga <slouken@libsdl.org>
88 - Updated for SDL 2.0
89
90 * Tue May 16 2006 Sam Lantinga <slouken@libsdl.org>
91 - Removed support for Darwin, due to build problems on ps2linux
92
93 * Sat Jan 03 2004 Anders Bjorklund <afb@algonet.se>
94 - Added support for Darwin, updated spec file
95
96 * Wed Jan 19 2000 Sam Lantinga <slouken@libsdl.org>
97 - Re-integrated spec file into SDL distribution
98 - 'name' and 'version' come from configure 
99 - Some of the documentation is devel specific
100 - Removed SMP support from %build - it doesn't work with libtool anyway
101
102 * Tue Jan 18 2000 Hakan Tandogan <hakan@iconsult.com>
103 - Hacked Mandrake sdl spec to build 1.1
104
105 * Sun Dec 19 1999 John Buswell <johnb@mandrakesoft.com>
106 - Build Release
107
108 * Sat Dec 18 1999 John Buswell <johnb@mandrakesoft.com>
109 - Add symlink for libSDL-1.0.so.0 required by sdlbomber
110 - Added docs
111
112 * Thu Dec 09 1999 Lenny Cartier <lenny@mandrakesoft.com>
113 - v 1.0.0
114
115 * Mon Nov  1 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
116 - First spec file for Mandrake distribution.
117
118 # end of file