build: tizen-black theme package
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.22
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
101         - tizen-winsets: Fix demo menu
102         - Tizenwinset: Reorder tizenwinset menu
103         - SearchBar: Header button size issue has been fixed
104         - Swipe: list item overflow: hidden has been added
105         - Tizenwinset: href has been added in grouped list
106         - Tizenwinset: Page transition page has been added
107         - Tizenwinset: Radio description has been fixed
108         - This patch fixes problem when base url is changed when site is prefetched.
109         - Entry : limit textarea's width (N_SE-28653)
110         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
111         - Gallery : next, prev images position bug has been fixed
112         - Multimediaview: Fix display error while handling orientationchange event.
113         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
114         - Datetimepicker: picker position has been fixed when browser resize event fired
115         - Tips: generate elements sample page javascript has been fixed
116         - Tokentextarea: Fix Tizen-winsets demo.
117
118 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
119         - VirtualGrid: Fix errors on centerTo and resize methods
120         - loader: Fix default font size at device-width viewport
121         - scrollview : remove overflow-x property
122         - Naviframe : fix backbutton position/ change down button icon
123         - Naviframe : bug fix
124         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
125
126 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
127         - JQM Navigation : remove page min-height
128         - Pagelayout : add refresh to pagelayout
129         - Tokentextarea: Changes 'remove' tests to asyncTest
130         - Popup: input tag alignment has been fixed
131         - Tokentextarea: add/remove events are deprecated.
132         - Contextpopup: Support horizontal list
133         - Select: icon z-index has been deleted
134         - Tizenwinset: ui widget order has been changed
135         - Tool: make web app template disable context menu by default
136         - Tizen-winset: change tips for using listview
137         - Loader: calculate font size with mobile width
138         - Naviframe : fix header's back button position
139         - TizenWinset : move locale info to another file
140
141 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
142         - JQM Navigation : remove page min-height
143         - Pagelayout : add refresh to pagelayout
144         - Tokentextarea: Changes 'remove' tests to asyncTest
145         - Popup: input tag alignment has been fixed
146         - Tokentextarea: add/remove events are deprecated.
147         - Contextpopup: Support horizontal list
148         - Select: icon z-index has been deleted
149         - Tizenwinset: ui widget order has been changed
150         - Tool: make web app template disable context menu by default
151         - Tizen-winset: change tips for using listview
152         - Loader: calculate font size with mobile width
153         - Naviframe : fix header's back button position
154         - TizenWinset : move locale info to another file
155
156 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
157         - Tizen-winset: Support accessibility for tizen-winset
158         - Orientation : add orientataionchange to tizen-winset
159         - Tokentextarea: Adjusts VI effect for add/remove block
160         - splitview: Support accessibility for splitview
161         - Tizen-winset: Date/time picker guide text has been fixed
162         - Popup: context popup arrow position, setTimeout open method bug have been fixed
163         - fastscroll: Add new indexString API to Fastscroll widget.
164         - splitview: Add new widget
165         - gallery3d: Add new widget
166         - Scrollview : disable VI effect for gesture event
167         - Scrollview : disable SIP outerscroll
168         - Tizen-winset: resize VirtualGrid widget in demo
169         - Tizen-winsets: Refactor searchbar subpages
170         - Tizen-winsets: Remove depracated usage of virtuallist
171         - Tizen-winsets: Move js code from main.js to subpages
172         - Tizen-winsets: Refactor virtual grid demo subpages
173         - Tizen-winsets: Move css files from index to proper subpages
174         - Tizen-winsets: Refactor list dialogue edit subpage
175         - Tizen-winsets: Refactor pagelayout subpages
176         - Tizen-winsets: Refactor tips subpages
177         - Tizen-winsets: Move subpages popup files from index.html
178         - Tizen-winsets: Move subpages javascript files from index.html
179         - virtualgrid: fix improperly merged codes
180         - ColorTheme : remove unused color value(1st)
181         - Scrollview : change scrollbar draw
182         - Popup: Apply popup background dim
183         - Tizen-winsets: Move tokentextarea demo to external page.
184         - Tizen-winsets: Move tabbar persist demo to external page.
185         - Tizen-winsets: Remove notImplemented page
186         - Tizen-winsets: Move slider demo page to external subpage
187         - Tizen-winsets: Fix ids, remove duplicated names for sliders
188         - Tizen-winsets: Remove event for changing theme
189         - tool: Fix wgt sample app generator tool to make apps be installed
190         - demos : change live to on
191         - build: Trim compiled CSS files
192         - Gallery: CSS left -> translate or translate3D
193         - Tokentextarea: Disfunctional APIs fixed.
194
195 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
196         - build: Fix Makefile to add globalize to the minified lib
197         - build-tools : upgrade less to v1.3.3
198         - demos : change normal js path to minified js
199         - Theme : remove reduantant less - dayselector, optionheader, nocontents
200         - multimediaview : fix full-screen mode.
201         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
202         - Extendablelist: Added min-height "load more button" in listitem
203         - virtualgrid: adjusts VI effect for an overflow action
204         - ControlGroup : change ellipsis font color (press/normal)
205         - multimediaview: Add an error message to Multimediaview
206         - virtualgrid: adjusts triple flick gesture
207         - scrollview: add function for getting width of view
208         - scrollview: adds support x axis gesture scroll
209         - multimediaview : fix audio control
210         - tabbar : tabbar slide animation change
211         - TizenWinsetDemo : 2line-text demo bug fix
212         - collapsible: Fix demo to show radio button correctly in the collapsible list
213         - collapsible: Set listitem position to relative
214         - UnitTC: added list divider unit test
215         - Style: unnecessary color codes have been deleted and modified
216         - build: Module build implementation
217         - UnitTC: Additional unit testcases have been added
218         - listview : bug fix
219         - Naviframe : remove back button's hover effect
220         - TizenDemo : remove back button
221         - Transition: added more-button vi
222         - pinch: added new event called pinch
223         - Popup: css word-wrap:break-word has been added
224         - virtualgrid: memory leak fix
225         - progress: set to init state at pending bar
226         - progress: add margin of top/bottom
227         - unit-test: split progress test and progressbar test
228         - Tizen-winset: Context popup sample page guide text has been changed
229         - multimediaview: fix the height of widget when full-screen mode
230         - JQM: performance tuning
231
232 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
233         - DialogueList : delete border top value / add sample's text ellipsis
234         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
235         - Multimediaview: Fix mute function
236         - Tizen-winset: list vi index guide textbox has been removed
237         - Tizen-winset: custom button texts have been changed
238         - slider: move popup div to out of content
239         - TizenWinset: disable context popup in multimediaview
240         - Swipe: wrong style name has been fixed
241         - demo: add the sample at dialogue list
242         - listview: Add ui-li-has-right-btn class with toggleswitch
243         - WinsetDemo : change wrong title name
244
245 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
246         - demo: checkbox: reduce button's width
247         - tabbar : delete right/left tab animation color
248         - scrollview: fix the scroll position at keydown event
249         - groupControl : change footer groupControl from min-width to percentage
250         - scrollview: get height of softkeyboard correctly
251         - tizen-winset: Add name attr to all radio inputs
252         - virtualgrid: changes event binding target
253         - scrollview: skip the drag if target is textarea
254         - scrollview: skip the dragging of parent scrollview
255         - scrollview: apply the scaling ratio to the soft keyboard
256         - demos: apply disabled option in textarea
257         - demo: remove unused codes
258         - demo: datetimepicker: show selected date correctly
259         - listview: Adjust bubble listitem width and margin
260         - pagelayout : change external refresh call and ime status follow only current page
261         - toggleSwitch : bug fix
262         - unit-test: slider: fix the move test
263         - handler: fix jslint error
264         - ToggleSwitch : set image toggleswitch background attribute
265
266 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
267         - slider: increase the text width(N_SE-23397)
268         - virtualgrid: DOM element leak fix
269         - header: Move button top higher in header with tabbar(N_SE-22253)
270         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
271         - handler: bug fix (regarding enableHandler function )
272         - demo:fix syntax error
273
274 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
275         - demo: fix demo using tizen device API
276         - multimediaview: reset the height of container
277         - input: modify css correctly
278         - multimediaview: fix the height of widget
279         - gallery: bind create event
280         - progress: bind create event
281         - slider: bind create event
282         - progressbar: bind create event
283         - progressbar: event trigger correctly
284         - popup: fix height of popup scroller
285         - build: add continue option to jslint
286         - ctxpopup demo : bug fix
287         - demo: fix searchbar demo to use different IDs
288         - demo: extract routine executing Tizen device API
289         - toggleswitch : set default margin, delete box padding
290
291 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
292         - virtuallist: Prevent replacing contents on nonexist element
293         - JQM: Trim text in listitem to get index in autodivider
294         - JQM: Remove trailing whitespace in jqm patch
295         - scrollview: get the height including margin
296         - multimediaview: bug fix ( scrolling in full-screen mode )
297         - virtuallist: set listitem width to exclude listitem left/right margin
298         - demo: fix virtuallist sample layout
299         - progress: set the position explicitly
300         - progress: rename from progressing to progress
301         - build: remove unused files
302         - searchbar: fix jslint errors
303         - src: fix file permissions
304         - button : change jump left icon
305
306 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
307         - theme : button icon - scrolltop, scrolleft icon changed.
308         - build: cleanaup Makefile
309         - pagelayout: fix jslint error
310         - virtualgrid: Fix jslint errors
311         - tabbar : jslint bug error fix
312         - build: add regexp option to jslint
313         - virtuallist: fix jslint errors
314         - handler: Apply the exceptional principle for scrollbar on Handler.
315         - build: remove unused copyright
316         - loader: extract log class for tizen web, and fix jslint errors
317         - loader: Viewport width is set to document width
318         - popupwindow: fix jslint error
319         - build: fix Makefile for tizen-white theme
320         - build: remove unused libraries
321         - datetimepicker: fix jslint error
322         - slider: fix jslint error
323         - demo: remove deprecated demos
324         - pagelayout : change to call relayout with this page
325         - Tokentextarea: Block size error fixed.
326         - handler: bug fix (handler activation)
327
328 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
329         - demo: clear input text value with cancel button click
330         - demo: Adjust textarea height automatically
331         - naviframe : bug fix
332         - tabbar : bug fix
333         - Fastscroll: popup position has been changed
334         - Button: custom button icon path, margin have been changed
335         - toggleswitch : bug fix
336         - slider: increase the margin
337         - datetimepicker: close the popup after select the value
338         - unit-test : add page backbutton control test
339         - Demo: added guide text and change input type in list vi
340         - remove legacy codes : jquery-geo
341         - Datetimepicker: text-main max-width has been removed
342         - Radio: control group border has been removed
343         - Demo: remove 'tab' space
344         - UnitTC: swipe unit tc has been fixed
345         - UnitTC: jQuery path has been fixed
346         - Button: bug fix when button has not a text
347         - tizen-winset: timepicker: demo title is changed
348
349 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
350         - tizen-winsets: codes cleanup
351         - datetimepicker: date calibration when year is changed
352         - Demo: textarea size has been changed
353         - Demo: Naviframe morebutton demo has been changed
354         - remove unused unit test cases : gallery3d
355         - tizen-winset: remove links
356
357 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
358         - gallery: use timeout function instead of interval
359         - Tokentextarea: Display error fixed.
360         - scrollview: Fix not selector to respond with jQuery1.8.2
361         - tabbar: remove the width of last element
362         - Demo: apply css 'user-select:none'
363         - Button: guide text has been shorten
364         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
365         - virtuallist: Fix mistyping
366         - demo: Fix tizen function namespace in demo
367         - virtuallist: Rewrite listitem replacing algorithm
368         - fastscroll: modify from not selector to function
369         - extendablelist: Fix unit-test
370         - tabbar : prefix to tabbar scroll event
371         - Popupwindow: removed unvalid selector in jquery 1.8.2
372         - slider: adjust handle text as length of value
373         - Demo: 3 buttons in popup text has been changed
374         - src: codes cleanup
375         - demo : remove trailing empty strings
376         - demo : rename TizenWinset list items
377         - button : change from long text list to multiline list
378         - build: Remove JQM1.1.0 patches
379         - Popup: Apply tizen style popup and attribute support
380         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
381         - UnitTest: folder and file renamed, QUnit path was modified
382         - tizen-winsets: button: fix textarea width
383         - Swipe: event name error has been fixed
384
385 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
386         - Button: button padding has been updated
387         - virtuallist: fix unique listitem ID bug
388         - checkbox, radio : change display attr
389         - Button: bug fix ( when data style circle button on text )
390         - handler: bug fix (when scrolling with multi selection)
391         - JQM: adjust patch number
392         - gallery: show the widget after pageshow
393         - TokenTextArea : resource add ( press image )
394         - gallery: adds function that set the index to value API
395         - configure: set TIZEN default configures
396         - footer: h tag display attribute value has been changed
397         - buttons : demo bug fix
398         - searchbar : demo page bug fix
399         - tizen demo : bug fix
400         - build: remove JQM1.1.0
401         - Tokentextarea: Fix issues
402         - scrollview: block the multi touch
403         - list : dialogue list demo change
404         - pagelayout : update dynamic control
405         - Demo: Context popup close method has been changed
406
407 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
408         - slider: set text container's width as text length
409         - Timepicker: li max-width has been changed
410         - remove experimental feature - mapview.
411         - scrollview: added conditions for finding slider
412         - UnitTC: Pass,error count save method has been changed
413         - confix.xml: default config added for tizen basic applications
414         - Swipe: p tag margin value is set '0'
415         - packaging: remove unused file
416         - tabbar : bug fix
417         - list demo : bug fix
418         - tizen-winsets: gallery: move to new section
419         - tizen-winsets: autodivider: removes link of list
420         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
421         - pagelayout : padding calculate change, ime footer check changed
422         - tizen-winsets: searchbar: scroll to the top when type the character
423         - searchbar : bug fix
424         - demo: Fix virtuallist demo following new list style
425         - demo: Add word-wrap:break-word and remove parag. width
426         - Demo: button max-width has been set( 3 buttons in popup )
427         - back button control demo : bug fix
428         - toggleswitch : demo page modify
429         - slider: add margin-top and margin-bottom
430         - tabbar demo : bug fix
431         - Popup: IME hide when popup is closed
432         - token textarea : bug fix
433         - Timepicker: change get attribute method
434         - footer demo : bug fix
435         - unit-test: gallery: add new APIs
436         - gallery: adds support new APIs
437
438 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
439         - JQM: patches cleanup
440         - Button: data-corners attribute has been added
441         - unit-test: slider: fix class name of background
442         - progressbar, slider: fix less variable typo
443         - Tabbar : VI update
444         - notification: add top position at fix class
445         - demo: entry demo page change
446         - css: .ui-disabled added
447         - tizen-winset: token textarea: remove back button at demo page
448         - theme: Remove unused less file
449         - pagelayout : content min height bug fix
450         - scrollview: skip the dragging when target is slider's handle
451         - scrollview: update and refactoring the scroll effect
452         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
453         - Swipe: demo page html error has been fixed
454         - listview: Add add/delete animation (VI)
455         - Popup: demo page has been modified
456         - tizen demo : bug fix
457         - searchbar : demo page change(change front button and add behaviour)
458         - pagelayout : add min height to content
459         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
460         - back button control demo : change url link to data-rel="back"
461         - loader: Skip loading theme CSS with a custom css code
462         - Button: support no-text in button
463         - collapsible: Fix syntax error
464         - slider: use data-highlight attribute
465         - collapsible: Rotate animation to collapsible heading icon
466         - toggleswitch : text switch bug fix
467         - remove candidates-calendarpicker
468         - Patch: Fix misc mistakes in JQM patches
469         - searchbar : animation change
470         - gallery: get the width correctly
471         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
472         - collapsible: Add collapse/expand animation (VI)
473         - datetimepicker: VI update
474         - JQM: set transition to pop as default
475         - tabbar : bug fix in case none li element case
476         - scrollview: fix the drag bug
477         - Button: Button icon scrolltop, left has beed added
478         - Swipe: VI update and swipe speed has been changed
479         - jqm: fix errors in patch files
480         - unit-test: swipe: fixed the destroy test
481
482 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
483         - Revert "[checkboxradio] exception handling for input"
484                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
485                 Tizen style supports no-label radio and checkbox when making lists.
486                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
487
488 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
489 - Fix:
490         - modify segment background
491         - rearrange check, radio input
492         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
493         - button: style has beed added(box,circle,nobg,round)
494         - favorite resource added
495         - demo/tizen-winsets: add footer and back button
496         - remove autodividers unit test
497         - add divider for tabbar
498         - checkboxradio: exception handling for input
499         - segment control backward compatiblity
500         - Fix collapsible unit-test
501         - remove toggleswitch
502         - add patch for remove segment text
503 - Spec changes:
504         - replace controlbar to tabbar
505
506 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
507 - FIX:
508         - slider: add image
509         - button: data-icon support, styles fix
510         - progressbar: modify the background
511         - scrollview: auto scrolling bug fix
512         - pagelayout: IME concept is changed
513 - Spec changes:
514         - dialogue: add edit mode
515         - nocontents: removed
516         - pagecontrol: removed
517         - dayselector: removed
518         - expandablelist: removed
519
520 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
521 - FIX:
522         - chang searchbar/slider images
523         - delete redundant button images
524 - Spec changes:
525         - Change widget name: shortcutscroll -> fastscroll
526
527 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
528 - FIX:
529         - jqm1.2: Change collapsible style to meet expandable list
530         - remove jquery-geo-1.0.a4
531         - unit-test: rename from imageslider to gallery
532         - nocontent: add warning message
533         - Handler: Fix issues in jqm1.2
534         - Multimediaview: modify APIs & comments
535         - Mapview: Fix issues in jqm1.2
536         - JQM: clean up patches
537         - Swipelist: refactoring swipelist
538         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
539         - rearrange button's data-icon resources
540 - Spec changes:
541         - Virtualgrid: remove option ('data-itemcount')
542         - gallery: rename the widget from imageslider to gallery
543         - add new style for searchbar
544         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
545
546 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
547 - FIX:
548         - fix jslint error
549         - remove unused files
550         - change naviframe style
551 - Spec changes:
552         - applied jQuery Mobile 1.2.0
553         - remove optionheader
554
555 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
556 - FIX:
557         - fix unit tests
558         - remove unused theme files
559         - timepicker: text position fix
560         - scrollview: set dragstop when mouse is out of window
561         - listview: fix margin
562 - Spec changes:
563         - support data-framework-viewport-width
564
565 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
566 - FIX:
567         - dayselector: fix size
568         - remove unised styles
569         - divider: set non-press effect to default option
570         - popupwindow: fix window closing failure
571         - handler: GUI implementation
572         - TC: fix unit TCs
573         - scrollview: fix padding size
574 - Spec changes:
575         - Remove color widgets
576         - add $.tizen.pkgVersion for SDK
577 - Etc.
578         - JSDuck documents
579
580 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
581 - FIX:
582         - Many winsets: Fix layout
583         - Footer: fix position to bottom
584 - Spec changes:
585         - Remove color widgets
586
587 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
588 - FIX:
589         - Many widgets: New UX 0.6 theme implementation
590         - widgetex: init speed up
591         - scrollview: fix scrollbar and scale animation
592         - scrollview: fix scroll position when updatelayout is triggered
593         - header/footer: make textselection disable, except input type="text"
594
595 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
596 - FIX:
597         - Remove tizen-black theme package description
598
599 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
600 - FIX:
601         - Fix theme name to meet the change of system theme name: white->tizen
602         - Popupwindow: fix left position
603         - Remove black theme
604         - footer: remove label, legend drawing
605 - Spec changes:
606         - UX guide v0.4 : button, layout
607
608 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
609 - FIX:
610         - scrollview: Fix outer scroll amount
611         - tabbar: fix tapping twice
612         - popupwindow: fix left position
613
614 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
615 - FIX:
616         - expandablelist: icon color fix
617         - scrollview: Fix xy scroll
618         - footer: Remove dummy div
619         - Make string concatnation effective in inline-protos.sh
620 - Spec changes:
621         - refresh header/footer when drag&drop event is fired in GUI builder
622         - searchbar: delete cancel button
623         - don't trigger updatelayout event when keyup event comes
624
625 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
626 - FIX:
627         - Toggleswitch: Change event name from 'changed' to 'change'
628         - Notification: Revert interval feature
629
630 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
631 - FIX:
632         - Fix SMACK manifest bug (S1-9098)
633
634 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
635 - FIX:
636         - handler: don't append a handler if handler is not enabled
637         - scrollview: use static value
638         - datetimepicker: fix date-format HH display error
639 - ETC:
640         - provide jquery.min.js
641         - barlayout: codes clean
642         - remove unused file
643
644 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
645 - FIX:
646         - listview: change focused color
647         - multibuttonentry: code refactoring
648         - datetimepicker: modify date format when triggered date-changed event
649         - slider: fix the top of slider bar
650         - add event blocker when load a first page
651
652 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
653 - ETC.
654         - Move SMACK manifest files to the top SRCDIR
655
656 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
657 - FIX:
658         - Popup: Do not focus container
659         - Header: show backbutton when both tabbar and header are present together
660         - Multi button entry: text ellipsis, code refactoring
661
662 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
663 - ETC.
664         - Apply SMACK manifest
665
666 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
667 - FIX:
668         - JSLINT code clean-up
669         - scrollview: firefox support
670         - scrollview: fix finding slider handle
671         - list: tweak text ellipsis
672         - checkbox: fix selecting wrong label tag (N_SE-8370)
673         - imageslider: check parameter
674         - smallpopup: fix position
675         - searchbar: fix 'clear' button size
676 - Spec changes:
677         - scrollview: support outer scroll
678         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
679         - remove S/W IME control
680
681 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
682 - FIX:
683         - Add missing icon: controlbar
684         - scrollview: tune scrolling animatio ninterval
685         - datetimepicker: digit/triangle position
686         - datetimepicker: fix day overflow issue
687 - Spec changes:
688         - scrollview: show scrollbar when page is showed
689         - scrollview: disable outer scroll
690         - extendablelist: change api with legacy support
691         - add ui-text-ellipsis class
692
693 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
694 - FIX:
695         - scrollveiw: fix height of view
696         - searchbar: support placeholder
697 - Spec changes:
698         - add ui-text-ellipsis class
699
700 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
701 - FIX:
702         - scrollview: scrolling bug fix
703         - controlbar: fix width of controlbar item
704 - Spec changes:
705         - searchbar: don't hide icon
706         - popup: update JQM poup widget
707
708 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
709 - FIX:
710         - controlbar: set correct controlbar width of last element
711         - slider: get popup enable value correctly
712         - use Date.now() instead of (new Data()).getTime()
713         - popupwindow: fix the background color of popup scroller
714         - listview: add padding-left to expandable list
715         - add ellipsis for title area support
716
717 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
718 - FIX:
719         - swipelist: show list items correctly
720         - datetimepicker: set last day, if day is overflowed
721 - Spec changes:
722         - controlbar: update icons
723
724 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
725 - FIX:
726         - notification: fix typo
727 - Spec changes:
728         - controlbar: update icons
729
730 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
731 - FIX:
732         - multimediaview: video progress bar display normally for too samll
733         - segmentcontrol: remove media query
734         - scrollview: add outer scroll condition
735         - datetimepicker: modify triangle size
736         - popupwindow: set the screen height explicitly
737         - notification: add multiline text
738 - Spec changes:
739         - mutibuttonentry: support new GUI
740         - virtualgrid: support new GUI
741
742 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
743 - FIX:
744         - radio/check button : button size bug fix
745
746 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
747 - FIX:
748         - build error fixed
749
750 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
751 - FIX:
752         - listview: style fix, remove filter placeholder
753         - controlbar: divide styles
754         - scrollview: don't skip dragging when click button or inputbox
755         - slider: trim the text on text slider
756 - Spec changes:
757         - remove gray and blue theme
758         - add white and black theme
759         - support new GUI guide
760
761 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
762 - FIX:
763         - fix coment of version tag
764
765 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
766 - FIX :
767         - button: fix alignment
768         - listview: adjust the main text width
769         - virtualgrid: refactoring
770 - Spec changes:
771         - transition: support JQM 1.1.0 transitions
772         - scrollview: support the outer scroll
773         - notification: remove interval feature
774
775 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
776 - FIX :
777         - checkboxRadio: Add left/right padding
778         - button: custom button & icon position
779         - virtuallist: remove 'recreate' test
780 - Spec changes:
781         - header/footer: enable/disable support
782
783 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
784 - FIX :
785         - expandablelist: modify show animation
786         - virtualgrid: Redesign programming interface
787         - popupwindow: code clean and fixed issues
788         - pagelayout: fix content height
789         - license file update
790         - virtuallist: Change programming interface
791         - datetimepicker: getting days correctly
792         - searchbar: set to hidden when cancel button is hide
793         - White theme title font tuning
794 - Spec changes:
795         - default theme tizen-gray to tizen-white
796         - set default page transition to none
797
798 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
799 - FIX :
800         - Back Button : enlarge backbutton click size for white theme
801 - Feature :
802         - Expandable List : Add refresh api
803 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
804 - FIX :
805         - click event touch threshold tuning
806
807 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
808 - FIX : 
809         - Add back button highlight effect for white theme
810
811 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
812 - FIX : 
813         - IME checkroutine update, improve relayout on resize event
814         - Add highlight effect for radio button list 
815         - Scrollview : fix condition of updatelayout event
816 - Feature : progressing : add show/hide api
817
818 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
819 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
820         add default theme option on buttonMarkup for tizen theme
821         [searchbar] first fix : focus/blur fixed
822         back button does not work when long press
823         scrollview: don't auto scrolling if resizing area is too large
824 - Feature : notification : add api to set the icon at tickernoti
825         demo : update the list sample demo
826         Support tizen default theme
827
828 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
829 - Improvements & Bugfixes
830    - HOTFIX: Revert template function with jquery.template
831
832 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
833 - Improvements & Bugfixes
834    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
835 - Spec changes
836    - $.tizen.loadTheme() function accepts theme name as arguement
837    - Scrollview supports 'updatelayout' callback
838
839 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
840 - Improvements & Bugfixes
841    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
842
843 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
844 - Improvements & Bugfixes
845    - Add tizen-white theme package, to make rpm build to be finished
846
847 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
848 - Improvements & Bugfixes
849    - Set 'slide' as default page transition effect, by JQM patch
850
851 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
852 - Improvements & Bugfixes
853    - Fix IME show/hide algorithm
854    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
855
856 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
857 - Improvements & Bugfixes
858    - Fix notification position
859    - Fix unit tests
860
861  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
862 - Spec changes
863         - JQM 1.1 upgrade
864 - Improvements & Bugfixes
865         - Transform3D support on scrollview
866         - Page layout supports IME control
867         - Mapview supports pinch zoom on JQM 1.1
868         - Fix wrong character on button in minified version
869         - Virtualgrid supports scrollbar
870         - Lots of bugfixes
871
872 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
873 - Spec changes
874         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
875         - imageslider : supports 'resize' event.
876         - listview : listview has 1px padding-bottom.
877         - loader : Change global namespace, from S to $.tizen.
878         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
879 - Improvements & Bugfixes
880         - Scrollview : supports 'translate3d', instead of 'translate'.
881         - notification : reset timer when 'show' or 'refresh' event.
882         - JQM patch : Fix vclick event triggered twice.
883 - Etc.
884         - Add & fix unit tests.
885
886 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
887 - Spec changes
888         - mapview : new widget.
889         - notification : add .refresh() API.
890         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
891 - Improvements & Bugfixes
892         - Support minified CSS.
893         - loader : Fix & refactor 'loading globalize culture file' routine.
894         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
895         - Many more bugfixes.
896 - Etc.
897         - Add many unit tests.
898         - Fix test coverage instrumentation tool to work with current source code.