Merge branch 'master' into tizen_2.1
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.21
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
88  - VirtualGrid: Fix errors on centerTo and resize methods
89  - loader: Fix default font size at device-width viewport
90  - scrollview : remove overflow-x property
91  - Naviframe : fix backbutton position/ change down button icon
92  - Naviframe : bug fix
93  - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
94
95 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
96         - JQM Navigation : remove page min-height
97         - Pagelayout : add refresh to pagelayout
98         - Tokentextarea: Changes 'remove' tests to asyncTest
99         - Popup: input tag alignment has been fixed
100         - Tokentextarea: add/remove events are deprecated.
101         - Contextpopup: Support horizontal list
102         - Select: icon z-index has been deleted
103         - Tizenwinset: ui widget order has been changed
104         - Tool: make web app template disable context menu by default
105         - Tizen-winset: change tips for using listview
106         - Loader: calculate font size with mobile width
107         - Naviframe : fix header's back button position
108         - TizenWinset : move locale info to another file
109
110 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
111         - JQM Navigation : remove page min-height
112         - Pagelayout : add refresh to pagelayout
113         - Tokentextarea: Changes 'remove' tests to asyncTest
114         - Popup: input tag alignment has been fixed
115         - Tokentextarea: add/remove events are deprecated.
116         - Contextpopup: Support horizontal list
117         - Select: icon z-index has been deleted
118         - Tizenwinset: ui widget order has been changed
119         - Tool: make web app template disable context menu by default
120         - Tizen-winset: change tips for using listview
121         - Loader: calculate font size with mobile width
122         - Naviframe : fix header's back button position
123         - TizenWinset : move locale info to another file
124
125 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
126         - Tizen-winset: Support accessibility for tizen-winset
127         - Orientation : add orientataionchange to tizen-winset
128         - Tokentextarea: Adjusts VI effect for add/remove block
129         - splitview: Support accessibility for splitview
130         - Tizen-winset: Date/time picker guide text has been fixed
131         - Popup: context popup arrow position, setTimeout open method bug have been fixed
132         - fastscroll: Add new indexString API to Fastscroll widget.
133         - splitview: Add new widget
134         - gallery3d: Add new widget
135         - Scrollview : disable VI effect for gesture event
136         - Scrollview : disable SIP outerscroll
137         - Tizen-winset: resize VirtualGrid widget in demo
138         - Tizen-winsets: Refactor searchbar subpages
139         - Tizen-winsets: Remove depracated usage of virtuallist
140         - Tizen-winsets: Move js code from main.js to subpages
141         - Tizen-winsets: Refactor virtual grid demo subpages
142         - Tizen-winsets: Move css files from index to proper subpages
143         - Tizen-winsets: Refactor list dialogue edit subpage
144         - Tizen-winsets: Refactor pagelayout subpages
145         - Tizen-winsets: Refactor tips subpages
146         - Tizen-winsets: Move subpages popup files from index.html
147         - Tizen-winsets: Move subpages javascript files from index.html
148         - virtualgrid: fix improperly merged codes
149         - ColorTheme : remove unused color value(1st)
150         - Scrollview : change scrollbar draw
151         - Popup: Apply popup background dim
152         - Tizen-winsets: Move tokentextarea demo to external page.
153         - Tizen-winsets: Move tabbar persist demo to external page.
154         - Tizen-winsets: Remove notImplemented page
155         - Tizen-winsets: Move slider demo page to external subpage
156         - Tizen-winsets: Fix ids, remove duplicated names for sliders
157         - Tizen-winsets: Remove event for changing theme
158         - tool: Fix wgt sample app generator tool to make apps be installed
159         - demos : change live to on
160         - build: Trim compiled CSS files
161         - Gallery: CSS left -> translate or translate3D
162         - Tokentextarea: Disfunctional APIs fixed.
163
164 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
165         - build: Fix Makefile to add globalize to the minified lib
166         - build-tools : upgrade less to v1.3.3
167         - demos : change normal js path to minified js
168         - Theme : remove reduantant less - dayselector, optionheader, nocontents
169         - multimediaview : fix full-screen mode.
170         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
171         - Extendablelist: Added min-height "load more button" in listitem
172         - virtualgrid: adjusts VI effect for an overflow action
173         - ControlGroup : change ellipsis font color (press/normal)
174         - multimediaview: Add an error message to Multimediaview
175         - virtualgrid: adjusts triple flick gesture
176         - scrollview: add function for getting width of view
177         - scrollview: adds support x axis gesture scroll
178         - multimediaview : fix audio control
179         - tabbar : tabbar slide animation change
180         - TizenWinsetDemo : 2line-text demo bug fix
181         - collapsible: Fix demo to show radio button correctly in the collapsible list
182         - collapsible: Set listitem position to relative
183         - UnitTC: added list divider unit test
184         - Style: unnecessary color codes have been deleted and modified
185         - build: Module build implementation
186         - UnitTC: Additional unit testcases have been added
187         - listview : bug fix
188         - Naviframe : remove back button's hover effect
189         - TizenDemo : remove back button
190         - Transition: added more-button vi
191         - pinch: added new event called pinch
192         - Popup: css word-wrap:break-word has been added
193         - virtualgrid: memory leak fix
194         - progress: set to init state at pending bar
195         - progress: add margin of top/bottom
196         - unit-test: split progress test and progressbar test
197         - Tizen-winset: Context popup sample page guide text has been changed
198         - multimediaview: fix the height of widget when full-screen mode
199         - JQM: performance tuning
200
201 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
202         - DialogueList : delete border top value / add sample's text ellipsis
203         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
204         - Multimediaview: Fix mute function
205         - Tizen-winset: list vi index guide textbox has been removed
206         - Tizen-winset: custom button texts have been changed
207         - slider: move popup div to out of content
208         - TizenWinset: disable context popup in multimediaview
209         - Swipe: wrong style name has been fixed
210         - demo: add the sample at dialogue list
211         - listview: Add ui-li-has-right-btn class with toggleswitch
212         - WinsetDemo : change wrong title name
213
214 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
215         - demo: checkbox: reduce button's width
216         - tabbar : delete right/left tab animation color
217         - scrollview: fix the scroll position at keydown event
218         - groupControl : change footer groupControl from min-width to percentage
219         - scrollview: get height of softkeyboard correctly
220         - tizen-winset: Add name attr to all radio inputs
221         - virtualgrid: changes event binding target
222         - scrollview: skip the drag if target is textarea
223         - scrollview: skip the dragging of parent scrollview
224         - scrollview: apply the scaling ratio to the soft keyboard
225         - demos: apply disabled option in textarea
226         - demo: remove unused codes
227         - demo: datetimepicker: show selected date correctly
228         - listview: Adjust bubble listitem width and margin
229         - pagelayout : change external refresh call and ime status follow only current page
230         - toggleSwitch : bug fix
231         - unit-test: slider: fix the move test
232         - handler: fix jslint error
233         - ToggleSwitch : set image toggleswitch background attribute
234
235 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
236         - slider: increase the text width(N_SE-23397)
237         - virtualgrid: DOM element leak fix
238         - header: Move button top higher in header with tabbar(N_SE-22253)
239         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
240         - handler: bug fix (regarding enableHandler function )
241         - demo:fix syntax error
242
243 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
244         - demo: fix demo using tizen device API
245         - multimediaview: reset the height of container
246         - input: modify css correctly
247         - multimediaview: fix the height of widget
248         - gallery: bind create event
249         - progress: bind create event
250         - slider: bind create event
251         - progressbar: bind create event
252         - progressbar: event trigger correctly
253         - popup: fix height of popup scroller
254         - build: add continue option to jslint
255         - ctxpopup demo : bug fix
256         - demo: fix searchbar demo to use different IDs
257         - demo: extract routine executing Tizen device API
258         - toggleswitch : set default margin, delete box padding
259
260 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
261         - virtuallist: Prevent replacing contents on nonexist element
262         - JQM: Trim text in listitem to get index in autodivider
263         - JQM: Remove trailing whitespace in jqm patch
264         - scrollview: get the height including margin
265         - multimediaview: bug fix ( scrolling in full-screen mode )
266         - virtuallist: set listitem width to exclude listitem left/right margin
267         - demo: fix virtuallist sample layout
268         - progress: set the position explicitly
269         - progress: rename from progressing to progress
270         - build: remove unused files
271         - searchbar: fix jslint errors
272         - src: fix file permissions
273         - button : change jump left icon
274
275 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
276         - theme : button icon - scrolltop, scrolleft icon changed.
277         - build: cleanaup Makefile
278         - pagelayout: fix jslint error
279         - virtualgrid: Fix jslint errors
280         - tabbar : jslint bug error fix
281         - build: add regexp option to jslint
282         - virtuallist: fix jslint errors
283         - handler: Apply the exceptional principle for scrollbar on Handler.
284         - build: remove unused copyright
285         - loader: extract log class for tizen web, and fix jslint errors
286         - loader: Viewport width is set to document width
287         - popupwindow: fix jslint error
288         - build: fix Makefile for tizen-white theme
289         - build: remove unused libraries
290         - datetimepicker: fix jslint error
291         - slider: fix jslint error
292         - demo: remove deprecated demos
293         - pagelayout : change to call relayout with this page
294         - Tokentextarea: Block size error fixed.
295         - handler: bug fix (handler activation)
296
297 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
298         - demo: clear input text value with cancel button click
299         - demo: Adjust textarea height automatically
300         - naviframe : bug fix
301         - tabbar : bug fix
302         - Fastscroll: popup position has been changed
303         - Button: custom button icon path, margin have been changed
304         - toggleswitch : bug fix
305         - slider: increase the margin
306         - datetimepicker: close the popup after select the value
307         - unit-test : add page backbutton control test
308         - Demo: added guide text and change input type in list vi
309         - remove legacy codes : jquery-geo
310         - Datetimepicker: text-main max-width has been removed
311         - Radio: control group border has been removed
312         - Demo: remove 'tab' space
313         - UnitTC: swipe unit tc has been fixed
314         - UnitTC: jQuery path has been fixed
315         - Button: bug fix when button has not a text
316         - tizen-winset: timepicker: demo title is changed
317
318 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
319         - tizen-winsets: codes cleanup
320         - datetimepicker: date calibration when year is changed
321         - Demo: textarea size has been changed
322         - Demo: Naviframe morebutton demo has been changed
323         - remove unused unit test cases : gallery3d
324         - tizen-winset: remove links
325
326 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
327         - gallery: use timeout function instead of interval
328         - Tokentextarea: Display error fixed.
329         - scrollview: Fix not selector to respond with jQuery1.8.2
330         - tabbar: remove the width of last element
331         - Demo: apply css 'user-select:none'
332         - Button: guide text has been shorten
333         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
334         - virtuallist: Fix mistyping
335         - demo: Fix tizen function namespace in demo
336         - virtuallist: Rewrite listitem replacing algorithm
337         - fastscroll: modify from not selector to function
338         - extendablelist: Fix unit-test
339         - tabbar : prefix to tabbar scroll event
340         - Popupwindow: removed unvalid selector in jquery 1.8.2
341         - slider: adjust handle text as length of value
342         - Demo: 3 buttons in popup text has been changed
343         - src: codes cleanup
344         - demo : remove trailing empty strings
345         - demo : rename TizenWinset list items
346         - button : change from long text list to multiline list
347         - build: Remove JQM1.1.0 patches
348         - Popup: Apply tizen style popup and attribute support
349         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
350         - UnitTest: folder and file renamed, QUnit path was modified
351         - tizen-winsets: button: fix textarea width
352         - Swipe: event name error has been fixed
353
354 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
355         - Button: button padding has been updated
356         - virtuallist: fix unique listitem ID bug
357         - checkbox, radio : change display attr
358         - Button: bug fix ( when data style circle button on text )
359         - handler: bug fix (when scrolling with multi selection)
360         - JQM: adjust patch number
361         - gallery: show the widget after pageshow
362         - TokenTextArea : resource add ( press image )
363         - gallery: adds function that set the index to value API
364         - configure: set TIZEN default configures
365         - footer: h tag display attribute value has been changed
366         - buttons : demo bug fix
367         - searchbar : demo page bug fix
368         - tizen demo : bug fix
369         - build: remove JQM1.1.0
370         - Tokentextarea: Fix issues
371         - scrollview: block the multi touch
372         - list : dialogue list demo change
373         - pagelayout : update dynamic control
374         - Demo: Context popup close method has been changed
375
376 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
377         - slider: set text container's width as text length
378         - Timepicker: li max-width has been changed
379         - remove experimental feature - mapview.
380         - scrollview: added conditions for finding slider
381         - UnitTC: Pass,error count save method has been changed
382         - confix.xml: default config added for tizen basic applications
383         - Swipe: p tag margin value is set '0'
384         - packaging: remove unused file
385         - tabbar : bug fix
386         - list demo : bug fix
387         - tizen-winsets: gallery: move to new section
388         - tizen-winsets: autodivider: removes link of list
389         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
390         - pagelayout : padding calculate change, ime footer check changed
391         - tizen-winsets: searchbar: scroll to the top when type the character
392         - searchbar : bug fix
393         - demo: Fix virtuallist demo following new list style
394         - demo: Add word-wrap:break-word and remove parag. width
395         - Demo: button max-width has been set( 3 buttons in popup )
396         - back button control demo : bug fix
397         - toggleswitch : demo page modify
398         - slider: add margin-top and margin-bottom
399         - tabbar demo : bug fix
400         - Popup: IME hide when popup is closed
401         - token textarea : bug fix
402         - Timepicker: change get attribute method
403         - footer demo : bug fix
404         - unit-test: gallery: add new APIs
405         - gallery: adds support new APIs
406
407 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
408         - JQM: patches cleanup
409         - Button: data-corners attribute has been added
410         - unit-test: slider: fix class name of background
411         - progressbar, slider: fix less variable typo
412         - Tabbar : VI update
413         - notification: add top position at fix class
414         - demo: entry demo page change
415         - css: .ui-disabled added
416         - tizen-winset: token textarea: remove back button at demo page
417         - theme: Remove unused less file
418         - pagelayout : content min height bug fix
419         - scrollview: skip the dragging when target is slider's handle
420         - scrollview: update and refactoring the scroll effect
421         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
422         - Swipe: demo page html error has been fixed
423         - listview: Add add/delete animation (VI)
424         - Popup: demo page has been modified
425         - tizen demo : bug fix
426         - searchbar : demo page change(change front button and add behaviour)
427         - pagelayout : add min height to content
428         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
429         - back button control demo : change url link to data-rel="back"
430         - loader: Skip loading theme CSS with a custom css code
431         - Button: support no-text in button
432         - collapsible: Fix syntax error
433         - slider: use data-highlight attribute
434         - collapsible: Rotate animation to collapsible heading icon
435         - toggleswitch : text switch bug fix
436         - remove candidates-calendarpicker
437         - Patch: Fix misc mistakes in JQM patches
438         - searchbar : animation change
439         - gallery: get the width correctly
440         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
441         - collapsible: Add collapse/expand animation (VI)
442         - datetimepicker: VI update
443         - JQM: set transition to pop as default
444         - tabbar : bug fix in case none li element case
445         - scrollview: fix the drag bug
446         - Button: Button icon scrolltop, left has beed added
447         - Swipe: VI update and swipe speed has been changed
448         - jqm: fix errors in patch files
449         - unit-test: swipe: fixed the destroy test
450
451 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
452         - Revert "[checkboxradio] exception handling for input"
453                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
454                 Tizen style supports no-label radio and checkbox when making lists.
455                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
456
457 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
458 - Fix:
459         - modify segment background
460         - rearrange check, radio input
461         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
462         - button: style has beed added(box,circle,nobg,round)
463         - favorite resource added
464         - demo/tizen-winsets: add footer and back button
465         - remove autodividers unit test
466         - add divider for tabbar
467         - checkboxradio: exception handling for input
468         - segment control backward compatiblity
469         - Fix collapsible unit-test
470         - remove toggleswitch
471         - add patch for remove segment text
472 - Spec changes:
473         - replace controlbar to tabbar
474
475 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
476 - FIX:
477         - slider: add image
478         - button: data-icon support, styles fix
479         - progressbar: modify the background
480         - scrollview: auto scrolling bug fix
481         - pagelayout: IME concept is changed
482 - Spec changes:
483         - dialogue: add edit mode
484         - nocontents: removed
485         - pagecontrol: removed
486         - dayselector: removed
487         - expandablelist: removed
488
489 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
490 - FIX:
491         - chang searchbar/slider images
492         - delete redundant button images
493 - Spec changes:
494         - Change widget name: shortcutscroll -> fastscroll
495
496 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
497 - FIX:
498         - jqm1.2: Change collapsible style to meet expandable list
499         - remove jquery-geo-1.0.a4
500         - unit-test: rename from imageslider to gallery
501         - nocontent: add warning message
502         - Handler: Fix issues in jqm1.2
503         - Multimediaview: modify APIs & comments
504         - Mapview: Fix issues in jqm1.2
505         - JQM: clean up patches
506         - Swipelist: refactoring swipelist
507         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
508         - rearrange button's data-icon resources
509 - Spec changes:
510         - Virtualgrid: remove option ('data-itemcount')
511         - gallery: rename the widget from imageslider to gallery
512         - add new style for searchbar
513         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
514
515 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
516 - FIX:
517         - fix jslint error
518         - remove unused files
519         - change naviframe style
520 - Spec changes:
521         - applied jQuery Mobile 1.2.0
522         - remove optionheader
523
524 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
525 - FIX:
526         - fix unit tests
527         - remove unused theme files
528         - timepicker: text position fix
529         - scrollview: set dragstop when mouse is out of window
530         - listview: fix margin
531 - Spec changes:
532         - support data-framework-viewport-width
533
534 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
535 - FIX:
536         - dayselector: fix size
537         - remove unised styles
538         - divider: set non-press effect to default option
539         - popupwindow: fix window closing failure
540         - handler: GUI implementation
541         - TC: fix unit TCs
542         - scrollview: fix padding size
543 - Spec changes:
544         - Remove color widgets
545         - add $.tizen.pkgVersion for SDK
546 - Etc.
547         - JSDuck documents
548
549 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
550 - FIX:
551         - Many winsets: Fix layout
552         - Footer: fix position to bottom
553 - Spec changes:
554         - Remove color widgets
555
556 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
557 - FIX:
558         - Many widgets: New UX 0.6 theme implementation
559         - widgetex: init speed up
560         - scrollview: fix scrollbar and scale animation
561         - scrollview: fix scroll position when updatelayout is triggered
562         - header/footer: make textselection disable, except input type="text"
563
564 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
565 - FIX:
566         - Remove tizen-black theme package description
567
568 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
569 - FIX:
570         - Fix theme name to meet the change of system theme name: white->tizen
571         - Popupwindow: fix left position
572         - Remove black theme
573         - footer: remove label, legend drawing
574 - Spec changes:
575         - UX guide v0.4 : button, layout
576
577 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
578 - FIX:
579         - scrollview: Fix outer scroll amount
580         - tabbar: fix tapping twice
581         - popupwindow: fix left position
582
583 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
584 - FIX:
585         - expandablelist: icon color fix
586         - scrollview: Fix xy scroll
587         - footer: Remove dummy div
588         - Make string concatnation effective in inline-protos.sh
589 - Spec changes:
590         - refresh header/footer when drag&drop event is fired in GUI builder
591         - searchbar: delete cancel button
592         - don't trigger updatelayout event when keyup event comes
593
594 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
595 - FIX:
596         - Toggleswitch: Change event name from 'changed' to 'change'
597         - Notification: Revert interval feature
598
599 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
600 - FIX:
601         - Fix SMACK manifest bug (S1-9098)
602
603 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
604 - FIX:
605         - handler: don't append a handler if handler is not enabled
606         - scrollview: use static value
607         - datetimepicker: fix date-format HH display error
608 - ETC:
609         - provide jquery.min.js
610         - barlayout: codes clean
611         - remove unused file
612
613 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
614 - FIX:
615         - listview: change focused color
616         - multibuttonentry: code refactoring
617         - datetimepicker: modify date format when triggered date-changed event
618         - slider: fix the top of slider bar
619         - add event blocker when load a first page
620
621 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
622 - ETC.
623         - Move SMACK manifest files to the top SRCDIR
624
625 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
626 - FIX:
627         - Popup: Do not focus container
628         - Header: show backbutton when both tabbar and header are present together
629         - Multi button entry: text ellipsis, code refactoring
630
631 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
632 - ETC.
633         - Apply SMACK manifest
634
635 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
636 - FIX:
637         - JSLINT code clean-up
638         - scrollview: firefox support
639         - scrollview: fix finding slider handle
640         - list: tweak text ellipsis
641         - checkbox: fix selecting wrong label tag (N_SE-8370)
642         - imageslider: check parameter
643         - smallpopup: fix position
644         - searchbar: fix 'clear' button size
645 - Spec changes:
646         - scrollview: support outer scroll
647         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
648         - remove S/W IME control
649
650 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
651 - FIX:
652         - Add missing icon: controlbar
653         - scrollview: tune scrolling animatio ninterval
654         - datetimepicker: digit/triangle position
655         - datetimepicker: fix day overflow issue
656 - Spec changes:
657         - scrollview: show scrollbar when page is showed
658         - scrollview: disable outer scroll
659         - extendablelist: change api with legacy support
660         - add ui-text-ellipsis class
661
662 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
663 - FIX:
664         - scrollveiw: fix height of view
665         - searchbar: support placeholder
666 - Spec changes:
667         - add ui-text-ellipsis class
668
669 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
670 - FIX:
671         - scrollview: scrolling bug fix
672         - controlbar: fix width of controlbar item
673 - Spec changes:
674         - searchbar: don't hide icon
675         - popup: update JQM poup widget
676
677 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
678 - FIX:
679         - controlbar: set correct controlbar width of last element
680         - slider: get popup enable value correctly
681         - use Date.now() instead of (new Data()).getTime()
682         - popupwindow: fix the background color of popup scroller
683         - listview: add padding-left to expandable list
684         - add ellipsis for title area support
685
686 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
687 - FIX:
688         - swipelist: show list items correctly
689         - datetimepicker: set last day, if day is overflowed
690 - Spec changes:
691         - controlbar: update icons
692
693 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
694 - FIX:
695         - notification: fix typo
696 - Spec changes:
697         - controlbar: update icons
698
699 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
700 - FIX:
701         - multimediaview: video progress bar display normally for too samll
702         - segmentcontrol: remove media query
703         - scrollview: add outer scroll condition
704         - datetimepicker: modify triangle size
705         - popupwindow: set the screen height explicitly
706         - notification: add multiline text
707 - Spec changes:
708         - mutibuttonentry: support new GUI
709         - virtualgrid: support new GUI
710
711 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
712 - FIX:
713         - radio/check button : button size bug fix
714
715 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
716 - FIX:
717         - build error fixed
718
719 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
720 - FIX:
721         - listview: style fix, remove filter placeholder
722         - controlbar: divide styles
723         - scrollview: don't skip dragging when click button or inputbox
724         - slider: trim the text on text slider
725 - Spec changes:
726         - remove gray and blue theme
727         - add white and black theme
728         - support new GUI guide
729
730 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
731 - FIX:
732         - fix coment of version tag
733
734 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
735 - FIX :
736         - button: fix alignment
737         - listview: adjust the main text width
738         - virtualgrid: refactoring
739 - Spec changes:
740         - transition: support JQM 1.1.0 transitions
741         - scrollview: support the outer scroll
742         - notification: remove interval feature
743
744 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
745 - FIX :
746         - checkboxRadio: Add left/right padding
747         - button: custom button & icon position
748         - virtuallist: remove 'recreate' test
749 - Spec changes:
750         - header/footer: enable/disable support
751
752 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
753 - FIX :
754         - expandablelist: modify show animation
755         - virtualgrid: Redesign programming interface
756         - popupwindow: code clean and fixed issues
757         - pagelayout: fix content height
758         - license file update
759         - virtuallist: Change programming interface
760         - datetimepicker: getting days correctly
761         - searchbar: set to hidden when cancel button is hide
762         - White theme title font tuning
763 - Spec changes:
764         - default theme tizen-gray to tizen-white
765         - set default page transition to none
766
767 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
768 - FIX :
769         - Back Button : enlarge backbutton click size for white theme
770 - Feature :
771         - Expandable List : Add refresh api
772 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
773 - FIX :
774         - click event touch threshold tuning
775
776 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
777 - FIX : 
778         - Add back button highlight effect for white theme
779
780 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
781 - FIX : 
782         - IME checkroutine update, improve relayout on resize event
783         - Add highlight effect for radio button list 
784         - Scrollview : fix condition of updatelayout event
785 - Feature : progressing : add show/hide api
786
787 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
788 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
789         add default theme option on buttonMarkup for tizen theme
790         [searchbar] first fix : focus/blur fixed
791         back button does not work when long press
792         scrollview: don't auto scrolling if resizing area is too large
793 - Feature : notification : add api to set the icon at tickernoti
794         demo : update the list sample demo
795         Support tizen default theme
796
797 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
798 - Improvements & Bugfixes
799    - HOTFIX: Revert template function with jquery.template
800
801 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
802 - Improvements & Bugfixes
803    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
804 - Spec changes
805    - $.tizen.loadTheme() function accepts theme name as arguement
806    - Scrollview supports 'updatelayout' callback
807
808 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
809 - Improvements & Bugfixes
810    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
811
812 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
813 - Improvements & Bugfixes
814    - Add tizen-white theme package, to make rpm build to be finished
815
816 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
817 - Improvements & Bugfixes
818    - Set 'slide' as default page transition effect, by JQM patch
819
820 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
821 - Improvements & Bugfixes
822    - Fix IME show/hide algorithm
823    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
824
825 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
826 - Improvements & Bugfixes
827    - Fix notification position
828    - Fix unit tests
829
830  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
831 - Spec changes
832         - JQM 1.1 upgrade
833 - Improvements & Bugfixes
834         - Transform3D support on scrollview
835         - Page layout supports IME control
836         - Mapview supports pinch zoom on JQM 1.1
837         - Fix wrong character on button in minified version
838         - Virtualgrid supports scrollbar
839         - Lots of bugfixes
840
841 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
842 - Spec changes
843         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
844         - imageslider : supports 'resize' event.
845         - listview : listview has 1px padding-bottom.
846         - loader : Change global namespace, from S to $.tizen.
847         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
848 - Improvements & Bugfixes
849         - Scrollview : supports 'translate3d', instead of 'translate'.
850         - notification : reset timer when 'show' or 'refresh' event.
851         - JQM patch : Fix vclick event triggered twice.
852 - Etc.
853         - Add & fix unit tests.
854
855 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
856 - Spec changes
857         - mapview : new widget.
858         - notification : add .refresh() API.
859         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
860 - Improvements & Bugfixes
861         - Support minified CSS.
862         - loader : Fix & refactor 'loading globalize culture file' routine.
863         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
864         - Many more bugfixes.
865 - Etc.
866         - Add many unit tests.
867         - Fix test coverage instrumentation tool to work with current source code.