Export 0.1.56
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.1.56
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34
35 ###############################
36 %package -n web-ui-fw-theme-tizen-gray
37 BuildArch:  noarch
38 Summary:    Tizen Web UI Framework Theme : tizen-gray
39 %Description -n web-ui-fw-theme-tizen-gray
40     Tizen Web UI Framework Theme : tizen-gray
41
42 ###############################
43 %package -n web-ui-fw-theme-tizen-black
44 BuildArch:  noarch
45 Summary:    Tizen Web UI Framework Theme : tizen-black
46 %Description -n web-ui-fw-theme-tizen-black
47     Tizen Web UI Framework Theme : tizen-black
48 %files -n web-ui-fw-theme-tizen-black
49 %manifest web-ui-fw-theme-tizen-black.manifest
50 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
51
52 ###############################
53 %package -n web-ui-fw-theme-tizen-white
54 BuildArch:  noarch
55 Summary:    Tizen Web UI Framework Theme : tizen-white
56 %Description -n web-ui-fw-theme-tizen-white
57     Tizen Web UI Framework Theme : tizen-white
58 %files -n web-ui-fw-theme-tizen-white
59 %manifest web-ui-fw-theme-tizen-white.manifest
60 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
61
62 ###############################
63 %package -n web-ui-fw-theme-default
64 BuildArch:  noarch
65 Summary:    Tizen Web UI Framework Theme : default
66 %Description -n web-ui-fw-theme-default
67     Tizen Web UI Framework Theme : default
68 %files -n web-ui-fw-theme-default
69 %manifest web-ui-fw-theme-default.manifest
70 /usr/share/tizen-web-ui-fw/*/themes/default
71
72 ###############################
73 %package -n web-ui-fw-devel
74 BuildArch:  noarch
75 Summary:    Tizen Web UI Framework Developer's files
76 %Description -n web-ui-fw-devel
77     Tizen Web UI Framework Developer's files
78 %files -n web-ui-fw-devel
79 /usr/share/tizen-web-ui-fw/bin
80 /usr/share/tizen-web-ui-fw/template
81
82 ###############################
83 %package -n web-ui-fw-demo-tizen-winsets
84 BuildArch:  noarch
85 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
86 %Description -n web-ui-fw-demo-tizen-winsets
87     Tizen Web UI Framework Demo Application: tizen winset demo
88 %files  -n web-ui-fw-demo-tizen-winsets
89 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
90
91
92 ###############################
93 %changelog
94 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
95 - FIX:
96         - Toggleswitch: Change event name from 'changed' to 'change'
97         - Notification: Revert interval feature
98
99 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
100 - FIX:
101         - Fix SMACK manifest bug (S1-9098)
102
103 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
104 - FIX:
105         - handler: don't append a handler if handler is not enabled
106         - scrollview: use static value
107         - datetimepicker: fix date-format HH display error
108 - ETC:
109         - provide jquery.min.js
110         - barlayout: codes clean
111         - remove unused file
112
113 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
114 - FIX:
115         - listview: change focused color
116         - multibuttonentry: code refactoring
117         - datetimepicker: modify date format when triggered date-changed event
118         - slider: fix the top of slider bar
119         - add event blocker when load a first page
120
121 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
122 - ETC.
123         - Move SMACK manifest files to the top SRCDIR
124
125 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
126 - FIX:
127         - Popup: Do not focus container
128         - Header: show backbutton when both tabbar and header are present together
129         - Multi button entry: text ellipsis, code refactoring
130
131 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
132 - ETC.
133         - Apply SMACK manifest
134
135 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
136 - FIX:
137         - JSLINT code clean-up
138         - scrollview: firefox support
139         - scrollview: fix finding slider handle
140         - list: tweak text ellipsis
141         - checkbox: fix selecting wrong label tag (N_SE-8370)
142         - imageslider: check parameter
143         - smallpopup: fix position
144         - searchbar: fix 'clear' button size
145 - Spec changes:
146         - scrollview: support outer scroll
147         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
148         - remove S/W IME control
149
150 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
151 - FIX:
152         - Add missing icon: controlbar
153         - scrollview: tune scrolling animatio ninterval
154         - datetimepicker: digit/triangle position
155         - datetimepicker: fix day overflow issue
156 - Spec changes:
157         - scrollview: show scrollbar when page is showed
158         - scrollview: disable outer scroll
159         - extendablelist: change api with legacy support
160         - add ui-text-ellipsis class
161
162 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
163 - FIX:
164         - scrollveiw: fix height of view
165         - searchbar: support placeholder
166 - Spec changes:
167         - add ui-text-ellipsis class
168
169 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
170 - FIX:
171         - scrollview: scrolling bug fix
172         - controlbar: fix width of controlbar item
173 - Spec changes:
174         - searchbar: don't hide icon
175         - popup: update JQM poup widget
176
177 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
178 - FIX:
179         - controlbar: set correct controlbar width of last element
180         - slider: get popup enable value correctly
181         - use Date.now() instead of (new Data()).getTime()
182         - popupwindow: fix the background color of popup scroller
183         - listview: add padding-left to expandable list
184         - add ellipsis for title area support
185
186 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
187 - FIX:
188         - swipelist: show list items correctly
189         - datetimepicker: set last day, if day is overflowed
190 - Spec changes:
191         - controlbar: update icons
192
193 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
194 - FIX:
195         - notification: fix typo
196 - Spec changes:
197         - controlbar: update icons
198
199 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
200 - FIX:
201         - multimediaview: video progress bar display normally for too samll
202         - segmentcontrol: remove media query
203         - scrollview: add outer scroll condition
204         - datetimepicker: modify triangle size
205         - popupwindow: set the screen height explicitly
206         - notification: add multiline text
207 - Spec changes:
208         - mutibuttonentry: support new GUI
209         - virtualgrid: support new GUI
210
211 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
212 - FIX:
213         - radio/check button : button size bug fix
214
215 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
216 - FIX:
217         - build error fixed
218
219 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
220 - FIX:
221         - listview: style fix, remove filter placeholder
222         - controlbar: divide styles
223         - scrollview: don't skip dragging when click button or inputbox
224         - slider: trim the text on text slider
225 - Spec changes:
226         - remove gray and blue theme
227         - add white and black theme
228         - support new GUI guide
229
230 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
231 - FIX:
232         - fix coment of version tag
233
234 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
235 - FIX :
236         - button: fix alignment
237         - listview: adjust the main text width
238         - virtualgrid: refactoring
239 - Spec changes:
240         - transition: support JQM 1.1.0 transitions
241         - scrollview: support the outer scroll
242         - notification: remove interval feature
243
244 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
245 - FIX :
246         - checkboxRadio: Add left/right padding
247         - button: custom button & icon position
248         - virtuallist: remove 'recreate' test
249 - Spec changes:
250         - header/footer: enable/disable support
251
252 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
253 - FIX :
254         - expandablelist: modify show animation
255         - virtualgrid: Redesign programming interface
256         - popupwindow: code clean and fixed issues
257         - pagelayout: fix content height
258         - license file update
259         - virtuallist: Change programming interface
260         - datetimepicker: getting days correctly
261         - searchbar: set to hidden when cancel button is hide
262         - White theme title font tuning
263 - Spec changes:
264         - default theme tizen-gray to tizen-white
265         - set default page transition to none
266
267 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
268 - FIX :
269         - Back Button : enlarge backbutton click size for white theme
270 - Feature :
271         - Expandable List : Add refresh api
272 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
273 - FIX :
274         - click event touch threshold tuning
275
276 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
277 - FIX : 
278         - Add back button highlight effect for white theme
279
280 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
281 - FIX : 
282         - IME checkroutine update, improve relayout on resize event
283         - Add highlight effect for radio button list 
284         - Scrollview : fix condition of updatelayout event
285 - Feature : progressing : add show/hide api
286
287 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
288 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
289         add default theme option on buttonMarkup for tizen theme
290         [searchbar] first fix : focus/blur fixed
291         back button does not work when long press
292         scrollview: don't auto scrolling if resizing area is too large
293 - Feature : notification : add api to set the icon at tickernoti
294         demo : update the list sample demo
295         Support tizen default theme
296
297 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
298 - Improvements & Bugfixes
299    - HOTFIX: Revert template function with jquery.template
300
301 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
302 - Improvements & Bugfixes
303    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
304 - Spec changes
305    - $.tizen.loadTheme() function accepts theme name as arguement
306    - Scrollview supports 'updatelayout' callback
307
308 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
309 - Improvements & Bugfixes
310    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
311
312 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
313 - Improvements & Bugfixes
314    - Add tizen-white theme package, to make rpm build to be finished
315
316 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
317 - Improvements & Bugfixes
318    - Set 'slide' as default page transition effect, by JQM patch
319
320 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
321 - Improvements & Bugfixes
322    - Fix IME show/hide algorithm
323    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
324
325 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
326 - Improvements & Bugfixes
327    - Fix notification position
328    - Fix unit tests
329
330  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
331 - Spec changes
332         - JQM 1.1 upgrade
333 - Improvements & Bugfixes
334         - Transform3D support on scrollview
335         - Page layout supports IME control
336         - Mapview supports pinch zoom on JQM 1.1
337         - Fix wrong character on button in minified version
338         - Virtualgrid supports scrollbar
339         - Lots of bugfixes
340
341 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
342 - Spec changes
343         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
344         - imageslider : supports 'resize' event.
345         - listview : listview has 1px padding-bottom.
346         - loader : Change global namespace, from S to $.tizen.
347         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
348 - Improvements & Bugfixes
349         - Scrollview : supports 'translate3d', instead of 'translate'.
350         - notification : reset timer when 'show' or 'refresh' event.
351         - JQM patch : Fix vclick event triggered twice.
352 - Etc.
353         - Add & fix unit tests.
354
355 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
356 - Spec changes
357         - mapview : new widget.
358         - notification : add .refresh() API.
359         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
360 - Improvements & Bugfixes
361         - Support minified CSS.
362         - loader : Fix & refactor 'loading globalize culture file' routine.
363         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
364         - Many more bugfixes.
365 - Etc.
366         - Add many unit tests.
367         - Fix test coverage instrumentation tool to work with current source code.