0.2.20 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.20
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js
33 /usr/share/tizen-web-ui-fw/latest
34 /usr/share/tizen-web-ui-fw/VERSION
35
36 ###############################
37 %package -n web-ui-fw-theme-tizen-gray
38 BuildArch:  noarch
39 Summary:    Tizen Web UI Framework Theme : tizen-gray
40 %Description -n web-ui-fw-theme-tizen-gray
41     Tizen Web UI Framework Theme : tizen-gray
42
43 ###############################
44 %package -n web-ui-fw-theme-tizen-white
45 BuildArch:  noarch
46 Summary:    Tizen Web UI Framework Theme : tizen-white
47 %Description -n web-ui-fw-theme-tizen-white
48     Tizen Web UI Framework Theme : tizen-white
49 %files -n web-ui-fw-theme-tizen-white
50 %manifest web-ui-fw-theme-tizen-white.manifest
51 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
52 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
53
54 ###############################
55 %package -n web-ui-fw-theme-default
56 BuildArch:  noarch
57 Summary:    Tizen Web UI Framework Theme : default
58 %Description -n web-ui-fw-theme-default
59     Tizen Web UI Framework Theme : default
60 %files -n web-ui-fw-theme-default
61 %manifest web-ui-fw-theme-default.manifest
62 /usr/share/tizen-web-ui-fw/*/themes/default
63
64 ###############################
65 %package -n web-ui-fw-devel
66 BuildArch:  noarch
67 Summary:    Tizen Web UI Framework Developer's files
68 %Description -n web-ui-fw-devel
69     Tizen Web UI Framework Developer's files
70 %files -n web-ui-fw-devel
71 /usr/share/tizen-web-ui-fw/bin
72 /usr/share/tizen-web-ui-fw/template
73
74 ###############################
75 %package -n web-ui-fw-demo-tizen-winsets
76 BuildArch:  noarch
77 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
78 %Description -n web-ui-fw-demo-tizen-winsets
79     Tizen Web UI Framework Demo Application: tizen winset demo
80 %files  -n web-ui-fw-demo-tizen-winsets
81 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
82
83
84 ###############################
85 %changelog
86
87 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
88         - JQM Navigation : remove page min-height
89         - Pagelayout : add refresh to pagelayout
90         - Tokentextarea: Changes 'remove' tests to asyncTest
91         - Popup: input tag alignment has been fixed
92         - Tokentextarea: add/remove events are deprecated.
93         - Contextpopup: Support horizontal list
94         - Select: icon z-index has been deleted
95         - Tizenwinset: ui widget order has been changed
96         - Tool: make web app template disable context menu by default
97         - Tizen-winset: change tips for using listview
98         - Loader: calculate font size with mobile width
99         - Naviframe : fix header's back button position
100         - TizenWinset : move locale info to another file
101
102 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
103         - JQM Navigation : remove page min-height
104         - Pagelayout : add refresh to pagelayout
105         - Tokentextarea: Changes 'remove' tests to asyncTest
106         - Popup: input tag alignment has been fixed
107         - Tokentextarea: add/remove events are deprecated.
108         - Contextpopup: Support horizontal list
109         - Select: icon z-index has been deleted
110         - Tizenwinset: ui widget order has been changed
111         - Tool: make web app template disable context menu by default
112         - Tizen-winset: change tips for using listview
113         - Loader: calculate font size with mobile width
114         - Naviframe : fix header's back button position
115         - TizenWinset : move locale info to another file
116
117 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
118         - Tizen-winset: Support accessibility for tizen-winset
119         - Orientation : add orientataionchange to tizen-winset
120         - Tokentextarea: Adjusts VI effect for add/remove block
121         - splitview: Support accessibility for splitview
122         - Tizen-winset: Date/time picker guide text has been fixed
123         - Popup: context popup arrow position, setTimeout open method bug have been fixed
124         - fastscroll: Add new indexString API to Fastscroll widget.
125         - splitview: Add new widget
126         - gallery3d: Add new widget
127         - Scrollview : disable VI effect for gesture event
128         - Scrollview : disable SIP outerscroll
129         - Tizen-winset: resize VirtualGrid widget in demo
130         - Tizen-winsets: Refactor searchbar subpages
131         - Tizen-winsets: Remove depracated usage of virtuallist
132         - Tizen-winsets: Move js code from main.js to subpages
133         - Tizen-winsets: Refactor virtual grid demo subpages
134         - Tizen-winsets: Move css files from index to proper subpages
135         - Tizen-winsets: Refactor list dialogue edit subpage
136         - Tizen-winsets: Refactor pagelayout subpages
137         - Tizen-winsets: Refactor tips subpages
138         - Tizen-winsets: Move subpages popup files from index.html
139         - Tizen-winsets: Move subpages javascript files from index.html
140         - virtualgrid: fix improperly merged codes
141         - ColorTheme : remove unused color value(1st)
142         - Scrollview : change scrollbar draw
143         - Popup: Apply popup background dim
144         - Tizen-winsets: Move tokentextarea demo to external page.
145         - Tizen-winsets: Move tabbar persist demo to external page.
146         - Tizen-winsets: Remove notImplemented page
147         - Tizen-winsets: Move slider demo page to external subpage
148         - Tizen-winsets: Fix ids, remove duplicated names for sliders
149         - Tizen-winsets: Remove event for changing theme
150         - tool: Fix wgt sample app generator tool to make apps be installed
151         - demos : change live to on
152         - build: Trim compiled CSS files
153         - Gallery: CSS left -> translate or translate3D
154         - Tokentextarea: Disfunctional APIs fixed.
155
156 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
157         - build: Fix Makefile to add globalize to the minified lib
158         - build-tools : upgrade less to v1.3.3
159         - demos : change normal js path to minified js
160         - Theme : remove reduantant less - dayselector, optionheader, nocontents
161         - multimediaview : fix full-screen mode.
162         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
163         - Extendablelist: Added min-height "load more button" in listitem
164         - virtualgrid: adjusts VI effect for an overflow action
165         - ControlGroup : change ellipsis font color (press/normal)
166         - multimediaview: Add an error message to Multimediaview
167         - virtualgrid: adjusts triple flick gesture
168         - scrollview: add function for getting width of view
169         - scrollview: adds support x axis gesture scroll
170         - multimediaview : fix audio control
171         - tabbar : tabbar slide animation change
172         - TizenWinsetDemo : 2line-text demo bug fix
173         - collapsible: Fix demo to show radio button correctly in the collapsible list
174         - collapsible: Set listitem position to relative
175         - UnitTC: added list divider unit test
176         - Style: unnecessary color codes have been deleted and modified
177         - build: Module build implementation
178         - UnitTC: Additional unit testcases have been added
179         - listview : bug fix
180         - Naviframe : remove back button's hover effect
181         - TizenDemo : remove back button
182         - Transition: added more-button vi
183         - pinch: added new event called pinch
184         - Popup: css word-wrap:break-word has been added
185         - virtualgrid: memory leak fix
186         - progress: set to init state at pending bar
187         - progress: add margin of top/bottom
188         - unit-test: split progress test and progressbar test
189         - Tizen-winset: Context popup sample page guide text has been changed
190         - multimediaview: fix the height of widget when full-screen mode
191         - JQM: performance tuning
192
193 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
194         - DialogueList : delete border top value / add sample's text ellipsis
195         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
196         - Multimediaview: Fix mute function
197         - Tizen-winset: list vi index guide textbox has been removed
198         - Tizen-winset: custom button texts have been changed
199         - slider: move popup div to out of content
200         - TizenWinset: disable context popup in multimediaview
201         - Swipe: wrong style name has been fixed
202         - demo: add the sample at dialogue list
203         - listview: Add ui-li-has-right-btn class with toggleswitch
204         - WinsetDemo : change wrong title name
205
206 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
207         - demo: checkbox: reduce button's width
208         - tabbar : delete right/left tab animation color
209         - scrollview: fix the scroll position at keydown event
210         - groupControl : change footer groupControl from min-width to percentage
211         - scrollview: get height of softkeyboard correctly
212         - tizen-winset: Add name attr to all radio inputs
213         - virtualgrid: changes event binding target
214         - scrollview: skip the drag if target is textarea
215         - scrollview: skip the dragging of parent scrollview
216         - scrollview: apply the scaling ratio to the soft keyboard
217         - demos: apply disabled option in textarea
218         - demo: remove unused codes
219         - demo: datetimepicker: show selected date correctly
220         - listview: Adjust bubble listitem width and margin
221         - pagelayout : change external refresh call and ime status follow only current page
222         - toggleSwitch : bug fix
223         - unit-test: slider: fix the move test
224         - handler: fix jslint error
225         - ToggleSwitch : set image toggleswitch background attribute
226
227 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
228         - slider: increase the text width(N_SE-23397)
229         - virtualgrid: DOM element leak fix
230         - header: Move button top higher in header with tabbar(N_SE-22253)
231         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
232         - handler: bug fix (regarding enableHandler function )
233         - demo:fix syntax error
234
235 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
236         - demo: fix demo using tizen device API
237         - multimediaview: reset the height of container
238         - input: modify css correctly
239         - multimediaview: fix the height of widget
240         - gallery: bind create event
241         - progress: bind create event
242         - slider: bind create event
243         - progressbar: bind create event
244         - progressbar: event trigger correctly
245         - popup: fix height of popup scroller
246         - build: add continue option to jslint
247         - ctxpopup demo : bug fix
248         - demo: fix searchbar demo to use different IDs
249         - demo: extract routine executing Tizen device API
250         - toggleswitch : set default margin, delete box padding
251
252 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
253         - virtuallist: Prevent replacing contents on nonexist element
254         - JQM: Trim text in listitem to get index in autodivider
255         - JQM: Remove trailing whitespace in jqm patch
256         - scrollview: get the height including margin
257         - multimediaview: bug fix ( scrolling in full-screen mode )
258         - virtuallist: set listitem width to exclude listitem left/right margin
259         - demo: fix virtuallist sample layout
260         - progress: set the position explicitly
261         - progress: rename from progressing to progress
262         - build: remove unused files
263         - searchbar: fix jslint errors
264         - src: fix file permissions
265         - button : change jump left icon
266
267 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
268         - theme : button icon - scrolltop, scrolleft icon changed.
269         - build: cleanaup Makefile
270         - pagelayout: fix jslint error
271         - virtualgrid: Fix jslint errors
272         - tabbar : jslint bug error fix
273         - build: add regexp option to jslint
274         - virtuallist: fix jslint errors
275         - handler: Apply the exceptional principle for scrollbar on Handler.
276         - build: remove unused copyright
277         - loader: extract log class for tizen web, and fix jslint errors
278         - loader: Viewport width is set to document width
279         - popupwindow: fix jslint error
280         - build: fix Makefile for tizen-white theme
281         - build: remove unused libraries
282         - datetimepicker: fix jslint error
283         - slider: fix jslint error
284         - demo: remove deprecated demos
285         - pagelayout : change to call relayout with this page
286         - Tokentextarea: Block size error fixed.
287         - handler: bug fix (handler activation)
288
289 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
290         - demo: clear input text value with cancel button click
291         - demo: Adjust textarea height automatically
292         - naviframe : bug fix
293         - tabbar : bug fix
294         - Fastscroll: popup position has been changed
295         - Button: custom button icon path, margin have been changed
296         - toggleswitch : bug fix
297         - slider: increase the margin
298         - datetimepicker: close the popup after select the value
299         - unit-test : add page backbutton control test
300         - Demo: added guide text and change input type in list vi
301         - remove legacy codes : jquery-geo
302         - Datetimepicker: text-main max-width has been removed
303         - Radio: control group border has been removed
304         - Demo: remove 'tab' space
305         - UnitTC: swipe unit tc has been fixed
306         - UnitTC: jQuery path has been fixed
307         - Button: bug fix when button has not a text
308         - tizen-winset: timepicker: demo title is changed
309
310 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
311         - tizen-winsets: codes cleanup
312         - datetimepicker: date calibration when year is changed
313         - Demo: textarea size has been changed
314         - Demo: Naviframe morebutton demo has been changed
315         - remove unused unit test cases : gallery3d
316         - tizen-winset: remove links
317
318 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
319         - gallery: use timeout function instead of interval
320         - Tokentextarea: Display error fixed.
321         - scrollview: Fix not selector to respond with jQuery1.8.2
322         - tabbar: remove the width of last element
323         - Demo: apply css 'user-select:none'
324         - Button: guide text has been shorten
325         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
326         - virtuallist: Fix mistyping
327         - demo: Fix tizen function namespace in demo
328         - virtuallist: Rewrite listitem replacing algorithm
329         - fastscroll: modify from not selector to function
330         - extendablelist: Fix unit-test
331         - tabbar : prefix to tabbar scroll event
332         - Popupwindow: removed unvalid selector in jquery 1.8.2
333         - slider: adjust handle text as length of value
334         - Demo: 3 buttons in popup text has been changed
335         - src: codes cleanup
336         - demo : remove trailing empty strings
337         - demo : rename TizenWinset list items
338         - button : change from long text list to multiline list
339         - build: Remove JQM1.1.0 patches
340         - Popup: Apply tizen style popup and attribute support
341         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
342         - UnitTest: folder and file renamed, QUnit path was modified
343         - tizen-winsets: button: fix textarea width
344         - Swipe: event name error has been fixed
345
346 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
347         - Button: button padding has been updated
348         - virtuallist: fix unique listitem ID bug
349         - checkbox, radio : change display attr
350         - Button: bug fix ( when data style circle button on text )
351         - handler: bug fix (when scrolling with multi selection)
352         - JQM: adjust patch number
353         - gallery: show the widget after pageshow
354         - TokenTextArea : resource add ( press image )
355         - gallery: adds function that set the index to value API
356         - configure: set TIZEN default configures
357         - footer: h tag display attribute value has been changed
358         - buttons : demo bug fix
359         - searchbar : demo page bug fix
360         - tizen demo : bug fix
361         - build: remove JQM1.1.0
362         - Tokentextarea: Fix issues
363         - scrollview: block the multi touch
364         - list : dialogue list demo change
365         - pagelayout : update dynamic control
366         - Demo: Context popup close method has been changed
367
368 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
369         - slider: set text container's width as text length
370         - Timepicker: li max-width has been changed
371         - remove experimental feature - mapview.
372         - scrollview: added conditions for finding slider
373         - UnitTC: Pass,error count save method has been changed
374         - confix.xml: default config added for tizen basic applications
375         - Swipe: p tag margin value is set '0'
376         - packaging: remove unused file
377         - tabbar : bug fix
378         - list demo : bug fix
379         - tizen-winsets: gallery: move to new section
380         - tizen-winsets: autodivider: removes link of list
381         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
382         - pagelayout : padding calculate change, ime footer check changed
383         - tizen-winsets: searchbar: scroll to the top when type the character
384         - searchbar : bug fix
385         - demo: Fix virtuallist demo following new list style
386         - demo: Add word-wrap:break-word and remove parag. width
387         - Demo: button max-width has been set( 3 buttons in popup )
388         - back button control demo : bug fix
389         - toggleswitch : demo page modify
390         - slider: add margin-top and margin-bottom
391         - tabbar demo : bug fix
392         - Popup: IME hide when popup is closed
393         - token textarea : bug fix
394         - Timepicker: change get attribute method
395         - footer demo : bug fix
396         - unit-test: gallery: add new APIs
397         - gallery: adds support new APIs
398
399 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
400         - JQM: patches cleanup
401         - Button: data-corners attribute has been added
402         - unit-test: slider: fix class name of background
403         - progressbar, slider: fix less variable typo
404         - Tabbar : VI update
405         - notification: add top position at fix class
406         - demo: entry demo page change
407         - css: .ui-disabled added
408         - tizen-winset: token textarea: remove back button at demo page
409         - theme: Remove unused less file
410         - pagelayout : content min height bug fix
411         - scrollview: skip the dragging when target is slider's handle
412         - scrollview: update and refactoring the scroll effect
413         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
414         - Swipe: demo page html error has been fixed
415         - listview: Add add/delete animation (VI)
416         - Popup: demo page has been modified
417         - tizen demo : bug fix
418         - searchbar : demo page change(change front button and add behaviour)
419         - pagelayout : add min height to content
420         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
421         - back button control demo : change url link to data-rel="back"
422         - loader: Skip loading theme CSS with a custom css code
423         - Button: support no-text in button
424         - collapsible: Fix syntax error
425         - slider: use data-highlight attribute
426         - collapsible: Rotate animation to collapsible heading icon
427         - toggleswitch : text switch bug fix
428         - remove candidates-calendarpicker
429         - Patch: Fix misc mistakes in JQM patches
430         - searchbar : animation change
431         - gallery: get the width correctly
432         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
433         - collapsible: Add collapse/expand animation (VI)
434         - datetimepicker: VI update
435         - JQM: set transition to pop as default
436         - tabbar : bug fix in case none li element case
437         - scrollview: fix the drag bug
438         - Button: Button icon scrolltop, left has beed added
439         - Swipe: VI update and swipe speed has been changed
440         - jqm: fix errors in patch files
441         - unit-test: swipe: fixed the destroy test
442
443 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
444         - Revert "[checkboxradio] exception handling for input"
445                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
446                 Tizen style supports no-label radio and checkbox when making lists.
447                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
448
449 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
450 - Fix:
451         - modify segment background
452         - rearrange check, radio input
453         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
454         - button: style has beed added(box,circle,nobg,round)
455         - favorite resource added
456         - demo/tizen-winsets: add footer and back button
457         - remove autodividers unit test
458         - add divider for tabbar
459         - checkboxradio: exception handling for input
460         - segment control backward compatiblity
461         - Fix collapsible unit-test
462         - remove toggleswitch
463         - add patch for remove segment text
464 - Spec changes:
465         - replace controlbar to tabbar
466
467 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
468 - FIX:
469         - slider: add image
470         - button: data-icon support, styles fix
471         - progressbar: modify the background
472         - scrollview: auto scrolling bug fix
473         - pagelayout: IME concept is changed
474 - Spec changes:
475         - dialogue: add edit mode
476         - nocontents: removed
477         - pagecontrol: removed
478         - dayselector: removed
479         - expandablelist: removed
480
481 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
482 - FIX:
483         - chang searchbar/slider images
484         - delete redundant button images
485 - Spec changes:
486         - Change widget name: shortcutscroll -> fastscroll
487
488 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
489 - FIX:
490         - jqm1.2: Change collapsible style to meet expandable list
491         - remove jquery-geo-1.0.a4
492         - unit-test: rename from imageslider to gallery
493         - nocontent: add warning message
494         - Handler: Fix issues in jqm1.2
495         - Multimediaview: modify APIs & comments
496         - Mapview: Fix issues in jqm1.2
497         - JQM: clean up patches
498         - Swipelist: refactoring swipelist
499         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
500         - rearrange button's data-icon resources
501 - Spec changes:
502         - Virtualgrid: remove option ('data-itemcount')
503         - gallery: rename the widget from imageslider to gallery
504         - add new style for searchbar
505         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
506
507 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
508 - FIX:
509         - fix jslint error
510         - remove unused files
511         - change naviframe style
512 - Spec changes:
513         - applied jQuery Mobile 1.2.0
514         - remove optionheader
515
516 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
517 - FIX:
518         - fix unit tests
519         - remove unused theme files
520         - timepicker: text position fix
521         - scrollview: set dragstop when mouse is out of window
522         - listview: fix margin
523 - Spec changes:
524         - support data-framework-viewport-width
525
526 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
527 - FIX:
528         - dayselector: fix size
529         - remove unised styles
530         - divider: set non-press effect to default option
531         - popupwindow: fix window closing failure
532         - handler: GUI implementation
533         - TC: fix unit TCs
534         - scrollview: fix padding size
535 - Spec changes:
536         - Remove color widgets
537         - add $.tizen.pkgVersion for SDK
538 - Etc.
539         - JSDuck documents
540
541 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
542 - FIX:
543         - Many winsets: Fix layout
544         - Footer: fix position to bottom
545 - Spec changes:
546         - Remove color widgets
547
548 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
549 - FIX:
550         - Many widgets: New UX 0.6 theme implementation
551         - widgetex: init speed up
552         - scrollview: fix scrollbar and scale animation
553         - scrollview: fix scroll position when updatelayout is triggered
554         - header/footer: make textselection disable, except input type="text"
555
556 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
557 - FIX:
558         - Remove tizen-black theme package description
559
560 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
561 - FIX:
562         - Fix theme name to meet the change of system theme name: white->tizen
563         - Popupwindow: fix left position
564         - Remove black theme
565         - footer: remove label, legend drawing
566 - Spec changes:
567         - UX guide v0.4 : button, layout
568
569 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
570 - FIX:
571         - scrollview: Fix outer scroll amount
572         - tabbar: fix tapping twice
573         - popupwindow: fix left position
574
575 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
576 - FIX:
577         - expandablelist: icon color fix
578         - scrollview: Fix xy scroll
579         - footer: Remove dummy div
580         - Make string concatnation effective in inline-protos.sh
581 - Spec changes:
582         - refresh header/footer when drag&drop event is fired in GUI builder
583         - searchbar: delete cancel button
584         - don't trigger updatelayout event when keyup event comes
585
586 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
587 - FIX:
588         - Toggleswitch: Change event name from 'changed' to 'change'
589         - Notification: Revert interval feature
590
591 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
592 - FIX:
593         - Fix SMACK manifest bug (S1-9098)
594
595 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
596 - FIX:
597         - handler: don't append a handler if handler is not enabled
598         - scrollview: use static value
599         - datetimepicker: fix date-format HH display error
600 - ETC:
601         - provide jquery.min.js
602         - barlayout: codes clean
603         - remove unused file
604
605 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
606 - FIX:
607         - listview: change focused color
608         - multibuttonentry: code refactoring
609         - datetimepicker: modify date format when triggered date-changed event
610         - slider: fix the top of slider bar
611         - add event blocker when load a first page
612
613 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
614 - ETC.
615         - Move SMACK manifest files to the top SRCDIR
616
617 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
618 - FIX:
619         - Popup: Do not focus container
620         - Header: show backbutton when both tabbar and header are present together
621         - Multi button entry: text ellipsis, code refactoring
622
623 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
624 - ETC.
625         - Apply SMACK manifest
626
627 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
628 - FIX:
629         - JSLINT code clean-up
630         - scrollview: firefox support
631         - scrollview: fix finding slider handle
632         - list: tweak text ellipsis
633         - checkbox: fix selecting wrong label tag (N_SE-8370)
634         - imageslider: check parameter
635         - smallpopup: fix position
636         - searchbar: fix 'clear' button size
637 - Spec changes:
638         - scrollview: support outer scroll
639         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
640         - remove S/W IME control
641
642 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
643 - FIX:
644         - Add missing icon: controlbar
645         - scrollview: tune scrolling animatio ninterval
646         - datetimepicker: digit/triangle position
647         - datetimepicker: fix day overflow issue
648 - Spec changes:
649         - scrollview: show scrollbar when page is showed
650         - scrollview: disable outer scroll
651         - extendablelist: change api with legacy support
652         - add ui-text-ellipsis class
653
654 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
655 - FIX:
656         - scrollveiw: fix height of view
657         - searchbar: support placeholder
658 - Spec changes:
659         - add ui-text-ellipsis class
660
661 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
662 - FIX:
663         - scrollview: scrolling bug fix
664         - controlbar: fix width of controlbar item
665 - Spec changes:
666         - searchbar: don't hide icon
667         - popup: update JQM poup widget
668
669 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
670 - FIX:
671         - controlbar: set correct controlbar width of last element
672         - slider: get popup enable value correctly
673         - use Date.now() instead of (new Data()).getTime()
674         - popupwindow: fix the background color of popup scroller
675         - listview: add padding-left to expandable list
676         - add ellipsis for title area support
677
678 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
679 - FIX:
680         - swipelist: show list items correctly
681         - datetimepicker: set last day, if day is overflowed
682 - Spec changes:
683         - controlbar: update icons
684
685 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
686 - FIX:
687         - notification: fix typo
688 - Spec changes:
689         - controlbar: update icons
690
691 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
692 - FIX:
693         - multimediaview: video progress bar display normally for too samll
694         - segmentcontrol: remove media query
695         - scrollview: add outer scroll condition
696         - datetimepicker: modify triangle size
697         - popupwindow: set the screen height explicitly
698         - notification: add multiline text
699 - Spec changes:
700         - mutibuttonentry: support new GUI
701         - virtualgrid: support new GUI
702
703 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
704 - FIX:
705         - radio/check button : button size bug fix
706
707 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
708 - FIX:
709         - build error fixed
710
711 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
712 - FIX:
713         - listview: style fix, remove filter placeholder
714         - controlbar: divide styles
715         - scrollview: don't skip dragging when click button or inputbox
716         - slider: trim the text on text slider
717 - Spec changes:
718         - remove gray and blue theme
719         - add white and black theme
720         - support new GUI guide
721
722 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
723 - FIX:
724         - fix coment of version tag
725
726 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
727 - FIX :
728         - button: fix alignment
729         - listview: adjust the main text width
730         - virtualgrid: refactoring
731 - Spec changes:
732         - transition: support JQM 1.1.0 transitions
733         - scrollview: support the outer scroll
734         - notification: remove interval feature
735
736 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
737 - FIX :
738         - checkboxRadio: Add left/right padding
739         - button: custom button & icon position
740         - virtuallist: remove 'recreate' test
741 - Spec changes:
742         - header/footer: enable/disable support
743
744 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
745 - FIX :
746         - expandablelist: modify show animation
747         - virtualgrid: Redesign programming interface
748         - popupwindow: code clean and fixed issues
749         - pagelayout: fix content height
750         - license file update
751         - virtuallist: Change programming interface
752         - datetimepicker: getting days correctly
753         - searchbar: set to hidden when cancel button is hide
754         - White theme title font tuning
755 - Spec changes:
756         - default theme tizen-gray to tizen-white
757         - set default page transition to none
758
759 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
760 - FIX :
761         - Back Button : enlarge backbutton click size for white theme
762 - Feature :
763         - Expandable List : Add refresh api
764 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
765 - FIX :
766         - click event touch threshold tuning
767
768 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
769 - FIX : 
770         - Add back button highlight effect for white theme
771
772 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
773 - FIX : 
774         - IME checkroutine update, improve relayout on resize event
775         - Add highlight effect for radio button list 
776         - Scrollview : fix condition of updatelayout event
777 - Feature : progressing : add show/hide api
778
779 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
780 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
781         add default theme option on buttonMarkup for tizen theme
782         [searchbar] first fix : focus/blur fixed
783         back button does not work when long press
784         scrollview: don't auto scrolling if resizing area is too large
785 - Feature : notification : add api to set the icon at tickernoti
786         demo : update the list sample demo
787         Support tizen default theme
788
789 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
790 - Improvements & Bugfixes
791    - HOTFIX: Revert template function with jquery.template
792
793 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
794 - Improvements & Bugfixes
795    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
796 - Spec changes
797    - $.tizen.loadTheme() function accepts theme name as arguement
798    - Scrollview supports 'updatelayout' callback
799
800 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
801 - Improvements & Bugfixes
802    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
803
804 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
805 - Improvements & Bugfixes
806    - Add tizen-white theme package, to make rpm build to be finished
807
808 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
809 - Improvements & Bugfixes
810    - Set 'slide' as default page transition effect, by JQM patch
811
812 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
813 - Improvements & Bugfixes
814    - Fix IME show/hide algorithm
815    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
816
817 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
818 - Improvements & Bugfixes
819    - Fix notification position
820    - Fix unit tests
821
822  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
823 - Spec changes
824         - JQM 1.1 upgrade
825 - Improvements & Bugfixes
826         - Transform3D support on scrollview
827         - Page layout supports IME control
828         - Mapview supports pinch zoom on JQM 1.1
829         - Fix wrong character on button in minified version
830         - Virtualgrid supports scrollbar
831         - Lots of bugfixes
832
833 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
834 - Spec changes
835         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
836         - imageslider : supports 'resize' event.
837         - listview : listview has 1px padding-bottom.
838         - loader : Change global namespace, from S to $.tizen.
839         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
840 - Improvements & Bugfixes
841         - Scrollview : supports 'translate3d', instead of 'translate'.
842         - notification : reset timer when 'show' or 'refresh' event.
843         - JQM patch : Fix vclick event triggered twice.
844 - Etc.
845         - Add & fix unit tests.
846
847 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
848 - Spec changes
849         - mapview : new widget.
850         - notification : add .refresh() API.
851         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
852 - Improvements & Bugfixes
853         - Support minified CSS.
854         - loader : Fix & refactor 'loading globalize culture file' routine.
855         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
856         - Many more bugfixes.
857 - Etc.
858         - Add many unit tests.
859         - Fix test coverage instrumentation tool to work with current source code.