54b21642c4e4476edcb42a60626b140a93f0a27d
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
1 Name:       web-ui-fw
2 Version:    0.2.27
3 Release:    0
4 Summary:    Tizen Web UI Framework Library
5 Group:      Development/Other
6 License:    MIT
7 BuildArch:  noarch
8 BuildRequires:  make
9 BuildRequires:  nodejs
10 %ifarch %{arm}
11 BuildRequires:  nodejs-x86-arm
12 %endif
13
14 Source0:    %{name}-%{version}.tar.gz
15
16 %description
17 Tizen Web UI Framework library and theme packages
18
19 %prep
20 %setup -q
21
22 %build
23 make all
24
25 %install
26 make DESTDIR=%{buildroot} install
27
28 %post
29
30 %files
31 %manifest web-ui-fw.manifest
32 /usr/share/tizen-web-ui-fw/*/js/*.js
33 /usr/share/tizen-web-ui-fw/*/js/cultures
34 /usr/share/tizen-web-ui-fw/latest
35 /usr/share/tizen-web-ui-fw/VERSION
36
37 ###############################
38 %package -n web-ui-fw-theme-tizen-gray
39 BuildArch:  noarch
40 Summary:    Tizen Web UI Framework Theme : tizen-gray
41 %Description -n web-ui-fw-theme-tizen-gray
42     Tizen Web UI Framework Theme : tizen-gray
43     Deprecated package, but some binaries still refer this.
44
45 ###############################
46 %package -n web-ui-fw-theme-tizen-white
47 BuildArch:  noarch
48 Summary:    Tizen Web UI Framework Theme : tizen-white
49 %Description -n web-ui-fw-theme-tizen-white
50     Tizen Web UI Framework Theme : tizen-white
51 %files -n web-ui-fw-theme-tizen-white
52 %manifest web-ui-fw-theme-tizen-white.manifest
53 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
54 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
55
56 ###############################
57 %package -n web-ui-fw-theme-tizen-black
58 BuildArch:  noarch
59 Summary:    Tizen Web UI Framework Theme : tizen-black
60 %Description -n web-ui-fw-theme-tizen-black
61     Tizen Web UI Framework Theme : tizen-black
62 %files -n web-ui-fw-theme-tizen-black
63 %manifest web-ui-fw-theme-tizen-black.manifest
64 /usr/share/tizen-web-ui-fw/*/themes/tizen-black
65
66 ###############################
67 %package -n web-ui-fw-theme-default
68 BuildArch:  noarch
69 Summary:    Tizen Web UI Framework Theme : default
70 %Description -n web-ui-fw-theme-default
71     Tizen Web UI Framework Theme : default
72 %files -n web-ui-fw-theme-default
73 %manifest web-ui-fw-theme-default.manifest
74 /usr/share/tizen-web-ui-fw/*/themes/default
75
76 ###############################
77 %package -n web-ui-fw-devel
78 BuildArch:  noarch
79 Summary:    Tizen Web UI Framework Developer's files
80 %Description -n web-ui-fw-devel
81     Tizen Web UI Framework Developer's files
82 %files -n web-ui-fw-devel
83 /usr/share/tizen-web-ui-fw/bin
84 /usr/share/tizen-web-ui-fw/template
85 /usr/share/tizen-web-ui-fw/*/js/src
86 /usr/share/tizen-web-ui-fw/*/js/depData.json
87
88 ###############################
89 %package -n web-ui-fw-demo-tizen-winsets
90 BuildArch:  noarch
91 Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
92 %Description -n web-ui-fw-demo-tizen-winsets
93     Tizen Web UI Framework Demo Application: tizen winset demo
94 %files  -n web-ui-fw-demo-tizen-winsets
95 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
96
97
98 ###############################
99 %changelog
100 * Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
101         - Splitview: Fix popup error
102         - Tests: Add slider tests checking if jqm slider is used for select elements
103         - Adjust the latest GUI
104         - Handler: Adjust the latest GUI
105         - Swipe: Adjust the latest GUI
106         - Fastscroll: Adjust the latest GUI
107         - ToggleSwitch : bug fix
108         - TizenWinset : bug fix(N_SE-36666)
109         - Gallery3d: Fix Gallery3d TC failure
110         - UnitTC: fix virtualgrid test error
111         - Popup: popup background image have been added
112         - Tokentextarea: Use jQM popup instead of window.alert().
113         - Splitview: Use jQM popup instead of window.alert().
114         - Splitview: Change an option name to start with a capital letter
115         - License: Change flora license version
116         - Tabbar: Adjust the latest GUI
117         - Tokentextarea: Change from 'px' to 'em.'
118         - Fastscroll: Add 'orientationchange' event handler.
119         - Gallery3d: Fix null reference error
120
121 * Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
122         - PageLayout : bug fix
123         - Gallery3d: Change timing of 'gl-matrix' library's execution
124         - Replace in LoadTheme function strings build with array join with the string concat
125         - Contextpopup: context popup reposition module has been added
126         - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
127         - Splitview: Fix the touchend event error.
128         - Gallery3d: Change event registration method from $.bind() to $.on()
129         - Scrollview : remove useless setTimeout in case scrolls go outside
130         - Naviframe : adjust new SIP down button
131         - Timepicker: Added return false; after vclick
132         - Popupwindow: reserved words has been removed
133         - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
134         - TizenWinset : set default margin for checkbox demo
135         - Tizenwinset: Context popup demo has been changed
136         - TizenDemo : add initial orientation mode to popup demo
137         - Widgets: removed parsing error for legacy javascript engine
138         - Delegate init of popup widget with delegateSelfInitWithSingleSelector
139
140 * Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
141         - Pinch: pinch event re-implementation to use size
142         - Pagelayout : prevent code inserting window.innerHeight when content calculate
143         - BlachTheme : add missing icon (SIP down)
144         - Scrollview : support absolute position
145         - tizen-winsets: change the font-family in virtualgrid demo to default
146         - TizenWinset : Change default font
147         - tizen-winsets: Change image link
148         - tizenwinset: change images for virtual grid pages
149
150 * Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
151         - SegmentControl: 2-buttons display issue (N_SE-34200)
152         - Naviframe : remove unnecessary img positioning(N_SE-33969)
153         - Gallery: jslint error fix
154         - TizenWinset : remove landscape SIP on mode
155         - Tizen Black Theme png file changed
156         - Gallery: Images showing bug has been fixed
157         - Scrollview : change horizontal scrollview demo(N_SE-33997)
158         - Tizenwinset: added return false in popup sample
159         - Naviframe : support data-role="button" in header
160         - Additional UnitTC: tizen winset unit tc bugs have been fixed
161         - Checkbox : remove favorite button's display:block(N_SE-33896)
162         - UnitTC: QUnit path has been changed. Priority, function type check function has been added
163         - Tizen-winset : Footer changed from lower case to upper case.
164         - Slider: enhance performance fix
165         - UnitTC: Addtional unit tc ref path has been fixed
166         - virtualgrid: apply overscrolling images to the style of widget
167         - Tabbar : Change overscroll image(left/right)
168         - ensurens: optimizations
169         - ensurens: qunit tests
170         - Tokentextarea: Fix block size error
171         - Fastscroll: Add a feature to fade out Fastscroll widget.
172         - Fastscroll: Add a user interaction at the omitted items.
173         - ImageLoader: Performance fix: apply lazy loading for canvas element
174         - Tests: Add tests for $.imageloader
175         - SegmentControl: 2-buttons display issue (N_SE-34200)
176         - virtuallist: fix width resizing trigger
177         - Timepicker: timepicker is closed when orientationchange event fired
178         - TizenWinset : Tabbar-persist issue.(N_SE-33996)
179         - Add Flora license
180         - collapsible: Fix collapsible list animation bug
181
182 * Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
183         - Naviframe : modify SIP down button's position
184         - Core: Performance fix for disableSelection and enableSelection
185         - Tests: Core tests for disableSelection
186         - patch: fix small mistakes on the patches
187         - virtuallist: Change demo button style
188         - Button: btn-icon only css has been changed
189         - loader: Fix screen-width option processing
190         - pagelayout: Remember back key when it is hidden
191         - Tizen Black Theme : Tizen black theme png file changed.
192         - UnitTC: tizen winset unit tc bugs have been fixed
193         - TizenWinset: Swipe list sample has been fixed
194         - Radio : remove default radio's width(N_SE-33579)
195         - Scrollview : divide x/y overflow attribute
196         - Gallery: orientation image showing issue has been fixed
197         - Gallery: remove method bug has been fixed
198         - virtualgrid : fix unit-test error and increase test items
199         - Gallery3d: Modify demo & source codes for visibility enhancement.
200         - Gallery3d: Reduce loading time of widget
201         - Gallery3d: Change files' format to unix
202         - Contextpopup: context popup close when window resize event fire
203         - Popup: reverse orientation bug has been fixed
204         - Tokentextarea: modify description
205         - Multimediaview: modify description
206         - JQM: Do not add ui-btn-icon-only class at the select button
207         - build: tizen-black theme package
208         - Tizenwinset: popup script has been removed
209         - Tizenwinset: substring split view text message
210         - Timepicker: data-changed event will be deprecated
211
212 * Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
213         - tizen-winsets: Fix demo menu
214         - Tizenwinset: Reorder tizenwinset menu
215         - SearchBar: Header button size issue has been fixed
216         - Swipe: list item overflow: hidden has been added
217         - Tizenwinset: href has been added in grouped list
218         - Tizenwinset: Page transition page has been added
219         - Tizenwinset: Radio description has been fixed
220         - This patch fixes problem when base url is changed when site is prefetched.
221         - Entry : limit textarea's width (N_SE-28653)
222         - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
223         - Gallery : next, prev images position bug has been fixed
224         - Multimediaview: Fix display error while handling orientationchange event.
225         - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
226         - Datetimepicker: picker position has been fixed when browser resize event fired
227         - Tips: generate elements sample page javascript has been fixed
228         - Tokentextarea: Fix Tizen-winsets demo.
229
230 * Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
231         - VirtualGrid: Fix errors on centerTo and resize methods
232         - loader: Fix default font size at device-width viewport
233         - scrollview : remove overflow-x property
234         - Naviframe : fix backbutton position/ change down button icon
235         - Naviframe : bug fix
236         - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
237
238 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
239         - JQM Navigation : remove page min-height
240         - Pagelayout : add refresh to pagelayout
241         - Tokentextarea: Changes 'remove' tests to asyncTest
242         - Popup: input tag alignment has been fixed
243         - Tokentextarea: add/remove events are deprecated.
244         - Contextpopup: Support horizontal list
245         - Select: icon z-index has been deleted
246         - Tizenwinset: ui widget order has been changed
247         - Tool: make web app template disable context menu by default
248         - Tizen-winset: change tips for using listview
249         - Loader: calculate font size with mobile width
250         - Naviframe : fix header's back button position
251         - TizenWinset : move locale info to another file
252
253 * Fri Mar 22 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.19
254         - Tizen-winset: Support accessibility for tizen-winset
255         - Orientation : add orientataionchange to tizen-winset
256         - Tokentextarea: Adjusts VI effect for add/remove block
257         - splitview: Support accessibility for splitview
258         - Tizen-winset: Date/time picker guide text has been fixed
259         - Popup: context popup arrow position, setTimeout open method bug have been fixed
260         - fastscroll: Add new indexString API to Fastscroll widget.
261         - splitview: Add new widget
262         - gallery3d: Add new widget
263         - Scrollview : disable VI effect for gesture event
264         - Scrollview : disable SIP outerscroll
265         - Tizen-winset: resize VirtualGrid widget in demo
266         - Tizen-winsets: Refactor searchbar subpages
267         - Tizen-winsets: Remove depracated usage of virtuallist
268         - Tizen-winsets: Move js code from main.js to subpages
269         - Tizen-winsets: Refactor virtual grid demo subpages
270         - Tizen-winsets: Move css files from index to proper subpages
271         - Tizen-winsets: Refactor list dialogue edit subpage
272         - Tizen-winsets: Refactor pagelayout subpages
273         - Tizen-winsets: Refactor tips subpages
274         - Tizen-winsets: Move subpages popup files from index.html
275         - Tizen-winsets: Move subpages javascript files from index.html
276         - virtualgrid: fix improperly merged codes
277         - ColorTheme : remove unused color value(1st)
278         - Scrollview : change scrollbar draw
279         - Popup: Apply popup background dim
280         - Tizen-winsets: Move tokentextarea demo to external page.
281         - Tizen-winsets: Move tabbar persist demo to external page.
282         - Tizen-winsets: Remove notImplemented page
283         - Tizen-winsets: Move slider demo page to external subpage
284         - Tizen-winsets: Fix ids, remove duplicated names for sliders
285         - Tizen-winsets: Remove event for changing theme
286         - tool: Fix wgt sample app generator tool to make apps be installed
287         - demos : change live to on
288         - build: Trim compiled CSS files
289         - Gallery: CSS left -> translate or translate3D
290         - Tokentextarea: Disfunctional APIs fixed.
291
292 * Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
293         - build: Fix Makefile to add globalize to the minified lib
294         - build-tools : upgrade less to v1.3.3
295         - demos : change normal js path to minified js
296         - Theme : remove reduantant less - dayselector, optionheader, nocontents
297         - multimediaview : fix full-screen mode.
298         - multimediaview : fix 'width', 'height' and 'fullScreen' methods
299         - Extendablelist: Added min-height "load more button" in listitem
300         - virtualgrid: adjusts VI effect for an overflow action
301         - ControlGroup : change ellipsis font color (press/normal)
302         - multimediaview: Add an error message to Multimediaview
303         - virtualgrid: adjusts triple flick gesture
304         - scrollview: add function for getting width of view
305         - scrollview: adds support x axis gesture scroll
306         - multimediaview : fix audio control
307         - tabbar : tabbar slide animation change
308         - TizenWinsetDemo : 2line-text demo bug fix
309         - collapsible: Fix demo to show radio button correctly in the collapsible list
310         - collapsible: Set listitem position to relative
311         - UnitTC: added list divider unit test
312         - Style: unnecessary color codes have been deleted and modified
313         - build: Module build implementation
314         - UnitTC: Additional unit testcases have been added
315         - listview : bug fix
316         - Naviframe : remove back button's hover effect
317         - TizenDemo : remove back button
318         - Transition: added more-button vi
319         - pinch: added new event called pinch
320         - Popup: css word-wrap:break-word has been added
321         - virtualgrid: memory leak fix
322         - progress: set to init state at pending bar
323         - progress: add margin of top/bottom
324         - unit-test: split progress test and progressbar test
325         - Tizen-winset: Context popup sample page guide text has been changed
326         - multimediaview: fix the height of widget when full-screen mode
327         - JQM: performance tuning
328
329 * Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
330         - DialogueList : delete border top value / add sample's text ellipsis
331         - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
332         - Multimediaview: Fix mute function
333         - Tizen-winset: list vi index guide textbox has been removed
334         - Tizen-winset: custom button texts have been changed
335         - slider: move popup div to out of content
336         - TizenWinset: disable context popup in multimediaview
337         - Swipe: wrong style name has been fixed
338         - demo: add the sample at dialogue list
339         - listview: Add ui-li-has-right-btn class with toggleswitch
340         - WinsetDemo : change wrong title name
341
342 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
343         - demo: checkbox: reduce button's width
344         - tabbar : delete right/left tab animation color
345         - scrollview: fix the scroll position at keydown event
346         - groupControl : change footer groupControl from min-width to percentage
347         - scrollview: get height of softkeyboard correctly
348         - tizen-winset: Add name attr to all radio inputs
349         - virtualgrid: changes event binding target
350         - scrollview: skip the drag if target is textarea
351         - scrollview: skip the dragging of parent scrollview
352         - scrollview: apply the scaling ratio to the soft keyboard
353         - demos: apply disabled option in textarea
354         - demo: remove unused codes
355         - demo: datetimepicker: show selected date correctly
356         - listview: Adjust bubble listitem width and margin
357         - pagelayout : change external refresh call and ime status follow only current page
358         - toggleSwitch : bug fix
359         - unit-test: slider: fix the move test
360         - handler: fix jslint error
361         - ToggleSwitch : set image toggleswitch background attribute
362
363 * Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
364         - slider: increase the text width(N_SE-23397)
365         - virtualgrid: DOM element leak fix
366         - header: Move button top higher in header with tabbar(N_SE-22253)
367         - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
368         - handler: bug fix (regarding enableHandler function )
369         - demo:fix syntax error
370
371 * Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
372         - demo: fix demo using tizen device API
373         - multimediaview: reset the height of container
374         - input: modify css correctly
375         - multimediaview: fix the height of widget
376         - gallery: bind create event
377         - progress: bind create event
378         - slider: bind create event
379         - progressbar: bind create event
380         - progressbar: event trigger correctly
381         - popup: fix height of popup scroller
382         - build: add continue option to jslint
383         - ctxpopup demo : bug fix
384         - demo: fix searchbar demo to use different IDs
385         - demo: extract routine executing Tizen device API
386         - toggleswitch : set default margin, delete box padding
387
388 * Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
389         - virtuallist: Prevent replacing contents on nonexist element
390         - JQM: Trim text in listitem to get index in autodivider
391         - JQM: Remove trailing whitespace in jqm patch
392         - scrollview: get the height including margin
393         - multimediaview: bug fix ( scrolling in full-screen mode )
394         - virtuallist: set listitem width to exclude listitem left/right margin
395         - demo: fix virtuallist sample layout
396         - progress: set the position explicitly
397         - progress: rename from progressing to progress
398         - build: remove unused files
399         - searchbar: fix jslint errors
400         - src: fix file permissions
401         - button : change jump left icon
402
403 * Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
404         - theme : button icon - scrolltop, scrolleft icon changed.
405         - build: cleanaup Makefile
406         - pagelayout: fix jslint error
407         - virtualgrid: Fix jslint errors
408         - tabbar : jslint bug error fix
409         - build: add regexp option to jslint
410         - virtuallist: fix jslint errors
411         - handler: Apply the exceptional principle for scrollbar on Handler.
412         - build: remove unused copyright
413         - loader: extract log class for tizen web, and fix jslint errors
414         - loader: Viewport width is set to document width
415         - popupwindow: fix jslint error
416         - build: fix Makefile for tizen-white theme
417         - build: remove unused libraries
418         - datetimepicker: fix jslint error
419         - slider: fix jslint error
420         - demo: remove deprecated demos
421         - pagelayout : change to call relayout with this page
422         - Tokentextarea: Block size error fixed.
423         - handler: bug fix (handler activation)
424
425 * Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
426         - demo: clear input text value with cancel button click
427         - demo: Adjust textarea height automatically
428         - naviframe : bug fix
429         - tabbar : bug fix
430         - Fastscroll: popup position has been changed
431         - Button: custom button icon path, margin have been changed
432         - toggleswitch : bug fix
433         - slider: increase the margin
434         - datetimepicker: close the popup after select the value
435         - unit-test : add page backbutton control test
436         - Demo: added guide text and change input type in list vi
437         - remove legacy codes : jquery-geo
438         - Datetimepicker: text-main max-width has been removed
439         - Radio: control group border has been removed
440         - Demo: remove 'tab' space
441         - UnitTC: swipe unit tc has been fixed
442         - UnitTC: jQuery path has been fixed
443         - Button: bug fix when button has not a text
444         - tizen-winset: timepicker: demo title is changed
445
446 * Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
447         - tizen-winsets: codes cleanup
448         - datetimepicker: date calibration when year is changed
449         - Demo: textarea size has been changed
450         - Demo: Naviframe morebutton demo has been changed
451         - remove unused unit test cases : gallery3d
452         - tizen-winset: remove links
453
454 * Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
455         - gallery: use timeout function instead of interval
456         - Tokentextarea: Display error fixed.
457         - scrollview: Fix not selector to respond with jQuery1.8.2
458         - tabbar: remove the width of last element
459         - Demo: apply css 'user-select:none'
460         - Button: guide text has been shorten
461         - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
462         - virtuallist: Fix mistyping
463         - demo: Fix tizen function namespace in demo
464         - virtuallist: Rewrite listitem replacing algorithm
465         - fastscroll: modify from not selector to function
466         - extendablelist: Fix unit-test
467         - tabbar : prefix to tabbar scroll event
468         - Popupwindow: removed unvalid selector in jquery 1.8.2
469         - slider: adjust handle text as length of value
470         - Demo: 3 buttons in popup text has been changed
471         - src: codes cleanup
472         - demo : remove trailing empty strings
473         - demo : rename TizenWinset list items
474         - button : change from long text list to multiline list
475         - build: Remove JQM1.1.0 patches
476         - Popup: Apply tizen style popup and attribute support
477         - JQM: Fix buttonmarkup bug keeping ui-btn-down class
478         - UnitTest: folder and file renamed, QUnit path was modified
479         - tizen-winsets: button: fix textarea width
480         - Swipe: event name error has been fixed
481
482 * Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
483         - Button: button padding has been updated
484         - virtuallist: fix unique listitem ID bug
485         - checkbox, radio : change display attr
486         - Button: bug fix ( when data style circle button on text )
487         - handler: bug fix (when scrolling with multi selection)
488         - JQM: adjust patch number
489         - gallery: show the widget after pageshow
490         - TokenTextArea : resource add ( press image )
491         - gallery: adds function that set the index to value API
492         - configure: set TIZEN default configures
493         - footer: h tag display attribute value has been changed
494         - buttons : demo bug fix
495         - searchbar : demo page bug fix
496         - tizen demo : bug fix
497         - build: remove JQM1.1.0
498         - Tokentextarea: Fix issues
499         - scrollview: block the multi touch
500         - list : dialogue list demo change
501         - pagelayout : update dynamic control
502         - Demo: Context popup close method has been changed
503
504 * Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
505         - slider: set text container's width as text length
506         - Timepicker: li max-width has been changed
507         - remove experimental feature - mapview.
508         - scrollview: added conditions for finding slider
509         - UnitTC: Pass,error count save method has been changed
510         - confix.xml: default config added for tizen basic applications
511         - Swipe: p tag margin value is set '0'
512         - packaging: remove unused file
513         - tabbar : bug fix
514         - list demo : bug fix
515         - tizen-winsets: gallery: move to new section
516         - tizen-winsets: autodivider: removes link of list
517         - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
518         - pagelayout : padding calculate change, ime footer check changed
519         - tizen-winsets: searchbar: scroll to the top when type the character
520         - searchbar : bug fix
521         - demo: Fix virtuallist demo following new list style
522         - demo: Add word-wrap:break-word and remove parag. width
523         - Demo: button max-width has been set( 3 buttons in popup )
524         - back button control demo : bug fix
525         - toggleswitch : demo page modify
526         - slider: add margin-top and margin-bottom
527         - tabbar demo : bug fix
528         - Popup: IME hide when popup is closed
529         - token textarea : bug fix
530         - Timepicker: change get attribute method
531         - footer demo : bug fix
532         - unit-test: gallery: add new APIs
533         - gallery: adds support new APIs
534
535 * Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
536         - JQM: patches cleanup
537         - Button: data-corners attribute has been added
538         - unit-test: slider: fix class name of background
539         - progressbar, slider: fix less variable typo
540         - Tabbar : VI update
541         - notification: add top position at fix class
542         - demo: entry demo page change
543         - css: .ui-disabled added
544         - tizen-winset: token textarea: remove back button at demo page
545         - theme: Remove unused less file
546         - pagelayout : content min height bug fix
547         - scrollview: skip the dragging when target is slider's handle
548         - scrollview: update and refactoring the scroll effect
549         - UnitTest:JQM Unit TC helper has been added,TCs have been modified
550         - Swipe: demo page html error has been fixed
551         - listview: Add add/delete animation (VI)
552         - Popup: demo page has been modified
553         - tizen demo : bug fix
554         - searchbar : demo page change(change front button and add behaviour)
555         - pagelayout : add min height to content
556         - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
557         - back button control demo : change url link to data-rel="back"
558         - loader: Skip loading theme CSS with a custom css code
559         - Button: support no-text in button
560         - collapsible: Fix syntax error
561         - slider: use data-highlight attribute
562         - collapsible: Rotate animation to collapsible heading icon
563         - toggleswitch : text switch bug fix
564         - remove candidates-calendarpicker
565         - Patch: Fix misc mistakes in JQM patches
566         - searchbar : animation change
567         - gallery: get the width correctly
568         - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
569         - collapsible: Add collapse/expand animation (VI)
570         - datetimepicker: VI update
571         - JQM: set transition to pop as default
572         - tabbar : bug fix in case none li element case
573         - scrollview: fix the drag bug
574         - Button: Button icon scrolltop, left has beed added
575         - Swipe: VI update and swipe speed has been changed
576         - jqm: fix errors in patch files
577         - unit-test: swipe: fixed the destroy test
578
579 * Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
580         - Revert "[checkboxradio] exception handling for input"
581                 This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
582                 Tizen style supports no-label radio and checkbox when making lists.
583                 So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
584
585 * Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
586 - Fix:
587         - modify segment background
588         - rearrange check, radio input
589         - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
590         - button: style has beed added(box,circle,nobg,round)
591         - favorite resource added
592         - demo/tizen-winsets: add footer and back button
593         - remove autodividers unit test
594         - add divider for tabbar
595         - checkboxradio: exception handling for input
596         - segment control backward compatiblity
597         - Fix collapsible unit-test
598         - remove toggleswitch
599         - add patch for remove segment text
600 - Spec changes:
601         - replace controlbar to tabbar
602
603 * Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
604 - FIX:
605         - slider: add image
606         - button: data-icon support, styles fix
607         - progressbar: modify the background
608         - scrollview: auto scrolling bug fix
609         - pagelayout: IME concept is changed
610 - Spec changes:
611         - dialogue: add edit mode
612         - nocontents: removed
613         - pagecontrol: removed
614         - dayselector: removed
615         - expandablelist: removed
616
617 * Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
618 - FIX:
619         - chang searchbar/slider images
620         - delete redundant button images
621 - Spec changes:
622         - Change widget name: shortcutscroll -> fastscroll
623
624 * Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
625 - FIX:
626         - jqm1.2: Change collapsible style to meet expandable list
627         - remove jquery-geo-1.0.a4
628         - unit-test: rename from imageslider to gallery
629         - nocontent: add warning message
630         - Handler: Fix issues in jqm1.2
631         - Multimediaview: modify APIs & comments
632         - Mapview: Fix issues in jqm1.2
633         - JQM: clean up patches
634         - Swipelist: refactoring swipelist
635         - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
636         - rearrange button's data-icon resources
637 - Spec changes:
638         - Virtualgrid: remove option ('data-itemcount')
639         - gallery: rename the widget from imageslider to gallery
640         - add new style for searchbar
641         [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
642
643 * Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
644 - FIX:
645         - fix jslint error
646         - remove unused files
647         - change naviframe style
648 - Spec changes:
649         - applied jQuery Mobile 1.2.0
650         - remove optionheader
651
652 * Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
653 - FIX:
654         - fix unit tests
655         - remove unused theme files
656         - timepicker: text position fix
657         - scrollview: set dragstop when mouse is out of window
658         - listview: fix margin
659 - Spec changes:
660         - support data-framework-viewport-width
661
662 * Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
663 - FIX:
664         - dayselector: fix size
665         - remove unised styles
666         - divider: set non-press effect to default option
667         - popupwindow: fix window closing failure
668         - handler: GUI implementation
669         - TC: fix unit TCs
670         - scrollview: fix padding size
671 - Spec changes:
672         - Remove color widgets
673         - add $.tizen.pkgVersion for SDK
674 - Etc.
675         - JSDuck documents
676
677 * Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
678 - FIX:
679         - Many winsets: Fix layout
680         - Footer: fix position to bottom
681 - Spec changes:
682         - Remove color widgets
683
684 * Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
685 - FIX:
686         - Many widgets: New UX 0.6 theme implementation
687         - widgetex: init speed up
688         - scrollview: fix scrollbar and scale animation
689         - scrollview: fix scroll position when updatelayout is triggered
690         - header/footer: make textselection disable, except input type="text"
691
692 * Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
693 - FIX:
694         - Remove tizen-black theme package description
695
696 * Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
697 - FIX:
698         - Fix theme name to meet the change of system theme name: white->tizen
699         - Popupwindow: fix left position
700         - Remove black theme
701         - footer: remove label, legend drawing
702 - Spec changes:
703         - UX guide v0.4 : button, layout
704
705 * Fri Oct 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.58
706 - FIX:
707         - scrollview: Fix outer scroll amount
708         - tabbar: fix tapping twice
709         - popupwindow: fix left position
710
711 * Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
712 - FIX:
713         - expandablelist: icon color fix
714         - scrollview: Fix xy scroll
715         - footer: Remove dummy div
716         - Make string concatnation effective in inline-protos.sh
717 - Spec changes:
718         - refresh header/footer when drag&drop event is fired in GUI builder
719         - searchbar: delete cancel button
720         - don't trigger updatelayout event when keyup event comes
721
722 * Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
723 - FIX:
724         - Toggleswitch: Change event name from 'changed' to 'change'
725         - Notification: Revert interval feature
726
727 * Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
728 - FIX:
729         - Fix SMACK manifest bug (S1-9098)
730
731 * Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
732 - FIX:
733         - handler: don't append a handler if handler is not enabled
734         - scrollview: use static value
735         - datetimepicker: fix date-format HH display error
736 - ETC:
737         - provide jquery.min.js
738         - barlayout: codes clean
739         - remove unused file
740
741 * Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
742 - FIX:
743         - listview: change focused color
744         - multibuttonentry: code refactoring
745         - datetimepicker: modify date format when triggered date-changed event
746         - slider: fix the top of slider bar
747         - add event blocker when load a first page
748
749 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
750 - ETC.
751         - Move SMACK manifest files to the top SRCDIR
752
753 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
754 - FIX:
755         - Popup: Do not focus container
756         - Header: show backbutton when both tabbar and header are present together
757         - Multi button entry: text ellipsis, code refactoring
758
759 * Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
760 - ETC.
761         - Apply SMACK manifest
762
763 * Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
764 - FIX:
765         - JSLINT code clean-up
766         - scrollview: firefox support
767         - scrollview: fix finding slider handle
768         - list: tweak text ellipsis
769         - checkbox: fix selecting wrong label tag (N_SE-8370)
770         - imageslider: check parameter
771         - smallpopup: fix position
772         - searchbar: fix 'clear' button size
773 - Spec changes:
774         - scrollview: support outer scroll
775         - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
776         - remove S/W IME control
777
778 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
779 - FIX:
780         - Add missing icon: controlbar
781         - scrollview: tune scrolling animatio ninterval
782         - datetimepicker: digit/triangle position
783         - datetimepicker: fix day overflow issue
784 - Spec changes:
785         - scrollview: show scrollbar when page is showed
786         - scrollview: disable outer scroll
787         - extendablelist: change api with legacy support
788         - add ui-text-ellipsis class
789
790 * Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
791 - FIX:
792         - scrollveiw: fix height of view
793         - searchbar: support placeholder
794 - Spec changes:
795         - add ui-text-ellipsis class
796
797 * Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
798 - FIX:
799         - scrollview: scrolling bug fix
800         - controlbar: fix width of controlbar item
801 - Spec changes:
802         - searchbar: don't hide icon
803         - popup: update JQM poup widget
804
805 * Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
806 - FIX:
807         - controlbar: set correct controlbar width of last element
808         - slider: get popup enable value correctly
809         - use Date.now() instead of (new Data()).getTime()
810         - popupwindow: fix the background color of popup scroller
811         - listview: add padding-left to expandable list
812         - add ellipsis for title area support
813
814 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
815 - FIX:
816         - swipelist: show list items correctly
817         - datetimepicker: set last day, if day is overflowed
818 - Spec changes:
819         - controlbar: update icons
820
821 * Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
822 - FIX:
823         - notification: fix typo
824 - Spec changes:
825         - controlbar: update icons
826
827 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
828 - FIX:
829         - multimediaview: video progress bar display normally for too samll
830         - segmentcontrol: remove media query
831         - scrollview: add outer scroll condition
832         - datetimepicker: modify triangle size
833         - popupwindow: set the screen height explicitly
834         - notification: add multiline text
835 - Spec changes:
836         - mutibuttonentry: support new GUI
837         - virtualgrid: support new GUI
838
839 * Mon Aug 27 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.41
840 - FIX:
841         - radio/check button : button size bug fix
842
843 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.40
844 - FIX:
845         - build error fixed
846
847 * Fri Aug 24 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.39
848 - FIX:
849         - listview: style fix, remove filter placeholder
850         - controlbar: divide styles
851         - scrollview: don't skip dragging when click button or inputbox
852         - slider: trim the text on text slider
853 - Spec changes:
854         - remove gray and blue theme
855         - add white and black theme
856         - support new GUI guide
857
858 * Mon Aug 20 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.38
859 - FIX:
860         - fix coment of version tag
861
862 * Fri Aug 17 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.37
863 - FIX :
864         - button: fix alignment
865         - listview: adjust the main text width
866         - virtualgrid: refactoring
867 - Spec changes:
868         - transition: support JQM 1.1.0 transitions
869         - scrollview: support the outer scroll
870         - notification: remove interval feature
871
872 * Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
873 - FIX :
874         - checkboxRadio: Add left/right padding
875         - button: custom button & icon position
876         - virtuallist: remove 'recreate' test
877 - Spec changes:
878         - header/footer: enable/disable support
879
880 * Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
881 - FIX :
882         - expandablelist: modify show animation
883         - virtualgrid: Redesign programming interface
884         - popupwindow: code clean and fixed issues
885         - pagelayout: fix content height
886         - license file update
887         - virtuallist: Change programming interface
888         - datetimepicker: getting days correctly
889         - searchbar: set to hidden when cancel button is hide
890         - White theme title font tuning
891 - Spec changes:
892         - default theme tizen-gray to tizen-white
893         - set default page transition to none
894
895 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
896 - FIX :
897         - Back Button : enlarge backbutton click size for white theme
898 - Feature :
899         - Expandable List : Add refresh api
900 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
901 - FIX :
902         - click event touch threshold tuning
903
904 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
905 - FIX : 
906         - Add back button highlight effect for white theme
907
908 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
909 - FIX : 
910         - IME checkroutine update, improve relayout on resize event
911         - Add highlight effect for radio button list 
912         - Scrollview : fix condition of updatelayout event
913 - Feature : progressing : add show/hide api
914
915 * Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
916 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
917         add default theme option on buttonMarkup for tizen theme
918         [searchbar] first fix : focus/blur fixed
919         back button does not work when long press
920         scrollview: don't auto scrolling if resizing area is too large
921 - Feature : notification : add api to set the icon at tickernoti
922         demo : update the list sample demo
923         Support tizen default theme
924
925 * Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
926 - Improvements & Bugfixes
927    - HOTFIX: Revert template function with jquery.template
928
929 * Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
930 - Improvements & Bugfixes
931    - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
932 - Spec changes
933    - $.tizen.loadTheme() function accepts theme name as arguement
934    - Scrollview supports 'updatelayout' callback
935
936 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
937 - Improvements & Bugfixes
938    - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
939
940 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
941 - Improvements & Bugfixes
942    - Add tizen-white theme package, to make rpm build to be finished
943
944 * Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
945 - Improvements & Bugfixes
946    - Set 'slide' as default page transition effect, by JQM patch
947
948 * Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
949 - Improvements & Bugfixes
950    - Fix IME show/hide algorithm
951    - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
952
953 * Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
954 - Improvements & Bugfixes
955    - Fix notification position
956    - Fix unit tests
957
958  Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
959 - Spec changes
960         - JQM 1.1 upgrade
961 - Improvements & Bugfixes
962         - Transform3D support on scrollview
963         - Page layout supports IME control
964         - Mapview supports pinch zoom on JQM 1.1
965         - Fix wrong character on button in minified version
966         - Virtualgrid supports scrollbar
967         - Lots of bugfixes
968
969 * Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
970 - Spec changes
971         - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
972         - imageslider : supports 'resize' event.
973         - listview : listview has 1px padding-bottom.
974         - loader : Change global namespace, from S to $.tizen.
975         - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
976 - Improvements & Bugfixes
977         - Scrollview : supports 'translate3d', instead of 'translate'.
978         - notification : reset timer when 'show' or 'refresh' event.
979         - JQM patch : Fix vclick event triggered twice.
980 - Etc.
981         - Add & fix unit tests.
982
983 * Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
984 - Spec changes
985         - mapview : new widget.
986         - notification : add .refresh() API.
987         - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
988 - Improvements & Bugfixes
989         - Support minified CSS.
990         - loader : Fix & refactor 'loading globalize culture file' routine.
991         - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
992         - Many more bugfixes.
993 - Etc.
994         - Add many unit tests.
995         - Fix test coverage instrumentation tool to work with current source code.