Don't try to make a connection again from discon cb
[platform/framework/web/livebox-viewer.git] / packaging / liblivebox-viewer.spec
1 Name: liblivebox-viewer
2 Summary: Library for developing the application.
3 Version: 0.13.3
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(aul)
11 BuildRequires: pkgconfig(glib-2.0)
12 BuildRequires: pkgconfig(gio-2.0)
13 BuildRequires: pkgconfig(com-core)
14 BuildRequires: pkgconfig(x11)
15 BuildRequires: pkgconfig(xext)
16 BuildRequires: pkgconfig(sqlite3)
17 BuildRequires: pkgconfig(db-util)
18 BuildRequires: pkgconfig(livebox-service)
19 BuildRequires: pkgconfig(vconf)
20
21 %description
22 API for creating a new instance of the livebox and managing its life-cycle.
23
24 %package devel
25 Summary: Header and package configuration files for the livebox viewer development.
26 Group: Development/Libraries
27 Requires: %{name} = %{version}-%{release}
28
29 %description devel
30 Livebox viewer development library (dev)
31
32 %prep
33 %setup -q
34
35 %build
36 %cmake .
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42 mkdir -p %{buildroot}/%{_datarootdir}/license
43
44 %post
45
46 %files -n liblivebox-viewer
47 %manifest liblivebox-viewer.manifest
48 %defattr(-,root,root,-)
49 %{_libdir}/*.so*
50 %{_datarootdir}/license/*
51
52 %files devel
53 %defattr(-,root,root,-)
54 %{_includedir}/livebox-viewer/livebox.h
55 %{_datarootdir}/doc/livebox-viewer/livebox-viewer_PG.h
56 %{_libdir}/pkgconfig/*.pc
57
58 # End of a file