Update the FB size when a box gets resized event.
[platform/framework/web/livebox-viewer.git] / packaging / liblivebox-viewer.spec
1 Name: liblivebox-viewer
2 Summary: Library for developing the application.
3 Version: 0.9.8
4 Release: 1
5 Group: framework/livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(aul)
11 BuildRequires: pkgconfig(glib-2.0)
12 BuildRequires: pkgconfig(gio-2.0)
13 BuildRequires: pkgconfig(com-core)
14 BuildRequires: pkgconfig(x11)
15 BuildRequires: pkgconfig(xext)
16 BuildRequires: pkgconfig(sqlite3)
17 BuildRequires: pkgconfig(db-util)
18 BuildRequires: pkgconfig(livebox-service)
19
20 %description
21 API for creating a new instance of the livebox and managing its life-cycle.
22
23 %package devel
24 Summary: Header and package configuration files for the livebox viewer development.
25 Group: Development/Libraries
26 Requires: %{name} = %{version}-%{release}
27
28 %description devel
29 Livebox viewer development library (dev)
30
31 %prep
32 %setup -q
33
34 %build
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
36 make %{?jobs:-j%jobs}
37
38 %install
39 rm -rf %{buildroot}
40 %make_install
41 mkdir -p %{buildroot}/%{_datarootdir}/license
42
43 %post
44
45 %files -n liblivebox-viewer
46 %manifest liblivebox-viewer.manifest
47 %defattr(-,root,root,-)
48 %{_libdir}/*.so*
49 %{_datarootdir}/license/*
50
51 %files devel
52 %defattr(-,root,root,-)
53 %{_includedir}/livebox-viewer/livebox.h
54 %{_datarootdir}/doc/livebox-viewer/livebox-viewer_PG.h
55 %{_libdir}/pkgconfig/*.pc
56
57 # End of a file