Fix the invalid created event handling codes.
[platform/framework/web/livebox-viewer.git] / packaging / liblivebox-viewer.spec
1 Name: liblivebox-viewer
2 Summary: Library for developing the application
3 Version: 0.20.4
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires: cmake, gettext-tools, coreutils
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(aul)
12 BuildRequires: pkgconfig(glib-2.0)
13 BuildRequires: pkgconfig(gio-2.0)
14 BuildRequires: pkgconfig(com-core)
15 BuildRequires: pkgconfig(x11)
16 BuildRequires: pkgconfig(xext)
17 BuildRequires: pkgconfig(sqlite3)
18 BuildRequires: pkgconfig(db-util)
19 BuildRequires: pkgconfig(livebox-service)
20 BuildRequires: pkgconfig(vconf)
21
22 %description
23 API for creating a new instance of the livebox and managing its life-cycle.
24
25 %package devel
26 Summary: Header and package configuration files for the livebox viewer development
27 Group: Development/Libraries
28 Requires: %{name} = %{version}-%{release}
29
30 %description devel
31 Livebox viewer development library (dev)
32
33 %prep
34 %setup -q
35 cp %{SOURCE1001} .
36
37 %build
38 %if 0%{?sec_build_binary_debug_enable}
39 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
40 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
41 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
42 %endif
43
44 %if 0%{?tizen_build_binary_release_type_eng}
45 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
46 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
47 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
48 %endif
49 %cmake .
50 make %{?jobs:-j%jobs}
51
52 %install
53 rm -rf %{buildroot}
54 %make_install
55 mkdir -p %{buildroot}/%{_datarootdir}/license
56
57 %post
58
59 %files -n liblivebox-viewer
60 %manifest %{name}.manifest
61 %defattr(-,root,root,-)
62 %{_libdir}/*.so*
63 %{_datarootdir}/license/*
64
65 %files devel
66 %manifest %{name}.manifest
67 %defattr(-,root,root,-)
68 %{_includedir}/livebox-viewer/livebox.h
69 %{_libdir}/pkgconfig/*.pc
70
71 # End of a file