Update the accessibility event handler.
[platform/framework/web/livebox-edje.git] / packaging / liblivebox-edje.spec
1 Name: liblivebox-edje
2 Summary: EDJE Script loader for the data provider master
3 Version: 0.5.14
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools, coreutils
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(eina)
11 BuildRequires: pkgconfig(evas)
12 BuildRequires: pkgconfig(edje)
13 BuildRequires: pkgconfig(eet)
14 BuildRequires: pkgconfig(vconf)
15 BuildRequires: pkgconfig(ecore-x)
16 BuildRequires: pkgconfig(ecore)
17 BuildRequires: pkgconfig(elementary)
18 BuildRequires: pkgconfig(livebox-service)
19 BuildRequires: pkgconfig(capi-system-system-settings)
20
21 %description
22 Plugin for the data provider master to load the edje scripts
23
24 %prep
25 %setup -q
26
27 %build
28 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
29 make %{?jobs:-j%jobs}
30
31 %install
32 rm -rf %{buildroot}
33 %make_install
34 mkdir -p %{buildroot}/%{_datarootdir}/license
35
36 %post
37
38 %files -n liblivebox-edje
39 %manifest liblivebox-edje.manifest
40 %defattr(-,root,root,-)
41 /usr/share/data-provider-master/plugin-script/*.so*
42 %{_datarootdir}/license/*
43
44 # End of a file