4623b6358f9bceb5e66c6d294721d62b1cb7f5d1
[platform/framework/web/livebox-cpp.git] / packaging / liblivebox-cpp.spec
1 Name: liblivebox-cpp
2 Summary: C++ adaptor for a livebox 
3 Version: 0.2.8
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 Source1001:     liblivebox-cpp.manifest
9 BuildRequires: cmake, gettext-tools, coreutils
10 BuildRequires: pkgconfig(dlog)
11 BuildRequires: pkgconfig(livebox)
12 BuildRequires: pkgconfig(evas)
13 BuildRequires: pkgconfig(livebox-service)
14
15 %description
16 Livebox development library (C++)
17
18 %package devel
19 Summary: Files for livebox development.
20 Group: Development/Libraries
21 Requires: %{name} = %{version}-%{release}
22
23 %description devel
24 Livebox development library (C++) (dev)
25
26 %prep
27 %setup -q
28 cp %{SOURCE1001} .
29
30 %build
31 %if 0%{?tizen_build_binary_release_type_eng}
32 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
33 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
34 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
35 %endif
36 %cmake .
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42 mkdir -p %{buildroot}/%{_datarootdir}/license
43
44 %post
45
46 %files -n liblivebox-cpp
47 %manifest %{name}.manifest
48 %defattr(-,root,root,-)
49 %{_libdir}/*.so*
50 %{_datarootdir}/license/*
51
52 %files devel
53 %manifest %{name}.manifest
54 %defattr(-,root,root,-)
55 %{_includedir}/livebox-cpp/livebox-cpp.h
56 %{_datarootdir}/doc/livebox-cpp/livebox-cpp_PG.h
57 %{_libdir}/pkgconfig/*.pc
58
59 # End of a file