Sync with the latest one
[platform/framework/web/heap-monitor.git] / packaging / libheap-monitor.spec
1 Name: libheap-monitor
2 Summary: Library for monitoring the heap usage
3 Version: 0.0.17
4 Release: 1
5 Group: HomeTF/Livebox
6 License: Flora
7 Source0: %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires: cmake, gettext-tools, coreutils
10 BuildRequires: pkgconfig(dlog)
11
12 %description
13 Monitoring the heap usage to manage them safely.
14
15 %package devel
16 Summary: Files for implementaion of the heap monitor
17 Group: Development/Libraries
18 Requires: %{name} = %{version}-%{release}
19
20 %description devel
21 Monitoring the heap usage to manage them safely.(dev)
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 %if 0%{?sec_build_binary_debug_enable}
29 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
30 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
31 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
32 %endif
33
34 %if 0%{?tizen_build_binary_release_type_eng}
35 export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
36 export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
37 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
38 %endif
39
40 %cmake .
41 CFLAGS+="${CFLAGS} -fvisibility=hidden -Wall -Werror -Winline -fno-builtin-malloc" make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46 mkdir -p %{buildroot}/%{_datarootdir}/license
47
48 %post
49
50 %files
51 %manifest %{name}.manifest
52 %defattr(-,root,root,-)
53 %{_libdir}/*.so*
54 %{_datarootdir}/license/*
55
56 %files devel
57 %manifest %{name}.manifest
58 %defattr(-,root,root,-)
59 %{_includedir}/heap-monitor/heap-monitor.h
60 %{_libdir}/pkgconfig/*.pc
61
62 # End of a file