3e2ed89953ada6c983a699bbbd9298dfb8de9d8e
[platform/framework/web/crosswalk.git] / src / xwalk / packaging / crosswalk.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           crosswalk
5 Version:        5.34.105.0
6 Release:        0
7 Summary:        Crosswalk is an app runtime based on Chromium
8 License:        (BSD-3-Clause and LGPL-2.1+)
9 Group:          Web Framework/Web Run Time
10 Url:            https://github.com/otcshare/crosswalk
11 Source:         %{name}.tar
12 Source1:        xwalk.in
13 Source2:        org.crosswalkproject.Runtime1.service
14 Source3:        xwalk.service.in
15 Source1001:     crosswalk.manifest
16 Source1002:     %{name}.xml.in
17 Source1003:     %{name}.png
18 Patch1:         %{name}-do-not-look-for-gtk2-when-using-aura.patch
19 Patch7:         %{name}-tizen-audio-session-manager.patch
20 Patch8:         %{name}-mesa-ozone-typedefs.patch
21 Patch9:         Blink-Add-GCC-flag-Wno-narrowing-fix-64bits-build.patch
22
23 BuildRequires:  bison
24 BuildRequires:  bzip2-devel
25 BuildRequires:  expat-devel
26 BuildRequires:  flex
27 BuildRequires:  gperf
28 BuildRequires:  libcap-devel
29 BuildRequires:  python
30 BuildRequires:  python-xml
31 BuildRequires:  perl
32 BuildRequires:  which
33 BuildRequires:  pkgconfig(alsa)
34 BuildRequires:  pkgconfig(appcore-common)
35 BuildRequires:  pkgconfig(audio-session-mgr)
36 BuildRequires:  pkgconfig(cairo)
37 BuildRequires:  pkgconfig(capi-location-manager)
38 BuildRequires:  pkgconfig(dbus-1)
39 BuildRequires:  pkgconfig(fontconfig)
40 BuildRequires:  pkgconfig(freetype2)
41 BuildRequires:  pkgconfig(gles20)
42 BuildRequires:  pkgconfig(glib-2.0)
43 BuildRequires:  pkgconfig(haptic)
44 BuildRequires:  pkgconfig(icu-i18n)
45 BuildRequires:  pkgconfig(libdrm)
46 BuildRequires:  pkgconfig(libexif)
47 BuildRequires:  pkgconfig(libpci)
48 BuildRequires:  pkgconfig(libpulse)
49 BuildRequires:  pkgconfig(libudev)
50 BuildRequires:  pkgconfig(libxml-2.0)
51 BuildRequires:  pkgconfig(libxslt)
52 BuildRequires:  pkgconfig(pango)
53 BuildRequires:  pkgconfig(pkgmgr-info)
54 BuildRequires:  pkgconfig(pkgmgr-parser)
55 BuildRequires:  pkgconfig(nspr)
56 BuildRequires:  pkgconfig(nss)
57 BuildRequires:  pkgconfig(sensor)
58 BuildRequires:  pkgconfig(vconf)
59 %if %{with x}
60 BuildRequires:  pkgconfig(x11)
61 BuildRequires:  pkgconfig(xcomposite)
62 BuildRequires:  pkgconfig(xcursor)
63 BuildRequires:  pkgconfig(xdamage)
64 BuildRequires:  pkgconfig(xext)
65 BuildRequires:  pkgconfig(xfixes)
66 BuildRequires:  pkgconfig(xi)
67 BuildRequires:  pkgconfig(xrandr)
68 BuildRequires:  pkgconfig(xrender)
69 BuildRequires:  pkgconfig(xscrnsaver)
70 BuildRequires:  pkgconfig(xt)
71 BuildRequires:  pkgconfig(xtst)
72 %endif
73
74 %if %{with wayland}
75 BuildRequires:  pkgconfig(wayland-client)
76 BuildRequires:  pkgconfig(wayland-cursor)
77 BuildRequires:  pkgconfig(wayland-egl)
78 BuildRequires:  pkgconfig(xkbcommon)
79 %else
80 BuildRequires:  pkgconfig(scim)
81 %endif
82
83 %description
84 Crosswalk is an app runtime based on Chromium. It is an open source project started by the Intel Open Source Technology Center (http://www.01.org).
85
86 %define _manifestdir /usr/share/packages
87 %define _manifestdir_ro /opt/share/packages
88 %define _desktop_icondir /usr/share/icons/default/small
89 %define _desktop_icondir_ro /opt/share/icons/default/small
90 %define _dbusservicedir /usr/share/dbus-1/services
91 %define _systemduserservicedir /usr/lib/systemd/user
92
93 %prep
94 %setup -q -n crosswalk
95
96 cp %{SOURCE1} .
97 cp %{SOURCE3} .
98 cp %{SOURCE1001} .
99 cp %{SOURCE1002} .
100 cp %{SOURCE1003} .
101 sed "s/@VERSION@/%{version}/g" %{name}.xml.in > %{name}.xml
102 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.in > xwalk
103 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.service.in > xwalk.service
104
105 cp -a src/AUTHORS AUTHORS.chromium
106 cp -a src/LICENSE LICENSE.chromium
107 cp -a src/xwalk/LICENSE LICENSE.xwalk
108
109 %patch1
110 %patch7
111
112 %if "%{tizen}" < "3.0"
113 %patch2
114 %patch3
115 %patch4
116 %patch5 -p1
117 %patch6
118 %endif
119
120 %if %{with wayland}
121 %patch8
122 %endif
123
124 %patch9
125
126 %build
127
128 # For ffmpeg on ia32. The original CFLAGS set by the gyp and config files in
129 # src/third_party/ffmpeg already pass -O2 -fomit-frame-pointer, but Tizen's
130 # CFLAGS end up appending -fno-omit-frame-pointer. See http://crbug.com/37246
131 export CFLAGS=`echo $CFLAGS | sed s,-fno-omit-frame-pointer,,g`
132
133 # Building the RPM in the GBS chroot fails with errors such as
134 #   /usr/lib/gcc/i586-tizen-linux/4.7/../../../../i586-tizen-linux/bin/ld:
135 #       failed to set dynamic section sizes: Memory exhausted
136 # For now, work around it by passing a GNU ld-specific flag that optimizes the
137 # linker for memory usage.
138 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
139
140 # Support building in a non-standard directory, possibly outside %{_builddir}.
141 # Since the build root is erased every time a new build is performed, one way
142 # to avoid losing the build directory is to specify a location outside the
143 # build root to the BUILDDIR_NAME definition, such as "/var/tmp/xwalk-build"
144 # (remember all paths are still inside the chroot):
145 #    gbs build --define 'BUILDDIR_NAME /some/path'
146 #
147 # The --depth and --generator-output combo is used to put all the Makefiles
148 # inside the build directory, and (this is the important part) keep file lists
149 # (generatedwith <|() in gyp) in the build directory as well, otherwise they
150 # will be in the source directory, erased every time and trigger an almost full
151 # Blink rebuild (among other smaller targets).
152 # We cannot always pass those flags, though, because gyp's make generator does
153 # not work if the --generator-output is the top-level source directory.
154 BUILDDIR_NAME="%{?BUILDDIR_NAME}"
155 if [ -z "${BUILDDIR_NAME}" ]; then
156    BUILDDIR_NAME="."
157 else
158    GYP_EXTRA_FLAGS="--depth=. --generator-output=${BUILDDIR_NAME}"
159 fi
160
161 %if %{with wayland}
162 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Duse_ash=1 -Duse_ozone=1"
163 %endif
164
165 # Change src/ so that we can pass "." to --depth below, otherwise we would need
166 # to pass "src" to it, but this confuses the gyp make generator, that expects
167 # to be called from the root source directory.
168 cd src
169
170 # --no-parallel is added because chroot does not mount a /dev/shm, this will
171 # cause python multiprocessing.SemLock error.
172 export GYP_GENERATORS='make'
173 ./xwalk/gyp_xwalk xwalk/xwalk.gyp \
174 --no-parallel \
175 ${GYP_EXTRA_FLAGS} \
176 -Dchromeos=0 \
177 -Ddisable_nacl=1 \
178 -Dtizen=1 \
179 -Dpython_ver=2.7 \
180 -Duse_aura=1 \
181 -Duse_cups=0 \
182 -Duse_gconf=0 \
183 -Duse_kerberos=0 \
184 -Duse_system_bzip2=1 \
185 -Duse_system_icu=1 \
186 -Duse_system_libexif=1 \
187 -Duse_system_libxml=1 \
188 -Duse_system_nspr=1 \
189 -Denable_xi21_mt=1 \
190 -Duse_xi2_mt=0 \
191 -Denable_hidpi=1
192
193 make %{?_smp_mflags} -C "${BUILDDIR_NAME}" BUILDTYPE=Release xwalk xwalkctl xwalk_launcher xwalk-pkg-helper
194
195 %install
196 # Support building in a non-standard directory, possibly outside %{_builddir}.
197 # Since the build root is erased every time a new build is performed, one way
198 # to avoid losing the build directory is to specify a location outside the
199 # build root to the BUILDDIR_NAME definition, such as "/var/tmp/xwalk-build"
200 # (remember all paths are still inside the chroot):
201 #    gbs build --define 'BUILDDIR_NAME /some/path'
202 BUILDDIR_NAME="%{?BUILDDIR_NAME}"
203 if [ -z "${BUILDDIR_NAME}" ]; then
204    BUILDDIR_NAME="."
205 fi
206
207 # Since BUILDDIR_NAME can be either a relative path or an absolute one, we need
208 # to cd into src/ so that it means the same thing in the build and install
209 # stages: during the former, a relative location refers to a place inside src/,
210 # whereas during the latter a relative location by default would refer to a
211 # place one directory above src/. If BUILDDIR_NAME is an absolute path, this is
212 # irrelevant anyway.
213 cd src
214
215 # Binaries.
216 install -p -D ../xwalk %{buildroot}%{_bindir}/xwalk
217 install -p -D %{SOURCE2} %{buildroot}%{_dbusservicedir}/org.crosswalkproject.Runtime1.service
218 install -p -D ../xwalk.service %{buildroot}%{_systemduserservicedir}/xwalk.service
219 install -p -D ${BUILDDIR_NAME}/out/Release/xwalk %{buildroot}%{_libdir}/xwalk/xwalk
220 install -p -D ${BUILDDIR_NAME}/out/Release/xwalkctl %{buildroot}%{_bindir}/xwalkctl
221 install -p -D ${BUILDDIR_NAME}/out/Release/xwalk-launcher %{buildroot}%{_bindir}/xwalk-launcher
222 # xwalk-pkg-helper needs to be set-user-ID-root so it can finish the installation process.
223 install -m 06755 -p -D ${BUILDDIR_NAME}/out/Release/xwalk-pkg-helper %{buildroot}%{_bindir}/xwalk-pkg-helper
224
225 # Supporting libraries and resources.
226 install -p -D ${BUILDDIR_NAME}/out/Release/icudtl.dat %{buildroot}%{_libdir}/xwalk/icudtl.dat
227 install -p -D ${BUILDDIR_NAME}/out/Release/libffmpegsumo.so %{buildroot}%{_libdir}/xwalk/libffmpegsumo.so
228 install -p -D ${BUILDDIR_NAME}/out/Release/xwalk.pak %{buildroot}%{_libdir}/xwalk/xwalk.pak
229
230 # Register xwalk to the package manager.
231 install -p -D ../%{name}.xml %{buildroot}%{_manifestdir}/%{name}.xml
232 install -p -D ../%{name}.png %{buildroot}%{_desktop_icondir}/%{name}.png
233
234
235 %post
236 mkdir -p %{_desktop_icondir_ro}
237 mkdir -p %{_manifestdir_ro}
238
239 %files
240 %manifest %{name}.manifest
241 %license AUTHORS.chromium LICENSE.chromium LICENSE.xwalk
242 %{_bindir}/xwalk
243 %{_bindir}/xwalkctl
244 %{_bindir}/xwalk-launcher
245 %{_bindir}/xwalk-pkg-helper
246 %{_libdir}/xwalk/icudtl.dat
247 %{_libdir}/xwalk/libffmpegsumo.so
248 %{_libdir}/xwalk/xwalk
249 %{_libdir}/xwalk/xwalk.pak
250 %{_manifestdir}/%{name}.xml
251 %{_desktop_icondir}/%{name}.png
252 %{_dbusservicedir}/org.crosswalkproject.Runtime1.service
253 %{_systemduserservicedir}/xwalk.service