Upstream version 10.38.210.0
[platform/framework/web/crosswalk.git] / packaging / crosswalk.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %ifarch x86_64 %{arm}
5 ### x86_64
6 # NaCl build on 64bit system require libc 32bit to build the 32 IRT.
7 # While Tizen 64bit image does not offer 32bit packages at all,
8 # check https://bugs.tizen.org/jira/browse/PTREL-803 for details.
9 # So disable nacl for 64bit now.
10 ### ARM
11 # Due to OBS build for ARM some files needed by NaCl to be build
12 # are not present.
13 %define _disable_nacl 1
14 %else
15 %define _disable_nacl 0
16 %endif
17
18 Name:           crosswalk
19 Version:        10.38.210.0
20 Release:        0
21 Summary:        Chromium-based app runtime
22 License:        (BSD-3-Clause and LGPL-2.1+)
23 Group:          Web Framework/Web Run Time
24 Url:            https://github.com/otcshare/crosswalk
25 Source:         %{name}.tar
26 Source1:        xwalk.in
27 Source2:        org.crosswalkproject.Runtime1.service
28 Source3:        xwalk.service.in
29 Source1001:     crosswalk.manifest
30 Source1002:     %{name}.xml.in
31 Source1003:     %{name}.png
32 Patch9:         Blink-Add-GCC-flag-Wno-narrowing-fix-64bits-build.patch
33 Patch10:        crosswalk-do-not-look-for-gtk-dependencies-on-x11.patch
34
35 BuildRequires:  bison
36 BuildRequires:  bzip2-devel
37 BuildRequires:  elfutils
38 BuildRequires:  expat-devel
39 BuildRequires:  flex
40 BuildRequires:  gperf
41 BuildRequires:  libcap-devel
42 BuildRequires:  libelf-devel
43 BuildRequires:  ninja
44 BuildRequires:  python
45 BuildRequires:  python-xml
46 BuildRequires:  perl
47 BuildRequires:  which
48 BuildRequires:  pkgconfig(ail)
49 BuildRequires:  pkgconfig(alsa)
50 BuildRequires:  pkgconfig(appcore-common)
51 BuildRequires:  pkgconfig(cairo)
52 BuildRequires:  pkgconfig(capi-location-manager)
53 BuildRequires:  pkgconfig(dbus-1)
54 BuildRequires:  pkgconfig(fontconfig)
55 BuildRequires:  pkgconfig(freetype2)
56 BuildRequires:  pkgconfig(gles20)
57 BuildRequires:  pkgconfig(glib-2.0)
58 BuildRequires:  pkgconfig(haptic)
59 BuildRequires:  pkgconfig(icu-i18n)
60 BuildRequires:  pkgconfig(libdrm)
61 BuildRequires:  pkgconfig(libexif)
62 BuildRequires:  pkgconfig(libpci)
63 BuildRequires:  pkgconfig(libpulse)
64 BuildRequires:  pkgconfig(libtzplatform-config)
65 BuildRequires:  pkgconfig(libudev)
66 BuildRequires:  pkgconfig(libxml-2.0)
67 BuildRequires:  pkgconfig(libxslt)
68 BuildRequires:  pkgconfig(pango)
69 BuildRequires:  pkgconfig(pkgmgr)
70 BuildRequires:  pkgconfig(pkgmgr-info)
71 BuildRequires:  pkgconfig(pkgmgr-installer)
72 BuildRequires:  pkgconfig(pkgmgr-parser)
73 BuildRequires:  pkgconfig(nspr)
74 BuildRequires:  pkgconfig(nss)
75 BuildRequires:  pkgconfig(sensor)
76 BuildRequires:  pkgconfig(vconf)
77 BuildRequires:  pkgconfig(xmlsec1)
78 %if %{with x}
79 BuildRequires:  pkgconfig(x11)
80 BuildRequires:  pkgconfig(xcomposite)
81 BuildRequires:  pkgconfig(xcursor)
82 BuildRequires:  pkgconfig(xdamage)
83 BuildRequires:  pkgconfig(xext)
84 BuildRequires:  pkgconfig(xfixes)
85 BuildRequires:  pkgconfig(xi)
86 BuildRequires:  pkgconfig(xrandr)
87 BuildRequires:  pkgconfig(xrender)
88 BuildRequires:  pkgconfig(xscrnsaver)
89 BuildRequires:  pkgconfig(xt)
90 BuildRequires:  pkgconfig(xtst)
91 %endif
92
93 %if "%{profile}" == "ivi"
94 BuildRequires:  pkgconfig(murphy-common)
95 BuildRequires:  pkgconfig(murphy-resource)
96 %endif
97
98 %if %{with wayland}
99 BuildRequires:  pkgconfig(wayland-client)
100 BuildRequires:  pkgconfig(wayland-cursor)
101 BuildRequires:  pkgconfig(wayland-egl)
102 BuildRequires:  pkgconfig(xkbcommon)
103 %else
104 BuildRequires:  pkgconfig(scim)
105 %endif
106 Requires:  ca-certificates-tizen
107
108 %description
109 Crosswalk is an app runtime based on Chromium. It is an open source project started by the Intel Open Source Technology Center (http://www.01.org).
110
111 %define _manifestdir %TZ_SYS_RO_PACKAGES
112 %define _manifestdir_ro %TZ_SYS_RO_PACKAGE
113 %define _desktop_icondir %TZ_SYS_RW_ICONS/default/small
114 %define _desktop_icondir_ro %TZ_SYS_RO_ICONS/default/small
115 %define _dbusservicedir /usr/share/dbus-1/services
116 %define _systemduserservicedir /usr/lib/systemd/user
117
118 %prep
119 %setup -q -n crosswalk
120
121 cp %{SOURCE1} .
122 cp %{SOURCE3} .
123 cp %{SOURCE1001} .
124 cp %{SOURCE1002} .
125 cp %{SOURCE1003} .
126 sed "s/@VERSION@/%{version}/g" %{name}.xml.in > %{name}.xml
127 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.in > xwalk
128 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.service.in > xwalk.service
129
130 cp -a src/AUTHORS AUTHORS.chromium
131 cp -a src/LICENSE LICENSE.chromium
132 cp -a src/xwalk/LICENSE LICENSE.xwalk
133
134 %patch9
135
136 # The profiles using Wayland (and thus Ozone) do not need this patch.
137 %if !%{with wayland}
138 %patch10
139 %endif
140
141 %build
142
143 # For ffmpeg on ia32. The original CFLAGS set by the gyp and config files in
144 # src/third_party/ffmpeg already pass -O2 -fomit-frame-pointer, but Tizen's
145 # CFLAGS end up appending -fno-omit-frame-pointer. See http://crbug.com/37246
146 export CFLAGS=`echo $CFLAGS | sed s,-fno-omit-frame-pointer,,g`
147
148 %if ! %{_disable_nacl}
149 # For nacl_bootstrap on ia32. The original CFLAGS set by the gyp
150 # native_client/src/trusted/service_runtime/linux/nacl_bootstrap.gyp already ignored 
151 # -fstack-protector and -funwind-tables, but Tizen's CFLAGS end up appending them, thus
152 # causing linking failures. Check XWALK-1689 for details.
153 export CFLAGS=`echo $CFLAGS | sed s,-fstack-protector,,g`
154 export CFLAGS=`echo $CFLAGS | sed s,-funwind-tables,,g`
155 %endif
156
157 # Building the RPM in the GBS chroot fails with errors such as
158 #   /usr/lib/gcc/i586-tizen-linux/4.7/../../../../i586-tizen-linux/bin/ld:
159 #       failed to set dynamic section sizes: Memory exhausted
160 # For now, work around it by passing a GNU ld-specific flag that optimizes the
161 # linker for memory usage.
162 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
163
164 # Support building in a non-standard directory, possibly outside %{_builddir}.
165 # Since the build root is erased every time a new build is performed, one way
166 # to avoid losing the build directory is to specify a location outside the
167 # build root to the BUILDDIR_NAME definition, such as "/var/tmp/xwalk-build"
168 # (remember all paths are still inside the chroot):
169 #    gbs build --define 'BUILDDIR_NAME /some/path'
170 BUILDDIR_NAME="%{?BUILDDIR_NAME}"
171 if [ -n "${BUILDDIR_NAME}" ]; then
172    mkdir -p "${BUILDDIR_NAME}"
173    ln -s "${BUILDDIR_NAME}" src/out
174 fi
175
176 %if %{with wayland}
177 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Duse_ozone=1 -Denable_ozone_wayland_vkb=1 -Denable_xdg_shell=1"
178 %endif
179
180 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_nacl=%{_disable_nacl}"
181
182 # Linking fails in Tizen Common when fatal ld warnings are enabled. XWALK-1379.
183 %if "%{profile}" == "common" || "%{profile}" == "generic"
184 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_fatal_linker_warnings=1"
185 %endif
186
187 # For building for arm in OBS, we need :
188 # -> to unset sysroot value.
189 # sysroot variable is automatically set for cross compilation to use arm-sysroot provided by Chromium project
190 # -> to force system ld binary.
191 # Indeed the build is made on Emulated / Virtualized environment that correspond
192 # to the target.
193 # gold ld used is avaible only for 32/64 bits Intel Arch.
194 # sysroot usage is not needed, we need to use arm libraries from the virtualized environment.
195 #
196 # Crosswalk build fails if the fpu selected in the gcc option is different from neon in case of arm7 compilation
197 # So force it.
198 %ifarch %{arm}
199 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Dsysroot= -Dlinux_use_gold_binary=0"
200 export CFLAGS=`echo $CFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
201 export CXXFLAGS=`echo $CXXFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
202 export FFLAGS=`echo $FFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
203 %endif
204
205 %if "%{profile}" == "ivi"
206 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Denable_murphy=1"
207 %endif
208
209 # --no-parallel is added because chroot does not mount a /dev/shm, this will
210 # cause python multiprocessing.SemLock error.
211 export GYP_GENERATORS='ninja'
212 ./src/xwalk/gyp_xwalk src/xwalk/xwalk.gyp \
213 --no-parallel \
214 ${GYP_EXTRA_FLAGS} \
215 -Dchromeos=0 \
216 -Dclang=0 \
217 -Dtizen=1 \
218 -Dpython_ver=2.7 \
219 -Duse_aura=1 \
220 -Duse_cups=0 \
221 -Duse_gconf=0 \
222 -Duse_gnome_keyring=0 \
223 -Duse_kerberos=0 \
224 -Duse_system_bzip2=1 \
225 -Duse_system_libexif=1 \
226 -Duse_system_libxml=1 \
227 -Duse_system_nspr=1 \
228 -Dshared_process_mode=1 \
229 -Denable_hidpi=1
230
231 ninja %{?_smp_mflags} -C src/out/Release xwalk xwalkctl xwalk_launcher xwalk-pkg-helper xwalk-backendlib
232
233 %install
234 # Binaries.
235 install -p -D %{SOURCE2} %{buildroot}%{_dbusservicedir}/org.crosswalkproject.Runtime1.service
236 install -p -D xwalk.service %{buildroot}%{_systemduserservicedir}/xwalk.service
237 install -p -D src/out/Release/xwalk %{buildroot}%{_libdir}/xwalk/xwalk
238 install -p -D src/out/Release/xwalkctl %{buildroot}%{_bindir}/xwalkctl
239 install -p -D src/out/Release/xwalk-launcher %{buildroot}%{_bindir}/xwalk-launcher
240 # xwalk-pkg-helper needs to be set-user-ID-root so it can finish the installation process.
241 install -m 0755 -p -D src/out/Release/xwalk-pkg-helper %{buildroot}%{_bindir}/xwalk-pkg-helper
242 install -p -D src/out/Release/lib/libxwalk-backendlib.so %{buildroot}%{_libdir}/xwalk/libxwalk-backendlib.so
243 install -p -D src/xwalk/application/tools/tizen/xwalk_backend_wrapper.sh %{buildroot}%{_libdir}/xwalk/xwalk_backend_wrapper.sh
244
245 # Supporting libraries and resources.
246 install -p -D src/out/Release/icudtl.dat %{buildroot}%{_libdir}/xwalk/icudtl.dat
247 install -p -D src/out/Release/libffmpegsumo.so %{buildroot}%{_libdir}/xwalk/libffmpegsumo.so
248 install -p -D src/out/Release/xwalk.pak %{buildroot}%{_libdir}/xwalk/xwalk.pak
249 mkdir -p %{buildroot}%{_datadir}/xwalk
250 install -p -D src/xwalk/application/common/tizen/configuration/*.xsd %{buildroot}%{_datadir}/xwalk/
251
252 # PNaCl
253 %if ! %{_disable_nacl}
254 install -p -D src/out/Release/nacl_bootstrap_raw %{buildroot}%{_libdir}/xwalk/nacl_bootstrap_raw
255 install -p -D src/out/Release/nacl_helper %{buildroot}%{_libdir}/xwalk/nacl_helper
256 install -p -D src/out/Release/nacl_helper_bootstrap %{buildroot}%{_libdir}/xwalk/nacl_helper_bootstrap
257 install -p -D src/out/Release/nacl_irt_*.nexe %{buildroot}%{_libdir}/xwalk
258 install -p -d %{buildroot}%{_libdir}/xwalk/pnacl
259 install -m 0664 -p -D src/out/Release/pnacl/* %{buildroot}%{_libdir}/xwalk/pnacl
260 %endif
261
262 # Register xwalk to the package manager.
263 install -p -D %{name}.xml %{buildroot}%{_manifestdir}/%{name}.xml
264 install -p -D %{name}.png %{buildroot}%{_desktop_icondir}/%{name}.png
265
266 %post
267 mkdir -p %{_desktop_icondir_ro}
268 mkdir -p %{_manifestdir_ro}
269
270 ln -sf %{_libdir}/xwalk/libxwalk-backendlib.so /etc/package-manager/backendlib/libxpk.so
271 ln -sf %{_libdir}/xwalk/libxwalk-backendlib.so /etc/package-manager/backendlib/libwgt.so
272 ln -sf %{_libdir}/xwalk/xwalk_backend_wrapper.sh /etc/package-manager/backend/xpk
273 ln -sf %{_libdir}/xwalk/xwalk_backend_wrapper.sh /etc/package-manager/backend/wgt
274
275 %preun
276 [ -L /etc/package-manager/backendlib/libxpk.so ] && rm /etc/package-manager/backendlib/libxpk.so
277 [ -L /etc/package-manager/backendlib/libwgt.so ] && rm /etc/package-manager/backendlib/libwgt.so
278 [ -L /etc/package-manager/backend/xpk ] && rm /etc/package-manager/backend/xpk
279 [ -L /etc/package-manager/backend/wgt ] && rm /etc/package-manager/backend/wgt
280
281 %files
282 %manifest %{name}.manifest
283 %license AUTHORS.chromium LICENSE.chromium LICENSE.xwalk
284 %{_bindir}/xwalkctl
285 %{_bindir}/xwalk-launcher
286 %{_bindir}/xwalk-pkg-helper
287 %{_libdir}/xwalk/icudtl.dat
288 %{_libdir}/xwalk/libffmpegsumo.so
289 %if ! %{_disable_nacl}
290 %{_libdir}/xwalk/nacl_bootstrap_raw
291 %{_libdir}/xwalk/nacl_helper
292 %{_libdir}/xwalk/nacl_helper_bootstrap
293 %{_libdir}/xwalk/nacl_irt_*.nexe
294 %{_libdir}/xwalk/pnacl/*
295 %endif
296 %{_libdir}/xwalk/xwalk
297 %{_libdir}/xwalk/xwalk.pak
298 %{_libdir}/xwalk/libxwalk-backendlib.so
299 %{_libdir}/xwalk/xwalk_backend_wrapper.sh
300 %{_manifestdir}/%{name}.xml
301 %{_desktop_icondir}/%{name}.png
302 %{_dbusservicedir}/org.crosswalkproject.Runtime1.service
303 %{_systemduserservicedir}/xwalk.service
304 %{_datadir}/xwalk/*