Upstream version 9.38.204.0
[platform/framework/web/crosswalk.git] / packaging / crosswalk.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 %ifarch x86_64 %{arm}
5 ### x86_64
6 # NaCl build on 64bit system require libc 32bit to build the 32 IRT.
7 # While Tizen 64bit image does not offer 32bit packages at all,
8 # check https://bugs.tizen.org/jira/browse/PTREL-803 for details.
9 # So disable nacl for 64bit now.
10 ### ARM
11 # Due to OBS build for ARM some files needed by NaCl to be build
12 # are not present.
13 %define _disable_nacl 1
14 %else
15 %define _disable_nacl 0
16 %endif
17
18 Name:           crosswalk
19 Version:        9.38.204.0
20 Release:        0
21 Summary:        Chromium-based app runtime
22 License:        (BSD-3-Clause and LGPL-2.1+)
23 Group:          Web Framework/Web Run Time
24 Url:            https://github.com/otcshare/crosswalk
25 Source:         %{name}.tar
26 Source1:        xwalk.in
27 Source2:        org.crosswalkproject.Runtime1.service
28 Source3:        xwalk.service.in
29 Source1001:     crosswalk.manifest
30 Source1002:     %{name}.xml.in
31 Source1003:     %{name}.png
32 Patch9:         Blink-Add-GCC-flag-Wno-narrowing-fix-64bits-build.patch
33 Patch10:        crosswalk-do-not-look-for-gtk-dependencies-on-x11.patch
34
35 BuildRequires:  bison
36 BuildRequires:  bzip2-devel
37 BuildRequires:  elfutils
38 BuildRequires:  expat-devel
39 BuildRequires:  flex
40 BuildRequires:  gperf
41 BuildRequires:  libcap-devel
42 BuildRequires:  libelf-devel
43 BuildRequires:  ninja
44 BuildRequires:  python
45 BuildRequires:  python-xml
46 BuildRequires:  perl
47 BuildRequires:  which
48 BuildRequires:  pkgconfig(ail)
49 BuildRequires:  pkgconfig(alsa)
50 BuildRequires:  pkgconfig(appcore-common)
51 BuildRequires:  pkgconfig(cairo)
52 BuildRequires:  pkgconfig(capi-location-manager)
53 BuildRequires:  pkgconfig(dbus-1)
54 BuildRequires:  pkgconfig(fontconfig)
55 BuildRequires:  pkgconfig(freetype2)
56 BuildRequires:  pkgconfig(gles20)
57 BuildRequires:  pkgconfig(glib-2.0)
58 BuildRequires:  pkgconfig(haptic)
59 BuildRequires:  pkgconfig(icu-i18n)
60 BuildRequires:  pkgconfig(libdrm)
61 BuildRequires:  pkgconfig(libexif)
62 BuildRequires:  pkgconfig(libpci)
63 BuildRequires:  pkgconfig(libpulse)
64 BuildRequires:  pkgconfig(libtzplatform-config)
65 BuildRequires:  pkgconfig(libudev)
66 BuildRequires:  pkgconfig(libxml-2.0)
67 BuildRequires:  pkgconfig(libxslt)
68 BuildRequires:  pkgconfig(pango)
69 BuildRequires:  pkgconfig(pkgmgr)
70 BuildRequires:  pkgconfig(pkgmgr-info)
71 BuildRequires:  pkgconfig(pkgmgr-installer)
72 BuildRequires:  pkgconfig(pkgmgr-parser)
73 BuildRequires:  pkgconfig(nspr)
74 BuildRequires:  pkgconfig(nss)
75 BuildRequires:  pkgconfig(sensor)
76 BuildRequires:  pkgconfig(vconf)
77 %if %{with x}
78 BuildRequires:  pkgconfig(x11)
79 BuildRequires:  pkgconfig(xcomposite)
80 BuildRequires:  pkgconfig(xcursor)
81 BuildRequires:  pkgconfig(xdamage)
82 BuildRequires:  pkgconfig(xext)
83 BuildRequires:  pkgconfig(xfixes)
84 BuildRequires:  pkgconfig(xi)
85 BuildRequires:  pkgconfig(xrandr)
86 BuildRequires:  pkgconfig(xrender)
87 BuildRequires:  pkgconfig(xscrnsaver)
88 BuildRequires:  pkgconfig(xt)
89 BuildRequires:  pkgconfig(xtst)
90 %endif
91
92 %if "%{profile}" == "ivi"
93 BuildRequires:  pkgconfig(murphy-common)
94 BuildRequires:  pkgconfig(murphy-resource)
95 %endif
96
97 %if %{with wayland}
98 BuildRequires:  pkgconfig(wayland-client)
99 BuildRequires:  pkgconfig(wayland-cursor)
100 BuildRequires:  pkgconfig(wayland-egl)
101 BuildRequires:  pkgconfig(xkbcommon)
102 %else
103 BuildRequires:  pkgconfig(scim)
104 %endif
105
106 %description
107 Crosswalk is an app runtime based on Chromium. It is an open source project started by the Intel Open Source Technology Center (http://www.01.org).
108
109 %define _manifestdir %TZ_SYS_RO_PACKAGES
110 %define _manifestdir_ro %TZ_SYS_RO_PACKAGE
111 %define _desktop_icondir %TZ_SYS_RW_ICONS/default/small
112 %define _desktop_icondir_ro %TZ_SYS_RO_ICONS/default/small
113 %define _dbusservicedir /usr/share/dbus-1/services
114 %define _systemduserservicedir /usr/lib/systemd/user
115
116 %prep
117 %setup -q -n crosswalk
118
119 cp %{SOURCE1} .
120 cp %{SOURCE3} .
121 cp %{SOURCE1001} .
122 cp %{SOURCE1002} .
123 cp %{SOURCE1003} .
124 sed "s/@VERSION@/%{version}/g" %{name}.xml.in > %{name}.xml
125 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.in > xwalk
126 sed "s|@LIB_INSTALL_DIR@|%{_libdir}|g" xwalk.service.in > xwalk.service
127
128 cp -a src/AUTHORS AUTHORS.chromium
129 cp -a src/LICENSE LICENSE.chromium
130 cp -a src/xwalk/LICENSE LICENSE.xwalk
131
132 %patch9
133
134 # The profiles using Wayland (and thus Ozone) do not need this patch.
135 %if !%{with wayland}
136 %patch10
137 %endif
138
139 %build
140
141 # For ffmpeg on ia32. The original CFLAGS set by the gyp and config files in
142 # src/third_party/ffmpeg already pass -O2 -fomit-frame-pointer, but Tizen's
143 # CFLAGS end up appending -fno-omit-frame-pointer. See http://crbug.com/37246
144 export CFLAGS=`echo $CFLAGS | sed s,-fno-omit-frame-pointer,,g`
145
146 %if ! %{_disable_nacl}
147 # For nacl_bootstrap on ia32. The original CFLAGS set by the gyp
148 # native_client/src/trusted/service_runtime/linux/nacl_bootstrap.gyp already ignored 
149 # -fstack-protector and -funwind-tables, but Tizen's CFLAGS end up appending them, thus
150 # causing linking failures. Check XWALK-1689 for details.
151 export CFLAGS=`echo $CFLAGS | sed s,-fstack-protector,,g`
152 export CFLAGS=`echo $CFLAGS | sed s,-funwind-tables,,g`
153 %endif
154
155 # Building the RPM in the GBS chroot fails with errors such as
156 #   /usr/lib/gcc/i586-tizen-linux/4.7/../../../../i586-tizen-linux/bin/ld:
157 #       failed to set dynamic section sizes: Memory exhausted
158 # For now, work around it by passing a GNU ld-specific flag that optimizes the
159 # linker for memory usage.
160 export LDFLAGS="${LDFLAGS} -Wl,--no-keep-memory"
161
162 # Support building in a non-standard directory, possibly outside %{_builddir}.
163 # Since the build root is erased every time a new build is performed, one way
164 # to avoid losing the build directory is to specify a location outside the
165 # build root to the BUILDDIR_NAME definition, such as "/var/tmp/xwalk-build"
166 # (remember all paths are still inside the chroot):
167 #    gbs build --define 'BUILDDIR_NAME /some/path'
168 BUILDDIR_NAME="%{?BUILDDIR_NAME}"
169 if [ -n "${BUILDDIR_NAME}" ]; then
170    mkdir -p "${BUILDDIR_NAME}"
171    ln -s "${BUILDDIR_NAME}" src/out
172 fi
173
174 %if %{with wayland}
175 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Duse_ozone=1 -Denable_ozone_wayland_vkb=1 -Denable_xdg_shell=1"
176 %endif
177
178 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_nacl=%{_disable_nacl}"
179
180 # Linking fails in Tizen Common when fatal ld warnings are enabled. XWALK-1379.
181 %if "%{profile}" == "common" || "%{profile}" == "generic"
182 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_fatal_linker_warnings=1"
183 %endif
184
185 # For building for arm in OBS, we need :
186 # -> to unset sysroot value.
187 # sysroot variable is automatically set for cross compilation to use arm-sysroot provided by Chromium project
188 # -> to force system ld binary.
189 # Indeed the build is made on Emulated / Virtualized environment that correspond
190 # to the target.
191 # gold ld used is avaible only for 32/64 bits Intel Arch.
192 # sysroot usage is not needed, we need to use arm libraries from the virtualized environment.
193 #
194 # Crosswalk build fails if the fpu selected in the gcc option is different from neon in case of arm7 compilation
195 # So force it.
196 %ifarch %{arm}
197 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Dsysroot= -Dlinux_use_gold_binary=0"
198 export CFLAGS=`echo $CFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
199 export CXXFLAGS=`echo $CXXFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
200 export FFLAGS=`echo $FFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
201 %endif
202
203 %if "%{profile}" == "ivi"
204 GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Denable_murphy=1"
205 %endif
206
207 # --no-parallel is added because chroot does not mount a /dev/shm, this will
208 # cause python multiprocessing.SemLock error.
209 export GYP_GENERATORS='ninja'
210 ./src/xwalk/gyp_xwalk src/xwalk/xwalk.gyp \
211 --no-parallel \
212 ${GYP_EXTRA_FLAGS} \
213 -Dchromeos=0 \
214 -Dclang=0 \
215 -Dtizen=1 \
216 -Dpython_ver=2.7 \
217 -Duse_aura=1 \
218 -Duse_cups=0 \
219 -Duse_gconf=0 \
220 -Duse_gnome_keyring=0 \
221 -Duse_kerberos=0 \
222 -Duse_system_bzip2=1 \
223 -Duse_system_libexif=1 \
224 -Duse_system_libxml=1 \
225 -Duse_system_nspr=1 \
226 -Dshared_process_mode=1 \
227 -Denable_hidpi=1
228
229 ninja %{?_smp_mflags} -C src/out/Release xwalk xwalkctl xwalk_launcher xwalk-pkg-helper xwalk-backendlib
230
231 %install
232 # Binaries.
233 install -p -D %{SOURCE2} %{buildroot}%{_dbusservicedir}/org.crosswalkproject.Runtime1.service
234 install -p -D xwalk.service %{buildroot}%{_systemduserservicedir}/xwalk.service
235 install -p -D src/out/Release/xwalk %{buildroot}%{_libdir}/xwalk/xwalk
236 install -p -D src/out/Release/xwalkctl %{buildroot}%{_bindir}/xwalkctl
237 install -p -D src/out/Release/xwalk-launcher %{buildroot}%{_bindir}/xwalk-launcher
238 # xwalk-pkg-helper needs to be set-user-ID-root so it can finish the installation process.
239 install -m 06755 -p -D src/out/Release/xwalk-pkg-helper %{buildroot}%{_bindir}/xwalk-pkg-helper
240 install -p -D src/out/Release/lib/libxwalk-backendlib.so %{buildroot}%{_libdir}/xwalk/libxwalk-backendlib.so
241 install -p -D src/xwalk/application/tools/tizen/xwalk_backend_wrapper.sh %{buildroot}%{_libdir}/xwalk/xwalk_backend_wrapper.sh
242
243 # Supporting libraries and resources.
244 install -p -D src/out/Release/icudtl.dat %{buildroot}%{_libdir}/xwalk/icudtl.dat
245 install -p -D src/out/Release/libffmpegsumo.so %{buildroot}%{_libdir}/xwalk/libffmpegsumo.so
246 install -p -D src/out/Release/xwalk.pak %{buildroot}%{_libdir}/xwalk/xwalk.pak
247 mkdir -p %{buildroot}%{_datadir}/xwalk
248 install -p -D src/xwalk/application/common/tizen/configuration/*.xsd %{buildroot}%{_datadir}/xwalk/
249
250 # PNaCl
251 %if ! %{_disable_nacl}
252 install -p -D src/out/Release/nacl_bootstrap_raw %{buildroot}%{_libdir}/xwalk/nacl_bootstrap_raw
253 install -p -D src/out/Release/nacl_helper %{buildroot}%{_libdir}/xwalk/nacl_helper
254 install -p -D src/out/Release/nacl_helper_bootstrap %{buildroot}%{_libdir}/xwalk/nacl_helper_bootstrap
255 install -p -D src/out/Release/nacl_irt_*.nexe %{buildroot}%{_libdir}/xwalk
256 install -p -d %{buildroot}%{_libdir}/xwalk/pnacl
257 install -m 0664 -p -D src/out/Release/pnacl/* %{buildroot}%{_libdir}/xwalk/pnacl
258 %endif
259
260 # Register xwalk to the package manager.
261 install -p -D %{name}.xml %{buildroot}%{_manifestdir}/%{name}.xml
262 install -p -D %{name}.png %{buildroot}%{_desktop_icondir}/%{name}.png
263
264 %post
265 mkdir -p %{_desktop_icondir_ro}
266 mkdir -p %{_manifestdir_ro}
267
268 ln -sf %{_libdir}/xwalk/libxwalk-backendlib.so /etc/package-manager/backendlib/libxpk.so
269 ln -sf %{_libdir}/xwalk/libxwalk-backendlib.so /etc/package-manager/backendlib/libwgt.so
270 ln -sf %{_libdir}/xwalk/xwalk_backend_wrapper.sh /etc/package-manager/backend/xpk
271 ln -sf %{_libdir}/xwalk/xwalk_backend_wrapper.sh /etc/package-manager/backend/wgt
272
273 %preun
274 [ -L /etc/package-manager/backendlib/libxpk.so ] && rm /etc/package-manager/backendlib/libxpk.so
275 [ -L /etc/package-manager/backendlib/libwgt.so ] && rm /etc/package-manager/backendlib/libwgt.so
276 [ -L /etc/package-manager/backend/xpk ] && rm /etc/package-manager/backend/xpk
277 [ -L /etc/package-manager/backend/wgt ] && rm /etc/package-manager/backend/wgt
278
279 %files
280 %manifest %{name}.manifest
281 %license AUTHORS.chromium LICENSE.chromium LICENSE.xwalk
282 %{_bindir}/xwalkctl
283 %{_bindir}/xwalk-launcher
284 %{_bindir}/xwalk-pkg-helper
285 %{_libdir}/xwalk/icudtl.dat
286 %{_libdir}/xwalk/libffmpegsumo.so
287 %if ! %{_disable_nacl}
288 %{_libdir}/xwalk/nacl_bootstrap_raw
289 %{_libdir}/xwalk/nacl_helper
290 %{_libdir}/xwalk/nacl_helper_bootstrap
291 %{_libdir}/xwalk/nacl_irt_*.nexe
292 %{_libdir}/xwalk/pnacl/*
293 %endif
294 %{_libdir}/xwalk/xwalk
295 %{_libdir}/xwalk/xwalk.pak
296 %{_libdir}/xwalk/libxwalk-backendlib.so
297 %{_libdir}/xwalk/xwalk_backend_wrapper.sh
298 %{_manifestdir}/%{name}.xml
299 %{_desktop_icondir}/%{name}.png
300 %{_dbusservicedir}/org.crosswalkproject.Runtime1.service
301 %{_systemduserservicedir}/xwalk.service
302 %{_datadir}/xwalk/*