ad4d5ef3181d084bf0eec247ac59407766091075
[platform/framework/native/shell.git] / packaging / osp-shell.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:       osp-shell
5 Summary:    The Shell library of OSP 
6 Version:    1.2.2.0
7 Release:    12
8 Group:      System/Libraries
9 License:    Apache License, Version 2.0 or Flora
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(capi-appfw-application)
13 BuildRequires:  pkgconfig(capi-appfw-app-manager)
14 BuildRequires:  pkgconfig(capi-appfw-package-manager)
15 BuildRequires:  pkgconfig(chromium)
16 BuildRequires:  pkgconfig(osp-appfw)
17 BuildRequires:  pkgconfig(osp-uifw)
18 BuildRequires:  pkgconfig(evas)
19 BuildRequires:  pkgconfig(ecore)
20 BuildRequires:  pkgconfig(elementary)
21 BuildRequires:  pkgconfig(notification)
22 BuildRequires:  pkgconfig(appsvc)
23 BuildRequires:  pkgconfig(pkgmgr)
24 BuildRequires:  pkgconfig(minicontrol-provider)
25 BuildRequires:  pkgconfig(x11)
26 BuildRequires:  pkgconfig(xext)
27 BuildRequires:  pkgconfig(xfixes)
28 BuildRequires:  pkgconfig(xdamage)
29 BuildRequires:  pkgconfig(libdri2)
30 BuildRequires:  pkgconfig(libdrm)
31 BuildRequires:  pkgconfig(libtbm)
32 BuildRequires:  pkgconfig(dri2proto)
33 BuildRequires:  pkgconfig(glib-2.0)
34 BuildRequires:  pkgconfig(provider)
35 BuildRequires:  pkgconfig(livebox-viewer)
36 BuildRequires:  pkgconfig(livebox-service)
37 BuildRequires:  pkgconfig(libdri2)
38 BuildRequires:  pkgconfig(libdrm)
39 BuildRequires:  pkgconfig(shortcut)
40 BuildRequires:  pkgconfig(osp-image)
41 BuildRequires:  pkgconfig(osp-image-core)
42 BuildRequires:  pkgconfig(osp-media)
43 BuildRequires:  pkgconfig(osp-net)
44 BuildRequires:  pkgconfig(vconf)
45 BuildRequires:  osp-image-core-internal-devel
46 BuildRequires:  osp-appfw-internal-devel
47 BuildRequires:  osp-uifw-internal-devel
48 BuildRequires:  boost-devel
49 BuildRequires:  pkgconfig(badge)
50
51
52 # runtime requires
53 Requires: chromium
54 Requires: osp-appfw
55 Requires: osp-uifw 
56
57 Provides:   libosp-shell.so.1
58
59 Requires(post): /sbin/ldconfig
60 Requires(post): coreutils
61 Requires(postun): /sbin/ldconfig
62
63 %description
64 The Shell library of OSP
65
66 %package devel
67 Summary:    The Shell library of OSP (Development)
68 Group:      TO_BE/FILLED_IN
69 Requires:   %{name} = %{version}-%{release}
70 Requires: pkgconfig(osp-image)
71
72 %description devel
73 The Shell library of OSP (DEV)
74
75 %package internal-devel
76 Summary:    osp shell internel (Internal)
77 Group:      TO_BE/FILLED_IN
78 Requires:   %{name} = %{version}-%{release}
79
80 %description internal-devel
81 The Shell library of OSP (Internal-DEV)
82
83 %package debug
84 Summary:    The Shell library of OSP (Development)
85 Group:      TO_BE/FILLED_IN
86 Requires:   %{name} = %{version}-%{release}
87
88 %description debug
89 The Shell library of OSP (debug)
90
91 %prep
92
93 %setup -q
94
95 %build
96 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
97 %ifarch %{ix86}
98 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=x86
99 %else
100 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=arm
101 %endif
102
103 # Call make instruction with smp support
104 make %{?jobs:-j%jobs}
105
106 %install
107 rm -rf %{buildroot}
108 mkdir -p %{buildroot}/usr/share/license
109 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
110 cp %{_builddir}/%{name}-%{version}/LICENSE.Flora  %{buildroot}/usr/share/license/%{name}
111
112 %make_install
113
114 %post -p /sbin/ldconfig
115
116 %postun -p /sbin/ldconfig
117
118 %files
119 %manifest osp-shell.manifest
120 /usr/share/license/%{name}
121 %{_libdir}/osp/*.so*
122
123 %files devel
124 %{_includedir}/osp/*.h
125 %{_libdir}/pkgconfig/osp-shell.pc
126
127 %files internal-devel
128 %{_includedir}/osp/shell/*
129
130
131 %files debug
132 %{_libdir}/osp/debug/*.so*
133