Generate debuginfo package instead of debug package
[platform/framework/native/locations.git] / packaging / osp-locations.spec
1 Name:           osp-locations
2 Summary:        osp locations library
3 Version:        1.2.1.0
4 Release:        2
5 Group:          System/Libraries
6 License:        TO_BE/FILLED_IN
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(capi-location-manager)
10 BuildRequires:  pkgconfig(osp-appfw)
11 BuildRequires:  pkgconfig(osp-uifw)
12 BuildRequires:  osp-appfw-internal-devel
13 BuildRequires:  osp-uifw-internal-devel
14
15 # runtime requires
16 Requires: osp-appfw
17 Requires: osp-uifw
18
19 %description
20 osp locations library
21
22 %package devel
23 Summary:    osp locations library (Development)
24 Group:      TO_BE/FILLED_IN
25 Requires:   %{name} = %{version}-%{release}
26
27 %description devel
28 osp locations library (DEV)
29
30 %package internal-devel
31 Summary:    osp locations library (Internal)
32 Group:      TO_BE/FILLED_IN
33 Requires:   %{name} = %{version}-%{release}
34
35 %description internal-devel
36 osp locations library (Internal-DEV)
37
38 %prep
39 %setup -q
40
41 %build
42 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
43 %ifarch %{ix86}
44 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
45 %else
46 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
47 %endif
48
49 # Call make instruction with smp support
50 make %{?jobs:-j%jobs}
51
52 %install
53 rm -rf %{buildroot}
54 mkdir -p %{buildroot}/usr/share/license
55 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
56
57 %make_install
58
59 %post -p /sbin/ldconfig
60
61 %postun -p /sbin/ldconfig
62
63 %files
64 /usr/share/license/%{name}
65 %{_libdir}/osp/*.so*
66
67 %files devel
68 %{_includedir}/osp/*.h
69 %{_libdir}/pkgconfig/osp-locations.pc
70
71 %files internal-devel