resetting manifest requested domain to floor
[platform/framework/native/loader.git] / packaging / osp-loader.spec
1 Name:           osp-loader
2 Summary:        osp application loader
3 Version:        1.2.1.0
4 Release:        2
5 Group:          TO_BE/FILLED_IN
6 License:        Apache-2.0
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     osp-loader.manifest
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(aul)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(libprivilege-control)
13
14 # runtime requires
15 Requires:       osp-env-config
16
17 %description
18 osp application loader
19
20 %prep
21 %setup -q
22 cp %{SOURCE1001} .
23
24 %build 
25 %ifarch %{ix86} x86_64
26 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" %cmake .
27 %else
28 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" %cmake .
29 %endif
30
31 # Call make instruction with smp support
32 make %{?jobs:-j%jobs}
33
34 %install
35 rm -rf %{buildroot}
36 mkdir -p %{buildroot}/usr/share/license
37 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
38
39 %make_install
40
41 mkdir -p %{buildroot}/opt/usr/apps
42
43 %files
44 %manifest %{name}.manifest
45 /usr/share/license/%{name}
46 %{_libdir}/osp/*
47 /opt/usr/apps
48