merge commits of 2.2.1 to public
[platform/framework/native/image.git] / packaging / osp-image.spec
1 Name:           osp-image
2 Version:        1.2.2.0
3 Release:        1
4 License:        Apache-2.0
5 Summary:        The Media Image library of OSP
6 Group:          Graphics & UI Framework/Libraries
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     %{name}.manifest
9 BuildRequires:  cmake
10 BuildRequires:  osp-appfw-internal-devel
11 BuildRequires:  osp-image-core-internal-devel
12 BuildRequires:  osp-net-internal-devel
13 BuildRequires:  osp-uifw-internal-devel
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(libavcodec)
16 BuildRequires:  pkgconfig(libavformat)
17 BuildRequires:  pkgconfig(libavutil)
18 BuildRequires:  pkgconfig(libcurl)
19 BuildRequires:  pkgconfig(libswscale)
20 BuildRequires:  pkgconfig(libwbxml2)
21 BuildRequires:  pkgconfig(openssl)
22 BuildRequires:  pkgconfig(osp-appfw)
23 BuildRequires:  pkgconfig(osp-image-core)
24 BuildRequires:  pkgconfig(osp-net)
25 BuildRequires:  pkgconfig(osp-uifw)
26
27 # runtime requires
28 Requires:       osp-appfw
29 Requires:       osp-image-core
30 Requires:       osp-net
31 Requires:       osp-uifw
32
33 %description
34 The Media Image library of OSP
35
36 %package devel
37 Summary:        The Media Image library of OSP (Development)
38 Requires:       %{name} = %{version}
39
40 %description devel
41 The Media Image library of OSP (DEV)
42
43 %package internal-devel
44 Summary:        osp media image internel (Internal)
45 Requires:       %{name} = %{version}
46
47 %description internal-devel
48 The Media Image library of OSP (Internal-DEV)
49
50 %prep
51 %setup -q
52 cp %{SOURCE1001} .
53
54 %build
55 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
56 %ifarch %{ix86}
57 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_X86_ -D_OSP_EMUL_" %cmake .  -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=x86
58 %else
59 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_SECURE_LOG -D_OSP_ARMEL_" %cmake . -DOBS=1 -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DARCH=arm
60 %endif
61
62 make %{?_smp_mflags}
63
64 %install
65 %make_install
66
67 %post -p /sbin/ldconfig
68
69 %postun -p /sbin/ldconfig
70
71 %files
72 %manifest osp-image.manifest
73 %{_libdir}/osp/libosp-image.so*
74
75 %files devel
76 %{_includedir}/osp/*.h
77 %{_libdir}/pkgconfig/osp-image.pc
78
79 %files internal-devel
80 %{_includedir}/osp/media/*.h