Update doxygen and license info
[platform/framework/native/face.git] / packaging / osp-face.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:           osp-face
5 Summary:        osp face library
6 Version:        1.2.1.0
7 Release:        2
8 Group:          System/Libraries
9 License:        TO_BE/FILLED_IN
10 Source0:        %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(face-engine)
13 BuildRequires:  pkgconfig(osp-appfw)
14 BuildRequires:  osp-appfw-internal-devel
15 BuildRequires:  pkgconfig(osp-uifw)
16 BuildRequires:  osp-uifw-internal-devel
17
18 Provides:       libface-engine-plugin.so
19
20 # runtime requires
21 Requires: face-engine
22 Requires: osp-appfw 
23 Requires: osp-uifw
24
25 %description
26 osp face library
27
28 %package devel
29 Summary:    osp face library (Development)
30 Group:      TO_BE/FILLED_IN
31 Requires:   %{name} = %{version}-%{release}
32
33 %description devel
34 osp face library (DEV)
35
36 %package debug
37 Summary:    osp face library (Development)
38 Group:      TO_BE/FILLED_IN
39 Requires:   %{name} = %{version}-%{release}
40
41 %description debug
42 osp face library (DEV)
43
44 %prep
45 %setup -q
46
47 %build 
48 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
49
50 %ifarch %{ix86}
51 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
52 %else
53 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
54 %endif
55
56 # Call make instruction with smp support
57 make %{?jobs:-j%jobs}
58
59 %install
60 rm -rf %{buildroot}
61 mkdir -p %{buildroot}/usr/share/license
62 cp %{_builddir}/%{name}-%{version}/LICENSE.Flora  %{buildroot}/usr/share/license/%{name}
63 cat %{_builddir}/%{name}-%{version}/LICENSE.APLv2 >> %{buildroot}/usr/share/license/%{name}
64 %make_install
65
66 %post -p /sbin/ldconfig
67
68 %postun -p /sbin/ldconfig
69
70 %files
71 %manifest osp-face.manifest
72 /usr/share/license/%{name}
73 %{_libdir}/osp/*.so*
74
75 %files devel
76 %{_includedir}/osp/*.h
77 %{_libdir}/pkgconfig/osp-face.pc
78
79 %files debug
80 %{_libdir}/osp/debug/*.so*