2fac2f9b4a7522cfa7b5690b9bb87ee80ec499d2
[platform/framework/native/compat.git] / packaging / osp-compat.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:       osp-compat
5 Summary:    osp-compat library 
6 Version:    1.2.2.0
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Apache License, Version 2.0
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(osp-appfw)
13 BuildRequires:  pkgconfig(osp-net)
14 BuildRequires:  pkgconfig(osp-nfc)
15 BuildRequires:  pkgconfig(osp-social)
16 BuildRequires:  pkgconfig(osp-uifw)
17
18 Provides:       libosp-compat.so.1
19
20 %description
21 osp-compat library
22
23 %package debug
24 Summary:    osp-compat (Development)
25 Group:      TO_BE/FILLED_IN
26 Requires:   %{name} = %{version}-%{release}
27
28 %description debug
29 osp-compat library (DEV)
30
31 %prep
32 %setup -q
33
34 %build
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %ifarch %{ix86}
37 %if 0%{?simulator}
38 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DEMUL=1
39 %else
40 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ " cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DEMUL=1
41 %endif
42 %else
43 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTARGET=1
44 %endif
45
46 # Call make instruction with smp support
47 make %{?jobs:-j%jobs}
48
49 %install
50 rm -rf %{buildroot}
51 mkdir -p %{buildroot}/usr/share/license
52 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
53
54 %make_install
55
56 %post -p /sbin/ldconfig
57
58 %postun -p /sbin/ldconfig
59
60 %files
61 %manifest osp-compat.manifest
62 %defattr(-,root,root,-)
63 /usr/share/license/%{name}
64 %{_libdir}/osp/libosp-compat.so*
65
66 %files debug
67 %{_libdir}/osp/debug/*.so*