Add the check routine of certificate
[platform/framework/native/channel-service.git] / packaging / osp-channel-service.spec
1 Name:           osp-channel-service
2 Summary:        osp channel service
3 Version:        1.2.1.0
4 Release:        2
5 Group:          TO_BE/FILLED_IN
6 License:    Apache License, Version 2.0
7 Source0:        %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(osp-appfw)
11 BuildRequires:  pkgconfig(bundle)
12 BuildRequires:  pkgconfig(dlog)
13 BuildRequires:  pkgconfig(chromium)
14 BuildRequires:  pkgconfig(libsoup-2.4)
15 BuildRequires:  pkgconfig(libssl)
16 BuildRequires:  pkgconfig(libsmack)
17 BuildRequires:  pkgconfig(message-port)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(capi-appfw-package-manager)
20 BuildRequires:  osp-appfw-internal-devel
21
22 # runtime requires
23 Requires: osp-appfw 
24 Requires: osp-installer
25 Requires: osp-app-service
26
27 Requires(post): coreutils
28
29 %description
30 osp channel service
31
32 %prep
33 %setup -q
34
35 %build 
36 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
37 %ifarch %{ix86}
38 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
39 %else
40 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
41 %endif
42
43 # Call make instruction with smp support
44 make %{?jobs:-j%jobs}
45
46 %install
47 rm -rf %{buildroot}
48 mkdir -p %{buildroot}/usr/share/license
49 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
50
51 %make_install
52
53 %post
54
55 /bin/rm -fr /opt/apps/cp7ipabg4k
56
57 /usr/etc/package-manager/backend/tpk -i /usr/apps/cp7ipabg4k
58
59 #%postun -p /sbin/ldconfig
60
61 %files
62 %manifest osp-channel-service.manifest
63 /usr/share/license/%{name}
64 /usr/apps/*