Add to check condition for emulator in spec file
[platform/framework/native/certificate-selector.git] / packaging / apps.CertificateSelector.spec
1 Name:                   apps.CertificateSelector
2 Summary:                The app-control of the certificate manager
3 Version:                1.2.2.0
4 Release:                1
5 Group:                  TO_BE/FILLED_IN
6 License:                Apache License, Version 2.0
7 Source0:                %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(osp-appfw)
10 BuildRequires:  osp-appfw-internal-devel
11 BuildRequires:  pkgconfig(osp-uifw)
12 BuildRequires:  hash-signer
13
14 # smack domain requires
15 Requires(post): osp-security-service
16
17 # runtime requires
18 Requires:               chromium
19 Requires:               pkgmgr
20
21 %description
22 The app-control of the certificate manager
23
24 %prep
25 %setup -q
26
27 %build
28 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
29 %ifarch %{ix86}
30 %if 0%{?simulator}
31 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
32 %else
33 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ " cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
34 %endif
35 %else
36 CXXFLAGS="-O2 -g -pipe -Wall -fno-exceptions -Wformat -Wformat-security -Wl,--as-needed -fmessage-length=0 -march=armv7-a -mtune=cortex-a8 -mlittle-endian -mfpu=neon -mfloat-abi=softfp -D__SOFTFP__ -mthumb -Wa,-mimplicit-it=thumb -funwind-tables -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
37 %endif
38
39 # Call make instruction with smp support
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 mkdir -p %{buildroot}/usr/share/license
45 cp %{_builddir}/%{name}-%{version}/LICENSE.Apache-2.0 %{buildroot}/usr/share/license/%{name}
46
47 %make_install
48 ###### for package signing step ######
49 PKG_ID=hyCsE05ySM
50 %define tizen_sign 1
51 %define tizen_sign_base /usr/apps/${PKG_ID}
52 %define tizen_sign_level platform
53 %define tizen_author_sign 1
54 %define tizen_dist_sign 1
55
56 %post
57 /bin/rm -fr /opt/apps/hyCsE05ySM
58 /usr/etc/package-manager/backend/tpk -i /usr/apps/hyCsE05ySM
59
60 %files
61 %manifest apps.CertificateSelector.manifest
62 %defattr(-,root,root,-)
63 /usr/share/license/%{name}
64 /usr/apps/*