Add dependency on gcov
[platform/core/uifw/vc-webview-js.git] / packaging / vc-webview-js.spec
1 Name:       vc-webview-js
2 Summary:    Web voice touch javascript source
3 Version:    0.0.1
4 Release:    1
5 Group:      Graphics & UI Framework/Voice Framework
6 License:    Flora-1.1
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires:  pkgconfig(libtzplatform-config)
10 BuildRequires:  cmake
11 BuildRequires:  gcov
12
13 %description
14 Javascript source package to run web voice touch function on web application runtime
15
16 %prep
17 %setup -q
18 cp %{SOURCE1001} .
19
20 %build
21 export LDFLAGS+="-Wl,--rpath=%{_libdir} -Wl,--hash-style=both -Wl,--as-needed,-lgcov"
22 rm -rf objdir
23 mkdir objdir
24
25 cd objdir && cmake .. -DVERSION=%{version} \
26     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
27     -DCMAKE_BUILD_TYPE=Debug \
28     -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE
29
30 cd objdir && make %{?jobs:-j%jobs}
31
32 %install
33 (cd objdir &&
34 %make_install)
35
36 %clean
37 rm -rf %{buildroot}
38
39 %post
40
41 %files
42 %license LICENSE
43 %manifest %{name}.manifest
44 %defattr(-,root,root,-)
45 %{TZ_SYS_RO_SHARE}/voice/vc-webview/res/js/*
46 %{TZ_SYS_RO_SHARE}/voice/vc-webview/res/js_custom/*