Merge "Add new language specified script" into tizen_4.0
[platform/core/uifw/vc-webview-js.git] / packaging / vc-webview-js.spec
1 Name:       vc-webview-js
2 Summary:    Web voice touch javascript source
3 Version:    0.0.1
4 Release:    1
5 Group:      Graphics & UI Framework/Voice Framework
6 License:    Flora-1.1
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 BuildRequires:  pkgconfig(libtzplatform-config)
10 BuildRequires:  cmake
11
12 %description
13 Javascript source package to run web voice touch function on web application runtime
14
15 %prep
16 %setup -q
17 cp %{SOURCE1001} .
18
19 %build
20 export LDFLAGS+="-Wl,--rpath=%{_libdir} -Wl,--hash-style=both -Wl,--as-needed,-lgcov"
21 rm -rf objdir
22 mkdir objdir
23
24 cd objdir && cmake .. -DVERSION=%{version} \
25     -DCMAKE_INSTALL_PREFIX=%{_prefix} \
26     -DCMAKE_BUILD_TYPE=Debug \
27     -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE
28
29 cd objdir && make %{?jobs:-j%jobs}
30
31 %install
32 (cd objdir &&
33 %make_install)
34
35 %clean
36 rm -rf %{buildroot}
37
38 %post
39
40 %files
41 %license LICENSE
42 %manifest %{name}.manifest
43 %defattr(-,root,root,-)
44 %{TZ_SYS_RO_SHARE}/voice/vc-webview/res/js/*
45 %{TZ_SYS_RO_SHARE}/voice/vc-webview/res/js_custom/*