13d9a77a9a553ecda2d9b6782d2761f2af910c4b
[platform/core/uifw/stt.git] / packaging / stt.spec
1 Name:       stt
2 Summary:    Speech To Text client library and daemon
3 Version:    0.2.54
4 Release:    1
5 Group:      Graphics & UI Framework/Voice Framework
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: %{name}.manifest
9 Source1002: %{name}-devel.manifest
10 Requires(post): /sbin/ldconfig
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  pkgconfig(aul)
13 BuildRequires:  pkgconfig(capi-base-common)
14 BuildRequires:  pkgconfig(capi-media-audio-io)
15 BuildRequires:  pkgconfig(capi-media-wav-player)
16 BuildRequires:  pkgconfig(capi-system-info)
17 BuildRequires:  pkgconfig(dbus-1)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(ecore)
20 BuildRequires:  pkgconfig(glib-2.0)
21 BuildRequires:  pkgconfig(libtzplatform-config)
22 BuildRequires:  pkgconfig(libxml-2.0)
23 BuildRequires:  pkgconfig(vconf)
24
25 BuildRequires:  cmake
26
27 %description
28 Speech To Text client library and daemon.
29
30
31 %package devel
32 Summary:    Speech To Text header files for STT development
33 Group:      Graphics & UI Framework/Development
34 Requires:   %{name} = %{version}-%{release}
35
36 %package file-devel
37 Summary:    File To Text header files for STT FILE development
38 Group:      Graphics & UI Framework/Development
39 Requires:   %{name} = %{version}-%{release}
40
41 %package setting-devel
42 Summary:    Speech To Text setting header files for STT development
43 Group:      Graphics & UI Framework/Development
44 Requires:   %{name} = %{version}-%{release}
45
46 %package engine-devel
47 Summary:    Speech To Text engine header files for STT development
48 Group:      Graphics & UI Framework/Development
49 Requires:   %{name} = %{version}-%{release}
50
51 %description devel
52 Speech To Text header files for STT development.
53
54 %description file-devel
55 File To Text header files for STT FILE development.
56
57 %description setting-devel
58 Speech To Text setting header files for STT development.
59
60 %description engine-devel
61 Speech To Text engine header files for STT development.
62
63 %prep
64 %setup -q -n %{name}-%{version}
65 cp %{SOURCE1001} %{SOURCE1002} .
66
67
68 %build
69 export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
70 export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
71 export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
72
73 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
74 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
75 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
76
77
78 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DLIBDIR=%{_libdir} -DINCLUDEDIR=%{_includedir} \
79         -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE -DTZ_SYS_BIN=%TZ_SYS_BIN
80 make %{?jobs:-j%jobs}
81
82 %install
83 rm -rf %{buildroot}
84 mkdir -p %{buildroot}%{TZ_SYS_RO_SHARE}/license
85 install LICENSE.APLv2 %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}
86
87 %make_install
88
89 %post 
90 /sbin/ldconfig
91
92 mkdir -p %{_libdir}/voice/
93
94 mkdir -p %{TZ_SYS_RO_SHARE}/voice/test
95
96
97 %postun -p /sbin/ldconfig
98
99 %files
100 %manifest %{name}.manifest
101 %license LICENSE.APLv2
102 %defattr(-,root,root,-)
103 %{_libdir}/lib*.so
104 %{_bindir}/stt-daemon
105 /etc/dbus-1/session.d/stt-server.conf
106 %{TZ_SYS_RO_SHARE}/voice/stt/1.0/stt-config.xml
107 %{TZ_SYS_RO_SHARE}/dbus-1/services/org.tizen.voice*
108 %{TZ_SYS_RO_SHARE}/voice/test/stt-test
109 %{TZ_SYS_RO_SHARE}/license/%{name}
110
111 %files devel
112 %manifest %{name}-devel.manifest
113 %defattr(-,root,root,-)
114 %{_libdir}/pkgconfig/stt.pc
115 %{_includedir}/stt.h
116
117 %files file-devel
118 %defattr(-,root,root,-)
119 %{_libdir}/pkgconfig/stt-file.pc
120 %{_includedir}/stt_file.h
121
122 %files setting-devel
123 %defattr(-,root,root,-)
124 %{_libdir}/pkgconfig/stt-setting.pc
125 %{_includedir}/stt_setting.h
126
127 %files engine-devel
128 %defattr(-,root,root,-)
129 %{_libdir}/pkgconfig/stt-engine.pc
130 %{_includedir}/sttp.h