input: use pepper-xkb api to create/set keymap instead of pepper and xkbcommon apis
[platform/core/uifw/pepper-dali.git] / packaging / pepper-dali.spec
1 Name:       pepper-dali
2 Version:    0.0.15
3 Release:    0
4 Summary:    DALi backend for pepper
5 License:    MIT
6 Group:      Graphics & UI Framework/Wayland Window System
7
8 Source:     %{name}-%{version}.tar.xz
9
10 BuildRequires: pkgconfig(dali-core)
11 BuildRequires: pkgconfig(dali-adaptor)
12 BuildRequires: pkgconfig(dali-adaptor-integration)
13 BuildRequires: pkgconfig(dali-toolkit)
14 BuildRequires: pkgconfig(wayland-server)
15 BuildRequires: pkgconfig(pepper)
16 BuildRequires: pkgconfig(pepper-xkb)
17 BuildRequires: pkgconfig(xdg-shell-server)
18 BuildRequires: pkgconfig(xkbcommon)
19 BuildRequires: pkgconfig(tizen-extension-client)
20 BuildRequires: pkgconfig(ecore)
21 BuildRequires: pkgconfig(ecore-input)
22 BuildRequires: pkgconfig(ecore-wayland)
23 BuildRequires: pkgconfig(wayland-tbm-server)
24 BuildRequires: pkgconfig(wayland-tbm-client)
25 Requires: libwayland-extension-server
26 Requires: pepper-xkb
27
28 %description
29 DALi backend for pepper.
30 Pepper is a lightweight and flexible library for developing various types of wayland compositors.
31
32 ##############################
33 # devel
34 ##############################
35 %package devel
36 Summary:    Development components for pepper-dali
37 Group:      Development/Building
38 Requires:   %{name} = %{version}-%{release}
39
40 %description devel
41 This package includes developer files common to all packages.
42
43 ##############################
44 # Preparation
45 ##############################
46 %prep
47 %setup -q
48
49 ##############################
50 # Build
51 ##############################
52 %build
53 %autogen
54 make %{?_smp_mflags}
55
56 ##############################
57 # Installation
58 ##############################
59 %install
60 %make_install
61
62 ##############################
63 # Files in Binary Packages
64 ##############################
65 %files -n %{name}
66 %manifest pepper-dali.manifest     
67 %defattr(-,root,root,-)
68 %{_libdir}/lib%{name}.so*
69
70 %files devel
71 %defattr(-,root,root,-)
72 %dir %{_includedir}/%{name}/
73 %{_includedir}/%{name}/pepper-dali.h 
74 %{_includedir}/%{name}/public-api/*
75 %{_libdir}/pkgconfig/%{name}.pc
76