use wl_event_loop to support the event handling system
[platform/core/uifw/libtdm.git] / packaging / libtdm.spec
1 Name:           libtdm
2 Version:        1.1.0
3 Release:        0
4 Summary:        User Library of Tizen Display Manager
5 Group:          Development/Libraries
6 License:        MIT
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:         %{name}.manifest
9 BuildRequires:  pkgconfig(pthread-stubs)
10 BuildRequires:  pkgconfig(libtbm)
11 BuildRequires:  pkgconfig(libpng)
12 BuildRequires:  pkgconfig(ttrace)
13 BuildRequires:  pkgconfig(wayland-server)
14
15 %description
16 Common user library of Tizen Display Manager : libtdm front-end library
17
18 %package devel
19 Summary:        Devel of Tizen Display Manager Library
20 Group:          Development/Libraries
21 Requires:       libtdm = %{version}
22 Requires:       pkgconfig(libtbm)
23
24 %description devel
25 This supports frontend & backend library header and so
26
27 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33 %build
34 %reconfigure --disable-static \
35              CFLAGS="${CFLAGS} -Wall -Werror" \
36              LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
37 make %{?_smp_mflags}
38
39 %install
40 rm -rf %{buildroot}
41 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
42 cp -af COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
43 %make_install
44
45 %remove_docs
46
47 %post -p /sbin/ldconfig
48 %postun -p /sbin/ldconfig
49
50
51 %files
52 %manifest %{name}.manifest
53 %defattr(-,root,root,-)
54 %{TZ_SYS_RO_SHARE}/license/%{name}
55 %{_libdir}/libtdm.so.*
56
57 %files devel
58 %manifest %{name}.manifest
59 %defattr(-,root,root,-)
60 %{_includedir}/*
61 %{_libdir}/pkgconfig/*
62 %{_libdir}/libtdm.so
63
64 %changelog