Remove clipboard feature
[platform/core/uifw/ise-default.git] / packaging / ise-default.spec
1 Name:       ise-default
2 Summary:    Tizen keyboard
3 Version:    1.10.8
4 Release:    1
5 Group:      Graphics & UI Framework/Input
6 License:    Apache-2.0
7 Source0:    ise-default-%{version}.tar.gz
8 BuildRequires:  gettext-tools
9 BuildRequires:  edje-bin
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(elementary)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(libscl-ui)
15 BuildRequires:  pkgconfig(ecore-imf)
16 BuildRequires:  pkgconfig(libxml-2.0)
17 BuildRequires:  pkgconfig(efl-extension)
18 BuildRequires:  pkgconfig(libtzplatform-config)
19 BuildRequires:  pkgconfig(stt)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-appfw-preference)
22 BuildRequires:  pkgconfig(capi-appfw-package-manager)
23 BuildRequires:  pkgconfig(capi-media-sound-manager)
24 BuildRequires:  pkgconfig(capi-ui-inputmethod)
25 BuildRequires:  pkgconfig(smartreply)
26 BuildRequires:  pkgconfig(key-manager)
27 BuildRequires:  pkgconfig(ode)
28 BuildRequires:  pkgconfig(capi-system-system-settings)
29 BuildRequires:  pkgconfig(glib-2.0)
30 BuildRequires:  pkgconfig(dbus-1)
31 BuildRequires:  pkgconfig(gio-2.0)
32 BuildRequires:  pkgconfig(pkgmgr-info)
33 BuildRequires:  pkgconfig(capi-ui-sticker-consumer)
34 BuildRequires:  pkgconfig(capi-content-mime-type)
35 BuildRequires:  pkgconfig(json-glib-1.0)
36 BuildRequires:  pkgconfig(bundle)
37 BuildRequires:  pkgconfig(rpc-port)
38 BuildRequires:  pkgconfig(capi-appfw-event)
39 BuildRequires:  pkgconfig(notification)
40 Requires:       ise-engine-glm
41 Requires:       ise-engine-default
42
43 # This is for old profile-based OBS project optimizations.
44 # In 4.0 unified build env, this if statement is always true.
45 Requires:       %{name}-compat = %{version}-%{release}
46 # This is for old profile-based OBS project optimizations.
47 # In 4.0 unified build env, this if statement is always true.
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
49 Recommends:     %{name}-profile_common = %{version}-%{release}
50 %endif
51
52 %description
53 Description: Tizen keyboard
54
55
56 # This is for old profile-based OBS project optimizations.
57 # In 4.0 unified build env, this if statement is always true.
58 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
59 %package profile_common
60 Summary:    ise-default binaries and resources without flavors
61 Provides:   %{name}-compat = %{version}-%{release}
62 Conflicts:  %{name}-profile_mobile
63 Conflicts:  %{name}-profile_tv
64 Conflicts:  %{name}-profile_wearable
65 Conflicts:  %{name}-profile_ivi
66 %description profile_common
67 Tizen keyboard (ise-default) binaries and resources without flavors, intended
68 to support common profiles, which does not supply any additional options
69 for the build.
70 %endif
71
72 # This is for old profile-based OBS project optimizations.
73 # In 4.0 unified build env, this if statement is always true.
74 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
75 %package profile_mobile
76 Summary:    ise-default binaries and resources with mobile profile
77 Provides:   %{name}-compat = %{version}-%{release}
78 Conflicts:  %{name}-profile_common
79 Conflicts:  %{name}-profile_tv
80 Conflicts:  %{name}-profile_wearable
81 Conflicts:  %{name}-profile_ivi
82 %description profile_mobile
83 Tizen keyboard (ise-default) binaries and resources with mobile options.
84 This is intended to support mobile profiles.
85 %endif
86
87 # This is for old profile-based OBS project optimizations.
88 # In 4.0 unified build env, this if statement is always true.
89 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
90 %package profile_tv
91 Summary:    ise-default binaries and resources with tv profile
92 Provides:   %{name}-compat = %{version}-%{release}
93 Conflicts:  %{name}-profile_common
94 Conflicts:  %{name}-profile_mobile
95 Conflicts:  %{name}-profile_wearable
96 Conflicts:  %{name}-profile_ivi
97 %description profile_tv
98 Tizen keyboard (ise-default) binaries and resources with tv options.
99 This is intended to support tv profiles.
100 %endif
101
102 # This is for old profile-based OBS project optimizations.
103 # In 4.0 unified build env, this if statement is always true.
104 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv"
105 %package profile_ivi
106 Summary:    ise-default binaries and resources with ivi profile
107 Provides:   %{name}-compat = %{version}-%{release}
108 Conflicts:  %{name}-profile_common
109 Conflicts:  %{name}-profile_mobile
110 Conflicts:  %{name}-profile_wearable
111 Conflicts:  %{name}-profile_tv
112 %description profile_ivi
113 Tizen keyboard (ise-default) binaries and resources with ivi options.
114 This is intended to support ivi profiles.
115 %endif
116
117 # This is for old profile-based OBS project optimizations.
118 # In 4.0 unified build env, this if statement is always true.
119 # Common is blocked because wearable has extra efl-ext entries, which will be
120 # removed for unified build env later.
121 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
122 %package profile_wearable
123 Summary:    Meta package of ise-default for wearable profiles. (circle/rectangle)
124 Provides:   %{name}-compat = %{version}-%{release}
125 Conflicts:  %{name}-profile_common
126 Conflicts:  %{name}-profile_mobile
127 Conflicts:  %{name}-profile_tv
128 Conflicts:  %{name}-profile_ivi
129 Requires:   %{name}-profile_wearable-extension = %{version}-%{release}
130 Recommends: %{name}-profile_wearable-extension-circle = %{version}-%{release}
131 %description profile_wearable
132 Meta package of Tizen keyboard (ise-default) binaries and resources with
133 wearable options.
134
135 %package profile_wearable-extension-circle
136 Summary:    ise-default binaries and resources with wearable profile (circle)
137 Provides:   %{name}-profile_wearable-extension = %{version}-%{release}
138 Conflicts:  %{name}-profile_wearable-extension-rectangle
139 %description profile_wearable-extension-circle
140 Tizen keyboard (ise-default) binaries and resources with wearable options.
141 This is intended to support wearable profiles with circle display.
142
143 %package profile_wearable-extension-rectangle
144 Summary:    ise-default binaries and resources with wearable profile (rectangle)
145 Provides:   %{name}-profile_wearable-extension = %{version}-%{release}
146 Conflicts:  %{name}-profile_wearable-extension-circle
147 %description profile_wearable-extension-rectangle
148 Tizen keyboard (ise-default) binaries and resources with wearable options.
149 This is intended to support wearable profiles with rectangle display.
150 %endif
151
152 %package -n ise-default-config
153 Summary: ISE config file
154 BuildArch: noarch
155 Requires: %{name} = %{version}-%{release}
156
157 %description -n ise-default-config
158 ISE configuration file for default setting
159
160 %prep
161 %setup -q
162
163
164 %build
165 export CFLAGS_BASE="${CFLAGS} -DTIZEN_DEBUG_ENABLE -fvisibility=hidden"
166 export CXXFLAGS_BASE="${CXXFLAGS} -DTIZEN_DEBUG_ENABLE -std=c++11 -fvisibility-inlines-hidden -fvisibility=hidden"
167 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
168
169 export LD_LIBRARY_PATH=%{TZ_SYS_RO_APP}/ise-default/lib
170
171 rm -rf CMakeFiles
172 rm -rf CMakeCache.txt
173
174 # This is for old profile-based OBS project optimizations.
175 # In 4.0 unified build env, this if statement is always true.
176 # Common is blocked because wearable has extra efl-ext entries, which will be
177 # removed for unified build env later.
178 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
179 mkdir -p build_wearable_rec
180 pushd build_wearable_rec
181 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE";
182 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE";
183 %cmake .. -DTARGET=wearable \
184          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
185          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
186
187 make %{?jobs:-j%jobs}
188 popd
189
190 mkdir -p build_wearable_cir
191 pushd build_wearable_cir
192 export CFLAGS="${CFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
193 export CXXFLAGS="${CXXFLAGS_BASE} -D_WEARABLE -D_CIRCLE";
194 %cmake .. -DTARGET=wearable \
195          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
196          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
197
198 make %{?jobs:-j%jobs}
199 popd
200 %endif
201
202
203 # This is for old profile-based OBS project optimizations.
204 # In 4.0 unified build env, this if statement is always true.
205 %if "%{?profile}" != "tv" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
206 mkdir -p build_mobile
207 pushd build_mobile
208 export CFLAGS="${CFLAGS_BASE} -D_MOBILE";
209 export CXXFLAGS="${CXXFLAGS_BASE} -D_MOBILE";
210 %cmake .. -DTARGET=mobile \
211          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
212          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
213          -Dwith_cbhm=TRUE
214
215 make %{?jobs:-j%jobs}
216 popd
217 %endif
218
219 # This is for old profile-based OBS project optimizations.
220 # In 4.0 unified build env, this if statement is always true.
221 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
222 mkdir -p build_tv
223 pushd build_tv
224 export CFLAGS="${CFLAGS_BASE} -D_TV";
225 export CXXFLAGS="${CXXFLAGS_BASE} -D_TV";
226 %cmake .. -DTARGET=tv \
227          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
228          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
229
230 make %{?jobs:-j%jobs}
231 popd
232 %endif
233
234 # This is for old profile-based OBS project optimizations.
235 # In 4.0 unified build env, this if statement is always true.
236 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
237 mkdir -p build_ivi
238 pushd build_ivi
239 export CFLAGS="${CFLAGS_BASE} -D_IVI";
240 export CXXFLAGS="${CXXFLAGS_BASE} -D_IVI";
241 %cmake .. -DTARGET=ivi \
242          -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
243          -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES
244
245 make %{?jobs:-j%jobs}
246 popd
247 %endif
248
249 # This is for old profile-based OBS project optimizations.
250 # In 4.0 unified build env, this if statement is always true.
251 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
252 export CFLAGS="${CFLAGS_BASE} -D_COMMON";
253 export CXXFLAGS="${CXXFLAGS_BASE} -D_COMMON";
254 %cmake . -DTARGET=common \
255         -DTZ_SYS_RO_APP=%TZ_SYS_RO_APP \
256         -DTZ_SYS_RO_PACKAGES=%TZ_SYS_RO_PACKAGES \
257         -Dwith_cbhm=TRUE
258
259 make %{?jobs:-j%jobs}
260 %endif
261
262 %install
263 rm -rf %{buildroot}
264
265 %make_install
266 %__mkdir_p %{buildroot}%{_sysconfdir}/ise/conf
267 %__cp ise-default-config/config/* %{buildroot}%{_sysconfdir}/ise/conf
268
269 # This is for old profile-based OBS project optimizations.
270 # In 4.0 unified build env, this if statement is always true.
271 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
272 %make_install
273 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/common
274 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
275 mv bin common/
276 mkdir -p common/res
277 pushd res
278 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../common/res/; fi; done
279 popd
280 popd
281 %endif
282
283 # This is for old profile-based OBS project optimizations.
284 # In 4.0 unified build env, this if statement is always true.
285 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
286 pushd build_mobile
287 %make_install
288 popd
289 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/mobile
290 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
291 mv bin mobile/
292 mkdir -p mobile/res
293 pushd res
294 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../mobile/res/; fi; done
295 popd
296 popd
297 %endif
298
299 # This is for old profile-based OBS project optimizations.
300 # In 4.0 unified build env, this if statement is always true.
301 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
302 pushd build_tv
303 %make_install
304 popd
305 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/tv
306 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
307 mv bin tv/
308 mkdir -p tv/res
309 pushd res
310 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../tv/res/; fi; done
311 popd
312 popd
313 %endif
314
315 # This is for old profile-based OBS project optimizations.
316 # In 4.0 unified build env, this if statement is always true.
317 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
318 pushd build_ivi
319 %make_install
320 popd
321 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/ivi
322 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
323 mv bin ivi/
324 mkdir -p ivi/res
325 pushd res
326 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../ivi/res/; fi; done
327 popd
328 popd
329 %endif
330
331 # This is for old profile-based OBS project optimizations.
332 # In 4.0 unified build env, this if statement is always true.
333 # Common is blocked because wearable has extra efl-ext entries, which will be
334 # removed for unified build env later.
335 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
336 pushd build_wearable_cir
337 %make_install
338 popd
339 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-circle
340 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
341 mv bin wearable-circle/
342 mkdir -p wearable-circle/res
343 pushd res
344 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-circle/res/; fi; done
345 popd
346 popd
347
348 pushd build_wearable_rec
349 %make_install
350 popd
351 mkdir -p %{buildroot}%{TZ_SYS_RO_APP}/ise-default/wearable-rectangle
352 pushd %{buildroot}%{TZ_SYS_RO_APP}/ise-default/
353 mv bin wearable-rectangle/
354 mkdir -p wearable-rectangle/res
355 pushd res
356 for FILE in *; do if [[ $FILE =~ ^locale$ ]]; then echo skip commonly used "${FILE}"; else mv "${FILE}" ../wearable-rectangle/res/; fi; done
357 popd
358 popd
359 %endif
360
361 %find_lang %{name}
362
363 %files -f %{name}.lang
364 %manifest %{name}.manifest
365 %defattr(-,root,root,-)
366 %{TZ_SYS_RO_PACKAGES}/%{name}.xml
367 %ifarch %{arm} aarch64
368 %{TZ_SYS_RO_APP}/ise-default/lib/*
369 %endif
370 %license LICENSE
371
372 # This is for old profile-based OBS project optimizations.
373 # In 4.0 unified build env, this if statement is always true.
374 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi"
375 %post profile_common
376 pushd %{TZ_SYS_RO_APP}/ise-default/common/
377 mkdir -p ../res
378 mkdir -p ../bin
379 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
380 if [ "$1" = "2" ]; then
381     rm -Rf ../bin/*
382     pushd ../res
383     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
384     popd
385 fi
386 for FILE in bin/*; do ln -sf "../common/${FILE}" ../bin; done
387 for FILE in res/*; do ln -sf "../common/${FILE}" ../res; done
388 popd
389 %preun profile_common
390 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
391 if [ "$1" = "0" ]; then
392     pushd %{TZ_SYS_RO_APP}/ise-default
393     rm -Rf bin
394     pushd res
395     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
396     popd
397     popd
398 fi
399 %files profile_common
400 %manifest %{name}.manifest
401 %defattr(-,root,root,-)
402 %{TZ_SYS_RO_APP}/ise-default/common/*
403 %endif
404
405
406 # This is for old profile-based OBS project optimizations.
407 # In 4.0 unified build env, this if statement is always true.
408 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
409 %post profile_mobile
410 pushd %{TZ_SYS_RO_APP}/ise-default/mobile/
411 mkdir -p ../res
412 mkdir -p ../bin
413 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
414 if [ "$1" = "2" ]; then
415     rm -Rf ../bin/*
416     pushd ../res
417     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
418     popd
419 fi
420 for FILE in bin/*; do ln -sf "../mobile/${FILE}" ../bin; done
421 for FILE in res/*; do ln -sf "../mobile/${FILE}" ../res; done
422 popd
423 %preun profile_mobile
424 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
425 if [ "$1" = "0" ]; then
426     pushd %{TZ_SYS_RO_APP}/ise-default
427     rm -Rf bin
428     pushd res
429     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
430     popd
431     popd
432 fi
433 %files profile_mobile
434 %manifest %{name}.manifest
435 %defattr(-,root,root,-)
436 %{TZ_SYS_RO_APP}/ise-default/mobile/*
437 %endif
438
439
440 # This is for old profile-based OBS project optimizations.
441 # In 4.0 unified build env, this if statement is always true.
442 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
443 %post profile_tv
444 pushd %{TZ_SYS_RO_APP}/ise-default/tv/
445 mkdir -p ../res
446 mkdir -p ../bin
447 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
448 if [ "$1" = "2" ]; then
449     rm -Rf ../bin/*
450     pushd ../res
451     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
452     popd
453 fi
454 for FILE in bin/*; do ln -sf "../tv/${FILE}" ../bin; done
455 for FILE in res/*; do ln -sf "../tv/${FILE}" ../res; done
456 popd
457 %preun profile_tv
458 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
459 if [ "$1" = "0" ]; then
460     pushd %{TZ_SYS_RO_APP}/ise-default
461     rm -Rf bin
462     pushd res
463     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
464     popd
465     popd
466 fi
467 %files profile_tv
468 %manifest %{name}.manifest
469 %defattr(-,root,root,-)
470 %{TZ_SYS_RO_APP}/ise-default/tv/*
471 %endif
472
473
474 # This is for old profile-based OBS project optimizations.
475 # In 4.0 unified build env, this if statement is always true.
476 %if "%{?profile}" != "mobile" && "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common"
477 %post profile_ivi
478 pushd %{TZ_SYS_RO_APP}/ise-default/ivi/
479 mkdir -p ../res
480 mkdir -p ../bin
481 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
482 if [ "$1" = "2" ]; then
483     rm -Rf ../bin/*
484     pushd ../res
485     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
486     popd
487 fi
488 for FILE in bin/*; do ln -sf "../ivi/${FILE}" ../bin; done
489 for FILE in res/*; do ln -sf "../ivi/${FILE}" ../res; done
490 popd
491 %preun profile_ivi
492 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
493 if [ "$1" = "0" ]; then
494     pushd %{TZ_SYS_RO_APP}/ise-default
495     rm -Rf bin
496     pushd res
497     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
498     popd
499     popd
500 fi
501 %files profile_ivi
502 %manifest %{name}.manifest
503 %defattr(-,root,root,-)
504 %{TZ_SYS_RO_APP}/ise-default/ivi/*
505 %endif
506
507
508 # This is for old profile-based OBS project optimizations.
509 # In 4.0 unified build env, this if statement is always true.
510 # Common is blocked because wearable has extra efl-ext entries, which will be
511 # removed for unified build env later.
512 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "ivi"
513 %files profile_wearable
514
515 %post profile_wearable-extension-circle
516 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-circle/
517 mkdir -p ../res
518 mkdir -p ../bin
519 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
520 if [ "$1" = "2" ]; then
521     rm -Rf ../bin/*
522     pushd ../res
523     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
524     popd
525 fi
526 for FILE in bin/*; do ln -sf "../wearable-circle/${FILE}" ../bin; done
527 for FILE in res/*; do ln -sf "../wearable-circle/${FILE}" ../res; done
528 popd
529 %preun profile_wearable-extension-circle
530 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
531 if [ "$1" = "0" ]; then
532     pushd %{TZ_SYS_RO_APP}/ise-default
533     rm -Rf bin
534     pushd res
535     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
536     popd
537     popd
538 fi
539 %files profile_wearable-extension-circle
540 %manifest %{name}.manifest
541 %defattr(-,root,root,-)
542 %{TZ_SYS_RO_APP}/ise-default/wearable-circle/*
543
544
545 %post profile_wearable-extension-rectangle
546 pushd %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/
547 mkdir -p ../res
548 mkdir -p ../bin
549 # If we are upgrading this package, remove existing files before copying (1:install / 2:upgrade)
550 if [ "$1" = "2" ]; then
551     rm -Rf ../bin/*
552     pushd ../res
553     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
554     popd
555 fi
556 for FILE in bin/*; do ln -sf "../wearable-rectangle/${FILE}" ../bin; done
557 for FILE in res/*; do ln -sf "../wearable-rectangle/${FILE}" ../res; done
558 popd
559 %preun profile_wearable-extension-rectangle
560 # Perform file removal only when uninstalling (0:uninstall / 1:upgrade)
561 if [ "$1" = "0" ]; then
562     pushd %{TZ_SYS_RO_APP}/ise-default
563     rm -Rf bin
564     pushd res
565     for FILE in *; do if [[ $FILE =~ locale$ ]]; then echo skip "${FILE}"; else rm -Rf "${FILE}"; fi; done
566     popd
567     popd
568 fi
569 %files profile_wearable-extension-rectangle
570 %manifest %{name}.manifest
571 %defattr(-,root,root,-)
572 %{TZ_SYS_RO_APP}/ise-default/wearable-rectangle/*
573 %endif
574
575 %files -n ise-default-config
576 %manifest ise-default-config/ise-default-config.manifest
577 %{_sysconfdir}/ise/conf/*
578 %license LICENSE