Update package version to 0.1.160927
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
1 Name: org.tizen.inputdelegator
2 Summary: Input Delegator Application
3 Version: 0.1.160927
4 Release: 1
5 Group: Applications
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8
9 %define enable_log_manager 1
10
11 BuildRequires:  pkgconfig(ecore-wayland)
12 BuildRequires:  pkgconfig(ecore)
13 BuildRequires:  pkgconfig(evas)
14 BuildRequires:  pkgconfig(edje)
15 BuildRequires:  pkgconfig(edbus)
16
17 BuildRequires: cmake
18 BuildRequires: edje-bin
19 BuildRequires: gettext
20
21 BuildRequires: pkgconfig(dlog)
22 BuildRequires: pkgconfig(capi-appfw-application)
23 BuildRequires: pkgconfig(capi-media-wav-player)
24 BuildRequires: pkgconfig(capi-system-device)
25 BuildRequires: pkgconfig(eina)
26 BuildRequires: pkgconfig(elementary)
27 BuildRequires: pkgconfig(efl-extension)
28 BuildRequires: pkgconfig(feedback)
29 BuildRequires: pkgconfig(stt)
30 BuildRequires: pkgconfig(vconf)
31 BuildRequires: pkgconfig(db-util)
32 BuildRequires: pkgconfig(sqlite3)
33
34
35 %if %{enable_log_manager}
36 BuildRequires:  pkgconfig(bundle)
37 %endif
38
39 %if "%{?profile}" == "mobile"
40 ExcludeArch: %{arm} aarch64 %ix86 x86_64
41 %endif
42
43 %if "%{?profile}" == "tv"
44 ExcludeArch: %{arm} aarch64 %ix86 x86_64
45 %endif
46
47 %if "%{?profile}" == "common"
48 ExcludeArch: %{arm} aarch64 %ix86 x86_64
49 %endif
50
51 %if "%{?profile}" == "ivi"
52 ExcludeArch: %{arm} aarch64 %ix86 x86_64
53 %endif
54
55 %define _appdir         /usr/apps
56 %define _app_destdir    %{_appdir}/%{name}
57
58 # Sandboxed prefix '/'
59 %define _app_prefix     /
60 %define _app_localedir %{_app_prefix}res/locale
61
62 %description
63 Input Delegator Application for Wearable environment
64
65 %prep
66 %setup -q
67
68 %build
69 %if 0%{?sec_build_binary_debug_enable}
70 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
71 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
72 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
73 %endif
74
75 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"
76
77
78 cmake . -DCMAKE_INSTALL_PREFIX=%{_app_prefix} \
79         -DCMAKE_INSTALL_LOCALEDIR=%{_app_localedir} \
80         -DENABLE_LOG_MANAGER=%{enable_log_manager}
81
82 # compile warning & error filtering
83 make %{?jobs:-j%jobs} \
84   2>&1 | sed \
85   -e 's%^.*: error: .*$%\x1b[1;31;40m&\x1b[m%' \
86   -e 's%^.*: warning: .*$%\x1b[1;33;40m&\x1b[m%'
87
88 %install
89 rm -rf %{buildroot}
90 make install DESTDIR=%{buildroot}%{_app_destdir}
91
92 mkdir -p %{buildroot}%{_datadir}/packages/
93 cp -rf org.tizen.inputdelegator.xml %{buildroot}%{_datadir}/packages
94
95 %post
96 #nothing
97
98 /usr/bin/vconftool -u 5000 set -t int db/private/ise/stt/language "0" -f -s tizen::vconf::platform::rw
99
100 %files
101 %manifest org.tizen.inputdelegator.manifest
102 %defattr(-,root,root,-)
103 %license LICENSE
104 %{_datadir}/packages/org.tizen.inputdelegator.xml
105 %{_app_destdir}%{_app_prefix}/bin/inputdelegator
106 %{_app_destdir}%{_app_prefix}/res/edje/w-input-selector.edj
107 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt.edj
108 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt-button.edj
109 %{_app_destdir}%{_app_prefix}/res/images/*
110 %{_app_destdir}%{_app_prefix}/shared/res/w-input-selector.png
111 %{_app_destdir}%{_app_localedir}/*/LC_MESSAGES/org.tizen.inputdelegator.mo