8465a4bb5afb6af98089f84aa3ad142e34cca9e9
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
1 Name: org.tizen.inputdelegator
2 Summary: Input Delegator Application
3 Version: 0.1.170407
4 Release: 1
5 Group: Applications
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8
9 %define enable_log_manager 1
10
11 BuildRequires:  pkgconfig(ecore)
12 BuildRequires:  pkgconfig(evas)
13 BuildRequires:  pkgconfig(edje)
14
15 BuildRequires: cmake
16 BuildRequires: edje-bin
17 BuildRequires: gettext-tools
18
19 BuildRequires: pkgconfig(dlog)
20 BuildRequires: pkgconfig(capi-appfw-application)
21 BuildRequires: pkgconfig(capi-media-wav-player)
22 BuildRequires: pkgconfig(capi-system-device)
23 BuildRequires: pkgconfig(eina)
24 BuildRequires: pkgconfig(elementary)
25 BuildRequires: pkgconfig(efl-extension)
26 BuildRequires: pkgconfig(feedback)
27 BuildRequires: pkgconfig(stt)
28 BuildRequires: pkgconfig(vconf)
29 BuildRequires: pkgconfig(capi-media-audio-io)
30
31
32 %if %{enable_log_manager}
33 BuildRequires:  pkgconfig(bundle)
34 %endif
35
36 %if "%{?profile}" == "mobile"
37 ExcludeArch: %{arm} aarch64 %ix86 x86_64
38 %endif
39
40 %if "%{?profile}" == "tv"
41 ExcludeArch: %{arm} aarch64 %ix86 x86_64
42 %endif
43
44 %if "%{?profile}" == "common"
45 ExcludeArch: %{arm} aarch64 %ix86 x86_64
46 %endif
47
48 %if "%{?profile}" == "ivi"
49 ExcludeArch: %{arm} aarch64 %ix86 x86_64
50 %endif
51
52 %define _appdir         /usr/apps
53 %define _app_destdir    %{_appdir}/%{name}
54
55 # Sandboxed prefix '/'
56 %define _app_prefix     /
57 %define _app_localedir %{_app_prefix}res/locale
58
59 %description
60 Input Delegator Application for Wearable environment
61
62 %prep
63 %setup -q
64
65 %build
66 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden"
67 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden -fvisibility-inlines-hidden"
68 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
69
70 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"
71
72
73 cmake . -DCMAKE_INSTALL_PREFIX=%{_app_prefix} \
74         -DCMAKE_INSTALL_LOCALEDIR=%{_app_localedir} \
75         -DENABLE_LOG_MANAGER=%{enable_log_manager}
76
77 # compile warning & error filtering
78 make %{?jobs:-j%jobs} \
79   2>&1 | sed \
80   -e 's%^.*: error: .*$%\x1b[1;31;40m&\x1b[m%' \
81   -e 's%^.*: warning: .*$%\x1b[1;33;40m&\x1b[m%'
82
83 %install
84 rm -rf %{buildroot}
85 make install DESTDIR=%{buildroot}%{_app_destdir}
86
87 mkdir -p %{buildroot}%{_datadir}/packages/
88 cp -rf org.tizen.inputdelegator.xml %{buildroot}%{_datadir}/packages
89
90 %post
91 #nothing
92
93 /usr/bin/vconftool -u 5000 set -t int db/private/ise/stt/language "0" -f -s tizen::vconf::platform::rw
94
95 %files
96 %manifest org.tizen.inputdelegator.manifest
97 %defattr(-,root,root,-)
98 %license LICENSE
99 %{_datadir}/packages/org.tizen.inputdelegator.xml
100 %{_app_destdir}%{_app_prefix}/bin/inputdelegator
101 %{_app_destdir}%{_app_prefix}/res/edje/w-input-selector.edj
102 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt.edj
103 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt-button.edj
104 %{_app_destdir}%{_app_prefix}/res/images/*
105 %{_app_destdir}%{_app_prefix}/shared/res/w-input-selector.png
106 %{_app_destdir}%{_app_localedir}/*/LC_MESSAGES/org.tizen.inputdelegator.mo