Update package version to 0.1.170419
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
1 # For the backward compatibility, this is to be built for
2 # wearable profile or 4.0 unified building environment.
3 # This cannot be built for non-wearable in conventional 3.0 build environment.
4 # Note that it is not a good idea to limit building with ExcludeArch because there are new architectures being tested.
5 # Use ExclusiveArch istead.
6 %if "%{?profile}" == "mobile" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "common"
7 ExclusiveArch:  none
8 %endif
9
10 Name: org.tizen.inputdelegator
11 Summary: Input Delegator Application
12 Version: 0.1.170419
13 Release: 1
14 Group: Applications
15 License: Apache-2.0
16 Source0: %{name}-%{version}.tar.gz
17
18 %define enable_log_manager 1
19
20 BuildRequires:  pkgconfig(ecore)
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(edje)
23
24 BuildRequires: cmake
25 BuildRequires: edje-bin
26 BuildRequires: gettext-tools
27
28 BuildRequires: pkgconfig(dlog)
29 BuildRequires: pkgconfig(capi-appfw-application)
30 BuildRequires: pkgconfig(capi-appfw-app-control)
31 BuildRequires: pkgconfig(capi-appfw-preference)
32 BuildRequires: pkgconfig(capi-media-wav-player)
33 BuildRequires: pkgconfig(capi-system-device)
34 BuildRequires: pkgconfig(eina)
35 BuildRequires: pkgconfig(elementary)
36 BuildRequires: pkgconfig(efl-extension)
37 BuildRequires: pkgconfig(feedback)
38 BuildRequires: pkgconfig(stt)
39 BuildRequires: pkgconfig(vconf)
40 BuildRequires: pkgconfig(db-util)
41 BuildRequires: pkgconfig(sqlite3)
42 BuildRequires: pkgconfig(capi-media-audio-io)
43 BuildRequires: pkgconfig(smartreply)
44 BuildRequires: pkgconfig(capi-system-info)
45
46 %if %{enable_log_manager}
47 BuildRequires:  pkgconfig(bundle)
48 %endif
49
50 %define _appdir         /usr/apps
51 %define _app_destdir    %{_appdir}/%{name}
52
53 # Sandboxed prefix '/'
54 %define _app_prefix     /
55 %define _app_localedir %{_app_prefix}res/locale
56
57 %description
58 Input Delegator Application for Wearable environment
59
60 %prep
61 %setup -q
62
63 %build
64 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden"
65 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden -fvisibility-inlines-hidden"
66 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
67
68 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"
69
70
71 cmake . -DCMAKE_INSTALL_PREFIX=%{_app_prefix} \
72         -DCMAKE_INSTALL_LOCALEDIR=%{_app_localedir} \
73         -DENABLE_LOG_MANAGER=%{enable_log_manager}
74
75 # compile warning & error filtering
76 make %{?jobs:-j%jobs} \
77   2>&1 | sed \
78   -e 's%^.*: error: .*$%\x1b[1;31;40m&\x1b[m%' \
79   -e 's%^.*: warning: .*$%\x1b[1;33;40m&\x1b[m%'
80
81 %install
82 rm -rf %{buildroot}
83 make install DESTDIR=%{buildroot}%{_app_destdir}
84
85 mkdir -p %{buildroot}%{_datadir}/packages/
86 cp -rf org.tizen.inputdelegator.xml %{buildroot}%{_datadir}/packages
87
88 %post
89 #nothing
90
91 /usr/bin/vconftool -u 5000 set -t int db/private/ise/stt/language "0" -f -s tizen::vconf::platform::rw
92
93 %files
94 %manifest org.tizen.inputdelegator.manifest
95 %defattr(-,root,root,-)
96 %license LICENSE
97 %{_datadir}/packages/org.tizen.inputdelegator.xml
98 %{_app_destdir}%{_app_prefix}/bin/inputdelegator
99 %{_app_destdir}%{_app_prefix}/res/edje/w-input-selector.edj
100 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt.edj
101 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt-button.edj
102 %{_app_destdir}%{_app_prefix}/res/images/*
103 %{_app_destdir}%{_app_prefix}/shared/res/w-input-selector.png
104 %{_app_destdir}%{_app_localedir}/*/LC_MESSAGES/org.tizen.inputdelegator.mo