Fix build error when Werror option is on
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
1 Name: org.tizen.inputdelegator
2 Summary: Input Delegator Application
3 Version: 0.1.161122
4 Release: 1
5 Group: Applications
6 License: Apache-2.0
7 Source0: %{name}-%{version}.tar.gz
8
9 %define enable_log_manager 1
10
11 BuildRequires:  pkgconfig(ecore-wayland)
12 BuildRequires:  pkgconfig(ecore)
13 BuildRequires:  pkgconfig(evas)
14 BuildRequires:  pkgconfig(edje)
15 BuildRequires:  pkgconfig(edbus)
16
17 BuildRequires: cmake
18 BuildRequires: edje-bin
19 BuildRequires: gettext
20
21 BuildRequires: pkgconfig(dlog)
22 BuildRequires: pkgconfig(capi-appfw-application)
23 BuildRequires: pkgconfig(capi-media-wav-player)
24 BuildRequires: pkgconfig(capi-system-device)
25 BuildRequires: pkgconfig(eina)
26 BuildRequires: pkgconfig(elementary)
27 BuildRequires: pkgconfig(efl-extension)
28 BuildRequires: pkgconfig(feedback)
29 BuildRequires: pkgconfig(stt)
30 BuildRequires: pkgconfig(vconf)
31 BuildRequires: pkgconfig(db-util)
32 BuildRequires: pkgconfig(sqlite3)
33 BuildRequires: pkgconfig(capi-media-audio-io)
34
35
36 %if %{enable_log_manager}
37 BuildRequires:  pkgconfig(bundle)
38 %endif
39
40 %if "%{?profile}" == "mobile"
41 ExcludeArch: %{arm} aarch64 %ix86 x86_64
42 %endif
43
44 %if "%{?profile}" == "tv"
45 ExcludeArch: %{arm} aarch64 %ix86 x86_64
46 %endif
47
48 %if "%{?profile}" == "common"
49 ExcludeArch: %{arm} aarch64 %ix86 x86_64
50 %endif
51
52 %if "%{?profile}" == "ivi"
53 ExcludeArch: %{arm} aarch64 %ix86 x86_64
54 %endif
55
56 %define _appdir         /usr/apps
57 %define _app_destdir    %{_appdir}/%{name}
58
59 # Sandboxed prefix '/'
60 %define _app_prefix     /
61 %define _app_localedir %{_app_prefix}res/locale
62
63 %description
64 Input Delegator Application for Wearable environment
65
66 %prep
67 %setup -q
68
69 %build
70 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
71 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
72 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
73
74 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"
75
76
77 cmake . -DCMAKE_INSTALL_PREFIX=%{_app_prefix} \
78         -DCMAKE_INSTALL_LOCALEDIR=%{_app_localedir} \
79         -DENABLE_LOG_MANAGER=%{enable_log_manager}
80
81 # compile warning & error filtering
82 make %{?jobs:-j%jobs} \
83   2>&1 | sed \
84   -e 's%^.*: error: .*$%\x1b[1;31;40m&\x1b[m%' \
85   -e 's%^.*: warning: .*$%\x1b[1;33;40m&\x1b[m%'
86
87 %install
88 rm -rf %{buildroot}
89 make install DESTDIR=%{buildroot}%{_app_destdir}
90
91 mkdir -p %{buildroot}%{_datadir}/packages/
92 cp -rf org.tizen.inputdelegator.xml %{buildroot}%{_datadir}/packages
93
94 %post
95 #nothing
96
97 /usr/bin/vconftool -u 5000 set -t int db/private/ise/stt/language "0" -f -s tizen::vconf::platform::rw
98
99 %files
100 %manifest org.tizen.inputdelegator.manifest
101 %defattr(-,root,root,-)
102 %license LICENSE
103 %{_datadir}/packages/org.tizen.inputdelegator.xml
104 %{_app_destdir}%{_app_prefix}/bin/inputdelegator
105 %{_app_destdir}%{_app_prefix}/res/edje/w-input-selector.edj
106 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt.edj
107 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt-button.edj
108 %{_app_destdir}%{_app_prefix}/res/images/*
109 %{_app_destdir}%{_app_prefix}/shared/res/w-input-selector.png
110 %{_app_destdir}%{_app_localedir}/*/LC_MESSAGES/org.tizen.inputdelegator.mo