2d8f27954cdeb69d0d6b4a96f37f209f8e4c161b
[platform/core/uifw/inputdelegator.git] / packaging / org.tizen.inputdelegator.spec
1 # For the backward compatibility, this is to be built for
2 # wearable profile or 4.0 unified building environment.
3 # This cannot be built for non-wearable in conventional 3.0 build environment.
4 # Note that it is not a good idea to limit building with ExcludeArch because there are new architectures being tested.
5 # Use ExclusiveArch istead.
6 %if "%{?profile}" == "mobile" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "common"
7 ExclusiveArch:  none
8 %endif
9
10 Name: org.tizen.inputdelegator
11 Summary: Input Delegator Application
12 Version: 0.1.170316
13 Release: 1
14 Group: Applications
15 License: Apache-2.0
16 Source0: %{name}-%{version}.tar.gz
17
18 %define enable_log_manager 1
19
20 BuildRequires:  pkgconfig(ecore-wayland)
21 BuildRequires:  pkgconfig(ecore)
22 BuildRequires:  pkgconfig(evas)
23 BuildRequires:  pkgconfig(edje)
24 BuildRequires:  pkgconfig(edbus)
25
26 BuildRequires: cmake
27 BuildRequires: edje-bin
28 BuildRequires: gettext-tools
29
30 BuildRequires: pkgconfig(dlog)
31 BuildRequires: pkgconfig(capi-appfw-application)
32 BuildRequires: pkgconfig(capi-appfw-app-control)
33 BuildRequires: pkgconfig(capi-appfw-preference)
34 BuildRequires: pkgconfig(capi-media-wav-player)
35 BuildRequires: pkgconfig(capi-system-device)
36 BuildRequires: pkgconfig(eina)
37 BuildRequires: pkgconfig(elementary)
38 BuildRequires: pkgconfig(efl-extension)
39 BuildRequires: pkgconfig(feedback)
40 BuildRequires: pkgconfig(stt)
41 BuildRequires: pkgconfig(vconf)
42 BuildRequires: pkgconfig(db-util)
43 BuildRequires: pkgconfig(sqlite3)
44 BuildRequires: pkgconfig(capi-media-audio-io)
45 BuildRequires: pkgconfig(smartreply)
46 BuildRequires: pkgconfig(capi-system-info)
47
48 %if %{enable_log_manager}
49 BuildRequires:  pkgconfig(bundle)
50 %endif
51
52 %define _appdir         /usr/apps
53 %define _app_destdir    %{_appdir}/%{name}
54
55 # Sandboxed prefix '/'
56 %define _app_prefix     /
57 %define _app_localedir %{_app_prefix}res/locale
58
59 %description
60 Input Delegator Application for Wearable environment
61
62 %prep
63 %setup -q
64
65 %build
66 export CFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden"
67 export CXXFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror -fvisibility=hidden -fvisibility-inlines-hidden"
68 export FFLAGS+=" -DTIZEN_DEBUG_ENABLE -Werror"
69
70 export CXXFLAGS="$CXXFLAGS -std=gnu++0x"
71
72
73 cmake . -DCMAKE_INSTALL_PREFIX=%{_app_prefix} \
74         -DCMAKE_INSTALL_LOCALEDIR=%{_app_localedir} \
75         -DENABLE_LOG_MANAGER=%{enable_log_manager}
76
77 # compile warning & error filtering
78 make %{?jobs:-j%jobs} \
79   2>&1 | sed \
80   -e 's%^.*: error: .*$%\x1b[1;31;40m&\x1b[m%' \
81   -e 's%^.*: warning: .*$%\x1b[1;33;40m&\x1b[m%'
82
83 %install
84 rm -rf %{buildroot}
85 make install DESTDIR=%{buildroot}%{_app_destdir}
86
87 mkdir -p %{buildroot}%{_datadir}/packages/
88 cp -rf org.tizen.inputdelegator.xml %{buildroot}%{_datadir}/packages
89
90 %post
91 #nothing
92
93 /usr/bin/vconftool -u 5000 set -t int db/private/ise/stt/language "0" -f -s tizen::vconf::platform::rw
94
95 %files
96 %manifest org.tizen.inputdelegator.manifest
97 %defattr(-,root,root,-)
98 %license LICENSE
99 %{_datadir}/packages/org.tizen.inputdelegator.xml
100 %{_app_destdir}%{_app_prefix}/bin/inputdelegator
101 %{_app_destdir}%{_app_prefix}/res/edje/w-input-selector.edj
102 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt.edj
103 %{_app_destdir}%{_app_prefix}/res/edje/w-input-stt-button.edj
104 %{_app_destdir}%{_app_prefix}/res/images/*
105 %{_app_destdir}%{_app_prefix}/shared/res/w-input-selector.png
106 %{_app_destdir}%{_app_localedir}/*/LC_MESSAGES/org.tizen.inputdelegator.mo