6890823804e17e2128fceef4e9ee3e86ada264e1
[platform/core/uifw/e17.git] / packaging / e17.spec
1 Name:       e17
2 Summary:    The Enlightenment window manager
3 Version:    1.0.0.001+svn.76808slp2+build47
4 Release:    2
5 Group:      System/GUI/Other
6 License:    BSD
7 URL:        http://www.enlightenment.org/
8 Source0:    %{name}-%{version}.tar.gz
9 Source2:    packaging/e17.service
10 Source3:    packaging/e17_early.service
11 Source1001: e17.manifest
12 Source1002: e17-data.manifest
13 BuildRequires:  pkgconfig(alsa)
14 BuildRequires:  pkgconfig(ecore)
15 BuildRequires:  pkgconfig(ecore-con)
16 BuildRequires:  pkgconfig(ecore-evas)
17 BuildRequires:  pkgconfig(ecore-fb)
18 BuildRequires:  pkgconfig(ecore-file)
19 BuildRequires:  pkgconfig(ecore-imf)
20 BuildRequires:  pkgconfig(ecore-imf-evas)
21 BuildRequires:  pkgconfig(ecore-input)
22 BuildRequires:  pkgconfig(ecore-input-evas)
23 BuildRequires:  pkgconfig(ecore-ipc)
24 BuildRequires:  pkgconfig(ecore-x)
25 BuildRequires:  pkgconfig(edbus)
26 BuildRequires:  pkgconfig(elementary)
27 BuildRequires:  pkgconfig(edje)
28 BuildRequires:  pkgconfig(eet)
29 BuildRequires:  pkgconfig(efreet)
30 BuildRequires:  pkgconfig(efreet-mime)
31 BuildRequires:  pkgconfig(efreet-trash)
32 BuildRequires:  pkgconfig(ehal)
33 BuildRequires:  pkgconfig(eina)
34 BuildRequires:  pkgconfig(evas)
35 BuildRequires:  pkgconfig(eio)
36 BuildRequires:  pkgconfig(utilX)
37 BuildRequires:  pkgconfig(x11)
38 BuildRequires:  pkgconfig(xext)
39 BuildRequires:  pkgconfig(dlog)
40 BuildRequires:  edje-bin
41 BuildRequires:  embryo-bin
42 BuildRequires:  eet-bin
43 BuildRequires:  gettext-devel
44
45
46 %description
47 The Enlightenment DR17 Window Manager Enlightenment is an advanced window manager for X11. Unique
48  features include: a fully animated background, nice drop shadows
49  around windows, backed by an extremely clean and optimized
50  foundation of APIs.
51  .
52  This package contains the core files for Enlightenment DR17.
53
54
55
56 %package devel
57 Summary:    The Enlightenment window mgr (devel)
58 Group:      Development/Libraries
59 Requires:   %{name} = %{version}-%{release}
60
61 %description devel
62 The Enlightenment window manager (devel)
63
64 %package data
65 Summary:    The Enlightenment window mgr (data)
66 Group:      Development/Libraries
67 Requires:   %{name} = %{version}-%{release}
68
69 %description data
70 The Enlightenment window manager (data)
71
72
73 %prep
74 %setup -q
75
76
77 %build
78
79 cp %{SOURCE1001} .
80 cp %{SOURCE1002} .
81
82 %autogen --disable-static
83 LIBS='-ledbus' ./configure --prefix=/usr --disable-static \
84     --disable-temperature \
85     --disable-mixer \
86     --disable-everything \
87     --disable-dropshadow \
88     --disable-pager \
89     --disable-battery \
90     --disable-cpufreq \
91     --disable-start \
92     --disable-exebuf \
93     --disable-winlist \
94     --disable-fileman \
95     --disable-fileman-opinfo \
96     --disable-wizard \
97     --disable-conf \
98     --disable-conf-wallpaper \
99     --disable-conf-wallpaper2 \
100     --disable-conf-colors \
101     --disable-conf-fonts \
102     --disable-conf-borders \
103     --disable-conf-icon-theme \
104     --disable-conf-mouse-cursor \
105     --disable-conf-transitions \
106     --disable-conf-startup \
107     --disable-conf-intl \
108     --disable-conf-imc \
109     --disable-conf-profiles \
110     --disable-msgbus-lang \
111     --disable-conf-engine \
112     --disable-conf-desks \
113     --disable-conf-desk \
114     --disable-conf-display \
115     --disable-conf-desklock \
116     --disable-conf-screensaver \
117     --disable-conf-dpms \
118     --disable-conf-shelves \
119     --disable-conf-shelves \
120     --disable-conf-keybindings \
121     --disable-conf-mousebindings \
122     --disable-conf-edgebindings \
123     --disable-conf-mouse \
124     --disable-conf-window-display \
125     --disable-conf-window-focus \
126     --disable-conf-window-remembers \
127     --disable-conf-window-manipulation \
128     --disable-conf-menus \
129     --disable-conf-clientlist \
130     --disable-conf-dialogs \
131     --disable-conf-performance \
132     --disable-conf-winlist \
133     --disable-conf-exebuf \
134     --disable-conf-paths \
135     --disable-conf-mime \
136     --disable-conf-interaction \
137     --disable-conf-scale \
138     --disable-mixel \
139     --disable-connman \
140     --disable-illume \
141     --disable-syscon \
142     --disable-bluez \
143     --disable-ofono \
144     --disable-msgbus \
145     --disable-systray \
146     --disable-conf_acpibindings \
147     --disable-everything-apps \
148     --disable-everything-aspell \
149     --disable-everything-calc \
150     --disable-everything-files \
151     --disable-everything-settings \
152     --disable-everything-windows \
153     --disable-illume-bluetooth \
154     --disable-illume-home \
155     --disable-illume-toggle \
156     --disable-illume-indicator \
157     --disable-illume-kbd-toggle \
158     --disable-illume-keyboard \
159     --disable-illume-mode-toggle \
160     --disable-illume-softkey \
161     --disable-comp \
162     --disable-illume2 \
163     --disable-conf_randr \
164     --disable-tasks \
165     --disable-backlight \
166     --disable-shot \
167     --disable-notification \
168     --disable-quickaccess \
169     --disable-tiling \
170     --disable-xkbswitch \
171     --disable-access \
172     --enable-extra-features
173
174 make %{?jobs:-j%jobs}
175
176 %install
177 %make_install
178
179
180 #systemd setup
181 mkdir -p %{buildroot}/usr/lib/systemd/user/core-efl.target.wants
182 install -m 0644 %SOURCE2 %{buildroot}/usr/lib/systemd/user/
183 ln -s ../e17.service %{buildroot}/usr/lib/systemd/user/core-efl.target.wants/e17.service
184 install -m 0644 %SOURCE3 %{buildroot}/usr/lib/systemd/user/
185 ln -s ../e17_early.service %{buildroot}/usr/lib/systemd/user/core-efl.target.wants/e17_early.service
186 rm -rf %{buildroot}/usr/etc/xdg/*
187 rm -rf %{buildroot}/usr/lib/enlightenment/utils/*
188 rm -rf %{buildroot}/usr/share/enlightenment/AUTHORS
189 rm -rf %{buildroot}/usr/share/enlightenment/COPYING
190 rm -rf %{buildroot}/usr/share/enlightenment/data/backgrounds/*
191 rm -rf %{buildroot}/usr/share/enlightenment/data/config/*
192 rm -rf %{buildroot}/usr/share/enlightenment/data/icons/*
193 rm -rf %{buildroot}/usr/share/enlightenment/data/images/enlightenment.png
194 rm -rf %{buildroot}/usr/share/enlightenment/data/input_methods/*
195 rm -rf %{buildroot}/usr/share/locale/*
196 rm -rf %{buildroot}/usr/share/xsessions/*
197 rm -rf %{buildroot}/usr/share/applications/enlightenment_filemanager.desktop
198 rm -rf %{buildroot}/usr/share/enlightenment/data/flags/*
199 rm -rf %{buildroot}/usr/share/enlightenment/data/favorites/*
200 rm -rf %{buildroot}/usr/share/enlightenment/data/favorites/.order
201
202 %files
203 %manifest e17.manifest
204 %license COPYING
205 %defattr(-,root,root,-)
206 /usr/bin/enlightenment
207 /usr/bin/enlightenment_imc
208 /usr/bin/enlightenment_remote
209 /usr/bin/enlightenment_start
210 /usr/bin/enlightenment_filemanager
211 /usr/bin/enlightenment_open
212 /usr/lib/enlightenment/modules
213 /usr/lib/enlightenment/preload/*
214 %config /usr/etc/enlightenment/sysactions.conf
215 /usr/lib/systemd/user/e17.service
216 /usr/lib/systemd/user/core-efl.target.wants/e17.service
217 /usr/lib/systemd/user/e17_early.service
218 /usr/lib/systemd/user/core-efl.target.wants/e17_early.service
219
220 %files devel
221 %defattr(-,root,root,-)
222 /usr/lib/pkgconfig/enlightenment.pc
223 /usr/include/enlightenment/*.h
224
225 %files data
226 %manifest e17-data.manifest
227 %defattr(-,root,root,-)
228 /usr/share/enlightenment/data/themes
229
230 /usr/share/enlightenment/data/images/test.edj
231 /usr/share/enlightenment/data/images/test.png
232 /usr/share/enlightenment/data/images/test.svg
233 /usr/share/enlightenment/data/images/test.jpg