resetting manifest requested domain to floor
[platform/core/uifw/e17-extra-config-modules.git] / packaging / e17-extra-config-modules.spec
1 Name:           e17-extra-config-modules
2 Summary:        The E17 Extra Config Modules
3 Version:        0.1.28
4 Release:        1
5 Group:          Graphical desktop/Enlightenment
6 License:        BSD
7 Source0:        %{name}-%{version}.tar.gz
8 Source1001:     e17-extra-config-modules.manifest
9 BuildRequires:  pkgconfig(enlightenment)
10 BuildRequires:  pkgconfig(utilX)
11 BuildRequires:  pkgconfig(elementary)
12 BuildRequires:  pkgconfig(dlog)
13 Requires:       libX11
14
15
16 %description
17 The E17 Extra Config Modules  The E17 extra config modules consists of modules made by SAMSUNG.
18
19
20 %prep
21 %setup -q
22 cp %{SOURCE1001} .
23
24
25 %build
26 export CFLAGS+=" -Wall -g -fPIC -rdynamic"
27 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
28
29 %ifarch %{arm}
30 export CFLAGS+=" -D_ENV_ARM"
31 %endif
32
33 for FILE in config-tizen
34 do
35         (cd $FILE && ./autogen.sh && ./configure --prefix=/usr && make )
36 done
37
38
39 %install
40 rm -rf %{buildroot}
41 mkdir -p %{buildroot}/usr/share/license
42 cp %{_builddir}/%{buildsubdir}/LICENSE %{buildroot}/usr/share/license/%{name}
43
44 for FILE in config-tizen
45 do
46         (cd $FILE && %make_install )
47 done
48
49
50 %files
51 %manifest %{name}.manifest
52 %defattr(-,root,root,-)
53 %{_libdir}/enlightenment/modules/config-tizen/*
54 /usr/share/license/%{name}
55 %manifest %{name}.manifest